ubuntu/+source/icu:ubuntu/intrepid

Last commit made on 2008-06-09
Get this branch:
git clone -b ubuntu/intrepid https://git.launchpad.net/ubuntu/+source/icu
Members of Ubuntu Server Dev import team can upload to this branch. Log in for directions.

Branch merges

Branch information

Name:
ubuntu/intrepid
Repository:
lp:ubuntu/+source/icu

Recent commits

88f763e... by Jay Berkenbilt <email address hidden> on 2008-06-07

Import patches-unapplied version 3.8.1-2 to ubuntu/intrepid

Imported using git-ubuntu import.

Changelog parent: 472a33ee91dfc7e15d7b9bb64c29290a1a7b49a0

New changelog entries:
  * Patch from Harshula to fix split conjuncts problem in
    Sinhala. (Closes: #483563)
  * Force structures to be padded at byte boundaries (rather than 32-bit
    boundaries) on arm. (Closes: #484138)
  * Update doc-base section.

472a33e... by Jay Berkenbilt <email address hidden> on 2008-02-12

Import patches-unapplied version 3.8.1-1 to ubuntu/intrepid

Imported using git-ubuntu import.

Changelog parent: 81cfad4e55976b9d2b87d712b745e49918b1a613

New changelog entries:
  * New upstream release
  * Patch to support GNU/kFreeBSD. Thanks Aurelien Jarno. (Closes: #
    461782)

81cfad4... by Jay Berkenbilt <email address hidden> on 2008-02-07

Import patches-unapplied version 3.8-6 to ubuntu/hardy

Imported using git-ubuntu import.

Changelog parent: a34356095bdd7d42d9d68a206a3ea2013302244d

New changelog entries:
  * Add debian/patches/00-cve-2007-4770-4771.patch created from with
    svn diff -c 23292 \
    http://source.icu-project.org/repos/icu/icu/branches/maint/maint-3-8
    to address the following security vulnerablilities:
     - CVE-2007-4770: reference to non-existent capture group may
       cause access to invalid memory
     - CVE-2007-4771: buffer overflow in regexcmp.cpp
    (Closes: #463688)
  * Updated standards version to 3.7.3: no changes required.

a343560... by Jay Berkenbilt <email address hidden> on 2007-12-01

Import patches-unapplied version 3.8-5 to ubuntu/hardy

Imported using git-ubuntu import.

Changelog parent: 138a57dcfdc238c0b54ee2474765ad7b0b13980f

New changelog entries:
  * Filter out extraneous dependencies among different versions of the
    library packages. (Closes: #451767, 451978)
  * Include changes from 3.6-10.

138a57d... by Jay Berkenbilt <email address hidden> on 2007-11-18

Import patches-unapplied version 3.6-10 to ubuntu/hardy

Imported using git-ubuntu import.

Changelog parent: a3db2a3feb3192974ede9daf430bf19c6db5c977

New changelog entries:
  * It appears that amd64 requires 32-bit libraries to be in
    /emul/ia32-linux/usr/lib instead of /usr/lib32. Following zlib's
    example of moving them around for amd64 only. (Closes: #451495)
  * Yet another 32-bit library fix. Files were installed in /32 because
    of the debian/tmp32 thing. How did this ever work? (Closes: #451495)

a3db2a3... by Jay Berkenbilt <email address hidden> on 2007-11-07

Import patches-unapplied version 3.6-8 to ubuntu/hardy

Imported using git-ubuntu import.

Changelog parent: 2dab83fec73a37a710f1c34fe7847f9673299f5c

New changelog entries:
  * Clean up 32-bit library patch to avoid excessive and unnecessary runs
    of configure. (Closes: #447771)
  * make setBreakType public in rbbi.h; needed by OpenOffice.org. This
    patch is included in OpenOffice.org's internal ICU. Including it here
    allows OpenOffice.org to continue to use this ICU package. Thanks
    Rene Engelhard. (Closes: #448745)
  * Rename debian/watch.not-yet to debian/no-watch so it won't get picked
    up even though it's not supposed to. ICU's ftp site uses a structure
    that isn't supported by uscan. (Closes: #449701)

2dab83f... by Jay Berkenbilt <email address hidden> on 2007-10-20

Import patches-unapplied version 3.6-7 to ubuntu/hardy

Imported using git-ubuntu import.

Changelog parent: ac8af1075efca15830f54ec109f951eb2cdaf715

New changelog entries:
  * Fix bug in which 32-bit library installs were overwriting files for
    64-bit libraries on amd64. Thanks Robert Millan for the patch.
    (Closes: #447275).
  * Oops: fixed one more problem with 32-bit builds on a 64-bit platform.
    Thanks Aaron Ucko. (Closes: #398778)
  * Add additional Build-Depends for 64-bit platforms. Thanks Robert
    Millan. (Closes: #398778)
  * Accepted patch from Robert Millan (with very slight, mostly cosmetic
    modifications) to build 32-bit libraries on 64-bit architectures.
    Many thanks to Robert Millan for supplying this patch! (Closes:
    #398778)

ac8af10... by Jay Berkenbilt <email address hidden> on 2007-07-10

Import patches-unapplied version 3.6-3 to ubuntu/gutsy

Imported using git-ubuntu import.

Changelog parent: dcdb2463dfdfe0c8dabcaff9c591ab9380cdc1de

New changelog entries:
  * Include patch from Samuel Thibault to allow icu to build on gnu hurd.
    (Closes: #414446)

dcdb246... by Jay Berkenbilt <email address hidden> on 2006-11-28

Import patches-unapplied version 3.6-2 to ubuntu/feisty

Imported using git-ubuntu import.

Changelog parent: c84a3131aa04ef01db2dbe80ee63db6ada4038dc

New changelog entries:
  * Include patch to fix error in IndicClassTables to fix
    worstCaseExpansion for Sinhala. Thanks to Harshula for forwarding
    this.
  * New upstream release
  * Provide libicu34-dev since ICU 3.6 provides backward compatible
    interfaces in addition to new ones.
  * New upstream release.
  * Remove special optimization hack to work around now-fixed m68k build
    problems. (Closes: #360743)
  * Update standards version. No changes required.
  * Upstream re-released 3.4.1 without changing the version number because
    the header file with 3.4.1 still said it was 3.4. Unfortunately, the
    debian 3.4.1 package had already been uploaded. This "3.4.1a" release
    now matches upstream's 3.4.1.
  * New upstream release
  * Build with g++ 4.0 with -fno-strict-aliasing to work around g++ 4.0
    bugs that impact ICU. Future versions should work properly with the
    latest g++ without any special flags. (Closes: #342970)
  * Enable static libraries.

c84a313... by Jay Berkenbilt <email address hidden> on 2005-11-19

Import patches-unapplied version 3.4-3 to ubuntu/dapper

Imported using git-ubuntu import.

Changelog parent: b70b2b6a36b5af269d9a9f04f33fc1f496992dc2

New changelog entries:
  * Explicitly build with g++ 3.4. The current ICU fails its test suite
    with 4.0 but not with 3.4. Future versions should work properly with
    4.0.
  * Remove some extraneous build steps that may cause problems with
    autobuilders.
  * New upstream release
  * Completely new packaging
  * New maintainer as per discussion with Ivo.
  * g++ 4.0 transition: libicu21c102 is now libicu21c2.
  * Accepted changes from NMU below for now. This change will be
    reversed soon when icu is updated to the current upstream version.
    The icu28 package will also be removed at that time, as per discussion
    with the icu28 maintainer. Closes: #301316
  * Add shlibs files
  * Rename icu-doc to icu21-doc. icu-doc is built by the icu28 package.