ubuntu/+source/icu:ubuntu/feisty

Last commit made on 2007-03-05
Get this branch:
git clone -b ubuntu/feisty https://git.launchpad.net/ubuntu/+source/icu
Members of Ubuntu Server Dev import team can upload to this branch. Log in for directions.

Branch merges

Branch information

Name:
ubuntu/feisty
Repository:
lp:ubuntu/+source/icu

Recent commits

b8f2ece... by Matthias Klose on 2007-03-05

Import patches-unapplied version 3.6-2build1 to ubuntu/feisty

Imported using git-ubuntu import.

Changelog parent: dcdb2463dfdfe0c8dabcaff9c591ab9380cdc1de

New changelog entries:
  * Rebuild for changes in the amd64 toolchain.

dcdb246... by Jay Berkenbilt <email address hidden> on 2006-11-28

Import patches-unapplied version 3.6-2 to ubuntu/feisty

Imported using git-ubuntu import.

Changelog parent: c84a3131aa04ef01db2dbe80ee63db6ada4038dc

New changelog entries:
  * Include patch to fix error in IndicClassTables to fix
    worstCaseExpansion for Sinhala. Thanks to Harshula for forwarding
    this.
  * New upstream release
  * Provide libicu34-dev since ICU 3.6 provides backward compatible
    interfaces in addition to new ones.
  * New upstream release.
  * Remove special optimization hack to work around now-fixed m68k build
    problems. (Closes: #360743)
  * Update standards version. No changes required.
  * Upstream re-released 3.4.1 without changing the version number because
    the header file with 3.4.1 still said it was 3.4. Unfortunately, the
    debian 3.4.1 package had already been uploaded. This "3.4.1a" release
    now matches upstream's 3.4.1.
  * New upstream release
  * Build with g++ 4.0 with -fno-strict-aliasing to work around g++ 4.0
    bugs that impact ICU. Future versions should work properly with the
    latest g++ without any special flags. (Closes: #342970)
  * Enable static libraries.

c84a313... by Jay Berkenbilt <email address hidden> on 2005-11-19

Import patches-unapplied version 3.4-3 to ubuntu/dapper

Imported using git-ubuntu import.

Changelog parent: b70b2b6a36b5af269d9a9f04f33fc1f496992dc2

New changelog entries:
  * Explicitly build with g++ 3.4. The current ICU fails its test suite
    with 4.0 but not with 3.4. Future versions should work properly with
    4.0.
  * Remove some extraneous build steps that may cause problems with
    autobuilders.
  * New upstream release
  * Completely new packaging
  * New maintainer as per discussion with Ivo.
  * g++ 4.0 transition: libicu21c102 is now libicu21c2.
  * Accepted changes from NMU below for now. This change will be
    reversed soon when icu is updated to the current upstream version.
    The icu28 package will also be removed at that time, as per discussion
    with the icu28 maintainer. Closes: #301316
  * Add shlibs files
  * Rename icu-doc to icu21-doc. icu-doc is built by the icu28 package.

b70b2b6... by Ivo Timmermans <email address hidden> on 2004-01-18

Import patches-unapplied version 2.1-2 to ubuntu/warty

Imported using git-ubuntu import.