ubuntu/+source/icu:applied/ubuntu/trusty-devel

Last commit made on 2018-03-28
Get this branch:
git clone -b applied/ubuntu/trusty-devel https://git.launchpad.net/ubuntu/+source/icu
Members of Ubuntu Server Dev import team can upload to this branch. Log in for directions.

Branch merges

Branch information

Name:
applied/ubuntu/trusty-devel
Repository:
lp:ubuntu/+source/icu

Recent commits

89cc880... by Marc Deslauriers on 2018-03-27

Import patches-applied version 52.1-3ubuntu0.8 to applied/ubuntu/trusty-security

Imported using git-ubuntu import.

Changelog parent: af678570aa6090e16c9abbaa59ed30a166ac7d67
Unapplied parent: 5f7f912023657c745d75d29877603e589379bc47

New changelog entries:
  * SECURITY UPDATE: integer overflow in Persian Cal
    - debian/patches/CVE-2017-15422.patch: use int64_t math for one
      operation to avoid overflow, add tests in source/i18n/gregoimp.cpp,
      source/i18n/gregoimp.h, source/i18n/persncal.cpp,
      source/test/intltest/calregts.cpp, source/test/intltest/calregts.h.
    - CVE-2017-15422

5f7f912... by Marc Deslauriers on 2018-03-27

fix integer overflow in Persian Cal

Gbp-Pq: CVE-2017-15422.patch.

07c10fa... by Marc Deslauriers on 2018-03-27

Fixes double free

Gbp-Pq: CVE-2017-14952.patch.

d94daa9... by Marc Deslauriers on 2018-03-27

fix out-of-bounds write in common/utext.cpp

Gbp-Pq: CVE-2017-786x.patch.

f5aa2a8... by Marc Deslauriers on 2018-03-27

CVE-2016-7415.patch

No DEP3 Subject or Description header found

Gbp-Pq: CVE-2016-7415.patch.

cc1449b... by Marc Deslauriers on 2018-03-27

CVE-2016-6293.patch

No DEP3 Subject or Description header found

Gbp-Pq: CVE-2016-6293.patch.

33599ce... by Marc Deslauriers on 2018-03-27

Arrange font actions

Gbp-Pq: CVE-2016-0494.patch.

87fe4d6... by Marc Deslauriers on 2018-03-27

backport of CVE-2015-4844 patch from JDK

Gbp-Pq: CVE-2015-4844.patch.

0314082... by Marc Deslauriers on 2018-03-27

CVE-2014-9911.patch

No DEP3 Subject or Description header found

Gbp-Pq: CVE-2014-9911.patch.

cb5192d... by Marc Deslauriers on 2018-03-27

fix denial of service and possible code execution via overflows

Gbp-Pq: CVE-2015-4760.patch.