ubuntu/+source/ibus-pinyin:ubuntu/trusty-proposed

Last commit made on 2014-02-27
Get this branch:
git clone -b ubuntu/trusty-proposed https://git.launchpad.net/ubuntu/+source/ibus-pinyin
Members of Ubuntu Server Dev import team can upload to this branch. Log in for directions.

Branch merges

Branch information

Name:
ubuntu/trusty-proposed
Repository:
lp:ubuntu/+source/ibus-pinyin

Recent commits

bbabbfd... by Aron Xu on 2014-02-27

Import patches-unapplied version 1.5.0-1ubuntu1 to ubuntu/trusty-proposed

Imported using git-ubuntu import.

Changelog parent: aa1ca7c66eb74cbeeb9378040b25f8c64e2d39d7

New changelog entries:
  * Merge with Debian, changes (LP: #1220985):
    - debian/patches/ibus-pinyin-fixes-lua-compile.patch:
      Update patch to really fix build with lua 5.2.
    - debian/patches/lua52.diff:
      Use lua5.2 by default.
    - debian/control: Build-Depends on liblua5.2-dev.

aa1ca7c... by osamu on 2014-01-26

Import patches-unapplied version 1.5.0-1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 300e056d3bcbdeadf4d1a5190e835319864fd933

New changelog entries:
  * New upstream release
  * Update policy to 3.9.5 and compat to 9.
  * Add --with autoreconf. Closes: #727267
  * Add dependency to python-ibus, python-xdg.
    Closes: #735495, #734350, #734351
  * harden debian/rules.
  * Multi-Arch enabled.
  * Use libpyzy-1.0-0 and make this single binary package.
  * Sync with ibus-pinyin-1.5.0-5.fc19.src.rpm
    - Fixes lua 5.2 compile by Peng Wu
      (This is build with lua 5.1 since autoconf lose lua 5.2)
    - Fixes ibus: visible password entry flaw. (rhbz#1027029)
      (CVE-2013-4509) by Peng Wu

300e056... by osamu on 2013-06-18

Import patches-unapplied version 1.4.0-2 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 352b8ce6895072749260e3443e75702ae0334ace

New changelog entries:
  * Fix libexecdir to match ibus-setup expectation.
    Closes: #712580

352b8ce... by osamu on 2011-12-22

Import patches-unapplied version 1.4.0-1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 52e96efa429cd2b04294c39b9749995d6cc42167

New changelog entries:
  * New upstream release

52e96ef... by osamu on 2011-12-21

Import patches-unapplied version 1.3.99.20110706-2 to debian/sid

Imported using git-ubuntu import.

Changelog parent: f1edc5598d2505a5af225ae3bb57bba4841ab041

New changelog entries:
  * Install missing files. Closes: #646341
  * Remove useless lintian override file.
  * Use dh_link to make symlink properly.
  * Clean data/db/android/*.pyc for clean rebuild.

f1edc55... by Asias He on 2011-07-24

Import patches-unapplied version 1.3.99.20110706-1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 6beca2660e4fa7fdb5372cf6c85572b7a3f92e3b

New changelog entries:
  * New upstream release
  * Use dh in debian/rules
  * Bump standards version to 3.9.2
  * Set VCS to git.debian.org
  * Set DM-Upload-Allowed to yes
  * Set X-Python-Version to >= 2.5
  * Add debian/*.install files
  * Fix "Switch to dh_python2" (Closes: #635029)
  * Fix "Please enable GBK support or mention in document" (Closes: #535578)

6beca26... by LI Daobing on 2010-09-08

Import patches-unapplied version 1.3.11-1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: a5cea3c662f4410158beefe1de9221bd866b8606

New changelog entries:
  [ Asias He ]
  * New upstream release.

a5cea3c... by LI Daobing on 2010-08-09

Import patches-unapplied version 1.3.10-1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 3d6657acd7cc1a7b6b8b212d65499ccb93af5b26

New changelog entries:
  [ Asias He ]
  * New upstream release (closes: #590356).
  * debian/control:
    - bump standards version to 3.9.1
  [ LI Daobing ]
  * debian/control:
    - build depends on libopencc-dev (>= 0.1.0).

3d6657a... by LI Daobing on 2010-07-16

Import patches-unapplied version 1.3.9-1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: bb2e84b31450843a5645316fa0739c64afb5cfb7

New changelog entries:
  * New upstream release.
  * debian/control:
    - bump standards version to 3.9.0
    - add build depends on liblua5.1-0-dev, libopencc-dev
  * debian/rules: enable opencc.

bb2e84b... by LI Daobing on 2010-05-30

Import patches-unapplied version 1.3.8-1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 7bb43db753a3f03bfa91f994f950bdb565b53c9b

New changelog entries:
  [ Asias He ]
  * New upstream release.
  * debian/control:
    - add Asias He <email address hidden> to Uploaders.