ubuntu/+source/hplip:ubuntu/wily

Last commit made on 2015-09-18
Get this branch:
git clone -b ubuntu/wily https://git.launchpad.net/ubuntu/+source/hplip
Members of Ubuntu Server Dev import team can upload to this branch. Log in for directions.

Branch merges

Branch information

Name:
ubuntu/wily
Repository:
lp:ubuntu/+source/hplip

Recent commits

9dfa884... by Till Kamppeter on 2015-09-18

Import patches-unapplied version 3.15.7-0ubuntu4 to ubuntu/wily-proposed

Imported using git-ubuntu import.

Changelog parent: eaae66bcc5be579dcb3401e167b576668f046e06

New changelog entries:
  * debian/local/scripts/hp-plugin-ubuntu: Use pkexec instead of
    gksu (LP: #1496980).

eaae66b... by Till Kamppeter on 2015-09-15

Import patches-unapplied version 3.15.7-0ubuntu3 to ubuntu/wily-proposed

Imported using git-ubuntu import.

Changelog parent: 5783dcdf1a74456b1934a9e76cf638c69e1c4445

New changelog entries:
  * debian/patches/common-definitions-h-fix.patch: Fixed hpcups crash,
    patch backported from HPLIP 3.15.9 (LP: #1475022, LP: #1476920,
    LP: #1480332, LP: #1483073).

5783dcd... by Till Kamppeter on 2015-08-25

Import patches-unapplied version 3.15.7-0ubuntu2 to ubuntu/wily-proposed

Imported using git-ubuntu import.

Changelog parent: 25b0f858fa16478f021f5c520558f2a688f2bf71

New changelog entries:
  * debian/rules: Do not do the PPD file uncompression twice, especially
    do not uncompress the fax PPDs, as hp-setup accesses them directly
    instead of getting them through CUPS (LP: #1470300).
  * debian/rules: When patching the PPD files, remove the *.orig files so
    that they do not get shipped with the binary packages.

25b0f85... by Till Kamppeter on 2015-08-19

Import patches-unapplied version 3.15.7-0ubuntu1 to ubuntu/wily-proposed

Imported using git-ubuntu import.

Changelog parent: cd821ab8a2ba953c4567c366d8deaf20218b456c

New changelog entries:
  * New upstream release
     - Added support for HP Deskjet 1110, 1111, 1112 Printer, HP DeskJet
       2131 All-in-One Printer, HP Deskjet Ink Advantage 1110, 1115, 1118
       Printer, HP DeskJet Ink Advantage 2130, 2135, 2138, 3630, 3635, 3636,
       3638, 3830, 3835 All-in-One Printer, HP OfficeJet 3830, 3832, 3834
       All-in-One Printer, HP Officejet 7510 Wide Format All-in-One Printer
     - Removed the duplicate collate option from HP Device Manager
     - Fixed: Traceback error occurs when trying to configure a queue of same
       name
       but with different IO type
     - Fixed: HPLIP installer prompts to set up printers, even when printers are
       already set up (LP: #1464013).
     - Fixed: Insecure binary driver verification (CVE-2015-0839, LP: #1432516).

cd821ab... by Till Kamppeter on 2015-06-11

Import patches-unapplied version 3.15.6-0ubuntu1 to ubuntu/wily-proposed

Imported using git-ubuntu import.

Changelog parent: 78c0f7041588b001c2b73c86532266d2ed0a4568

New changelog entries:
  * New upstream release
     - Added support for HP DeskJet 2130/2132/2546B/2546P/2546R/3630/3632
       All-in-One printer, HP OfficeJet 57444 e-All-in-One
     - Fixed: Error message is displayed while running "hp-diagnose_queues"
       in a terminal.
     - Fixed: UDEV rules wrongly match on monitor hub, wrong invocation of
       systemd unti, changes confi files in UDEV rules (LP: #1433557).
     - Fixed: hp-setup creates spurious cupsd process (LP: #1438456).
  * debian/patches/musb-c-do-not-crash-on-usb-failure.patch,
    debian/patches/pcardext-python3-workaround-upstream.patch,
    debian/patches/hp-plugin-download-fix.patch: Updated for new upstream
    code.

78c0f70... by Till Kamppeter on 2015-05-06

Import patches-unapplied version 3.15.2-0ubuntu5 to ubuntu/wily-proposed

Imported using git-ubuntu import.

Changelog parent: 0b8d3b1df47c242f996fb8e02e6d0de5d72c54f7

New changelog entries:
  * debian/patches/hp-plugin-download-fix.patch: Fix download and installation
    of HP's proprietary plug-in in Python3 environments (LP: #1422004).

0b8d3b1... by Till Kamppeter on 2015-03-17

Import patches-unapplied version 3.15.2-0ubuntu4 to ubuntu/vivid-proposed

Imported using git-ubuntu import.

Changelog parent: a150f24990903f3ed14b7e2a7cdaadea6a81da75

New changelog entries:
  * debian/rules: Remove explicit call of /usr/bin/python when calling the
    /usr/bin/hp-config_usb_printer script so that the shebang does not get
    overridden (LP: #1425812).

a150f24... by Till Kamppeter on 2015-03-02

Import patches-unapplied version 3.15.2-0ubuntu3 to ubuntu/vivid-proposed

Imported using git-ubuntu import.

Changelog parent: 0b2f72bca087911d161c3899f9a54a6acbe7480b

New changelog entries:
  * debian/patches/hpscan-deskjet-3520-aio-allow-non-jpeg-scanning.patch:
    Allow non-JPEG scanning on the HP DeskJet 3520 All-in-One and similar
    devices. Thanks to Lubos Dolezel for the patch (LP: #1245578).

0b2f72b... by Till Kamppeter on 2015-02-06

Import patches-unapplied version 3.15.2-0ubuntu2 to ubuntu/vivid-proposed

Imported using git-ubuntu import.

Changelog parent: ec9c6af2ff87519a3c3a7a07248a53bce912e822

New changelog entries:
  * debian/patches/pcardext-python3-workaround-upstream.patch: Workaround
    patch for missing Python3 transition of the old (pre-USB-storage) photo
    memory card support (pcardext) as this part builds in Python3 environments
    but with pointer-related warnings which are fatal errors for Ubuntu's build
    servers. The patch silences the warnings but the memory card support is
    dropped in Python3 environments. This patch is supplied by the HPLIP
    upstream developers and will be replaced by a more proper solution in the
    next upstream release of HPLIP (see LP: #1275353).

ec9c6af... by Till Kamppeter on 2015-02-04

Import patches-unapplied version 3.15.2-0ubuntu1 to ubuntu/vivid-proposed

Imported using git-ubuntu import.

Changelog parent: 72c3904029856bc8db6843d7712afcb88d63ed4c

New changelog entries:
  * New upstream release
    - Python3 support for HPLIP
    - Doesn't build against libjpeg-turbo 1.3.90 (LP: #1388126)
    - hpcups crashes if DEVICE_URI not set in environment (LP: #1395676)
    - Incorrect call to hpmudext.device_open (LP: #1388007)
    - plugin download fails if python links to python3 (LP: #1187055)
    - Incorrect IEEE 1284 Device IDs for many models (LP: #802999)
  * debian/patches/85_rebuild_python_ui.dpatch: Manually updated to apply to new
    upstream source code.
  * debian/patches/hp_photosmart_pro_b9100_support.dpatch,
    debian/patches/simple-scan-as-default.dpatch,
    debian/patches/hpfax-bug-function-used-before-importing-log.dpatch,
    debian/patches/hp-systray-make-menu-title-visible-in-sni-qt-indicator.dpatch,
    debian/patches/hp-systray-make-menu-appear-in-sni-qt-indicator-with-kde.dpatch,
    debian/patches/hpaio-option-duplex.diff,
    debian/patches/musb-c-do-not-crash-on-usb-failure.patch,
    debian/patches/process-events-for-systray.patch: Refreshed with quilt.
  * debian/rules: Force Python3 build using PYTHON=python3 ./configure option
  * debian/rules: Use py3versions to get system's Python3 interpreter version
  * debian/rules: Use relative symlink for /usr/sbin/hpssd, so that shebang
    correction works.
  * debian/rules: Make sure that the Python interpreter paths in all executables
    use python3.
  * debian/rules: Use dh_python3 instead of dh_python2.
  * debian/control: Replaced all Python-related dependencies by their
    Python3 equivalent.