ubuntu/+source/hplip:applied/ubuntu/dapper-updates

Last commit made on 2008-11-19
Get this branch:
git clone -b applied/ubuntu/dapper-updates https://git.launchpad.net/ubuntu/+source/hplip
Members of Ubuntu Server Dev import team can upload to this branch. Log in for directions.

Branch merges

Branch information

Name:
applied/ubuntu/dapper-updates
Repository:
lp:ubuntu/+source/hplip

Recent commits

bd9b159... by Marc Deslauriers on 2008-11-18

Import patches-applied version 0.9.7-4ubuntu1.1 to applied/ubuntu/dapper-security

Imported using git-ubuntu import.

Changelog parent: 060dad697c862bd5941ca523a598f707c824a12b
Unapplied parent: f5e3d468d0abf958b1bf7a40b825aabc8e28b3c3

New changelog entries:
  * SECURITY UPDATE: privilege escalation using the hplip alert-mailing
    functionality.
    - debian/patches/70_SECURITY_CVE-2008-2940.dpatch: fix handle_event()
      in hpssd.py to validate device-uri parameter and disable
      handle_setalerts(). This fix alters hplip behaviour by preventing
      users from setting alerts and by moving alert configuration to a
      root-controlled /etc/hp/alerts.conf file.
    - CVE-2008-2940
  * SECURITY UPDATE: denial of service in hpssd message parser.
    - debian/patches/71_SECURITY_CVE-2008-2941.dpatch: fix handle_event()
      in hpssd.py to correctly validate parameters.
    - CVE-2008-2941

f5e3d46... by Marc Deslauriers on 2008-11-18

Import patches-unapplied version 0.9.7-4ubuntu1.1 to ubuntu/dapper-security

Imported using git-ubuntu import.

Changelog parent: 595afb91fc6bf753c49637feb55f7a5e9687cf4d

New changelog entries:
  * SECURITY UPDATE: privilege escalation using the hplip alert-mailing
    functionality.
    - debian/patches/70_SECURITY_CVE-2008-2940.dpatch: fix handle_event()
      in hpssd.py to validate device-uri parameter and disable
      handle_setalerts(). This fix alters hplip behaviour by preventing
      users from setting alerts and by moving alert configuration to a
      root-controlled /etc/hp/alerts.conf file.
    - CVE-2008-2940
  * SECURITY UPDATE: denial of service in hpssd message parser.
    - debian/patches/71_SECURITY_CVE-2008-2941.dpatch: fix handle_event()
      in hpssd.py to correctly validate parameters.
    - CVE-2008-2941

060dad6... by Matthias Klose on 2006-04-11

Import patches-applied version 0.9.7-4ubuntu1 to applied/ubuntu/dapper

Imported using git-ubuntu import.

Changelog parent: d8ac879cfc22406e9f01da4ad4eff640c0a369bd
Unapplied parent: 595afb91fc6bf753c49637feb55f7a5e9687cf4d

New changelog entries:
  * Synchronize with Debian unstable.
  * Keep the .desktop file, add "NoDisplay=true".
  * Keep qt build dependencies, now in main.
  * hplip-data now provides hpijs-data (introduced in 0.9.8).
  * Try to open a message dialog for the "No Qt" message. Malone: #26413.
  * Install ppd files into a manufacturer specific directory.
  * Set the manufacturer name to "HP".
  * Start hplip before cupsys. Malone: #3841, #26570.
  * Put toolbox icon in category system, not application. Malone: #25627.
  * New upstream 0.9.7-2 patch: fixes for the following problems:
    + Photosmart 2570 series blue screen scanning error
    + GetDeviceStatus overwrite in hpiod (from RedHat)
    + SuperB margin issue with OJ K550, OJ K850 and DJ9800
    + _GNU_SOURCE define in hpaio.h. (from RedHat)
  * Remove versioning of python-qt3 and pyqt-utils build-dependencies to
    make backports easier. Current versions in stable, testing and sid
    are safe AFAIK
  * Build-depend on libsnmp9-dev|libsnmp5-dev, to ease sarge backports
  * Switch from two versioned conflicts to two versioned depends/recommends
    to encode the relationship between hplip and hplip-data. This is
    easier on apt, since conflicts preclude unpack, while depends preclude
    configure
  * Fix non-removal of rem_str on 60_lp_instead_of_lpr (closes: #341445)
  * Brown paperbag release
  * Actually add 60_lp_instead_of_lpr to list of active dpatches.
    This closes: #336407 for real
  * New upstream version
    * HPIJS 2.1.7:
      + Fixed OJ K550 typo in HPIJS
      + Added photo tray support to DJGenericVIP device class. This effects
        all DJGenericVIP PPD files
      + Added support for the following new printers:
        + HP Color LaserJet 3000 (LJColor/PS)
        + HP Color LaserJet 3600 (LJJetReady)
        + HP Color LaserJet 3800 (LJColor/PS)
    * HPLIP 0.9.7:
      + Added 1284.4 support to hpiod. Previous support was MLC only
      + Changed hp-toolbox startup behavior to increase performance
      + Added checks in messaging code to prevent invalid messages from
        crashing hpssd
      + Added hp-toolbox PML cleanup code to LJ status code
      + Fixed clj28xx scanning issue. Mfpdtf buffer was too small
        libsane-hpaio. This fixes a problem introduced in 0.9.5
      + Modified hp-makeuri to allow hostnames for network addresses
      + Added support for "alternate n-up" for PS documents to hp-print
      + Fixed an issue where the website link for support information is
        wrong in "HP" tab of "Support Information" dialog
      + Fixed an issue setting the scan token in libsane-hpaio
      + Fixed an issue where an error occurs while executing the command
        "hp-check -lnone" in terminal
      + Fixed an issue where an exception is caught but the program does not
        show a correct prompt when running the command "hp-align" with parameter
        -p
      + Fixed System::GetSnmp sigfault in hpiod. This will fix network
        scanning/hp-toolbox issues in previous HPLIP releases
      + Fixed an issue where an error occurs while executing hp-photo after
        the usb cable was disconnected
  * Use far less tight versioning that works with the new rules for binNMUs,
    and break a dependency loop while at it (closes: #339909)
  * Add versioned dependency on coreutils 5.1+ (closes: #337375)
  * New dpatch 60_lp_instead_of_lpr:
    Use "lp" instead of "lpr" to submit jobs (closes: #336407)
  * Ship copyright and changelogs along with hplip-data too, as it is not
    depending on hplip anymore and the /usr/share/doc/hplip-data symlink has
    to go away

595afb9... by Matthias Klose on 2006-04-11

Import patches-unapplied version 0.9.7-4ubuntu1 to ubuntu/dapper

Imported using git-ubuntu import.

Changelog parent: 738e89c80e522c3a1b2d1f43311be578ab90b4f3

New changelog entries:
  * Synchronize with Debian unstable.
  * Keep the .desktop file, add "NoDisplay=true".
  * Keep qt build dependencies, now in main.
  * hplip-data now provides hpijs-data (introduced in 0.9.8).
  * Try to open a message dialog for the "No Qt" message. Malone: #26413.
  * Install ppd files into a manufacturer specific directory.
  * Set the manufacturer name to "HP".
  * Start hplip before cupsys. Malone: #3841, #26570.
  * Put toolbox icon in category system, not application. Malone: #25627.
  * New upstream 0.9.7-2 patch: fixes for the following problems:
    + Photosmart 2570 series blue screen scanning error
    + GetDeviceStatus overwrite in hpiod (from RedHat)
    + SuperB margin issue with OJ K550, OJ K850 and DJ9800
    + _GNU_SOURCE define in hpaio.h. (from RedHat)
  * Remove versioning of python-qt3 and pyqt-utils build-dependencies to
    make backports easier. Current versions in stable, testing and sid
    are safe AFAIK
  * Build-depend on libsnmp9-dev|libsnmp5-dev, to ease sarge backports
  * Switch from two versioned conflicts to two versioned depends/recommends
    to encode the relationship between hplip and hplip-data. This is
    easier on apt, since conflicts preclude unpack, while depends preclude
    configure
  * Fix non-removal of rem_str on 60_lp_instead_of_lpr (closes: #341445)
  * Brown paperbag release
  * Actually add 60_lp_instead_of_lpr to list of active dpatches.
    This closes: #336407 for real
  * New upstream version
    * HPIJS 2.1.7:
      + Fixed OJ K550 typo in HPIJS
      + Added photo tray support to DJGenericVIP device class. This effects
        all DJGenericVIP PPD files
      + Added support for the following new printers:
        + HP Color LaserJet 3000 (LJColor/PS)
        + HP Color LaserJet 3600 (LJJetReady)
        + HP Color LaserJet 3800 (LJColor/PS)
    * HPLIP 0.9.7:
      + Added 1284.4 support to hpiod. Previous support was MLC only
      + Changed hp-toolbox startup behavior to increase performance
      + Added checks in messaging code to prevent invalid messages from
        crashing hpssd
      + Added hp-toolbox PML cleanup code to LJ status code
      + Fixed clj28xx scanning issue. Mfpdtf buffer was too small
        libsane-hpaio. This fixes a problem introduced in 0.9.5
      + Modified hp-makeuri to allow hostnames for network addresses
      + Added support for "alternate n-up" for PS documents to hp-print
      + Fixed an issue where the website link for support information is
        wrong in "HP" tab of "Support Information" dialog
      + Fixed an issue setting the scan token in libsane-hpaio
      + Fixed an issue where an error occurs while executing the command
        "hp-check -lnone" in terminal
      + Fixed an issue where an exception is caught but the program does not
        show a correct prompt when running the command "hp-align" with parameter
        -p
      + Fixed System::GetSnmp sigfault in hpiod. This will fix network
        scanning/hp-toolbox issues in previous HPLIP releases
      + Fixed an issue where an error occurs while executing hp-photo after
        the usb cable was disconnected
  * Use far less tight versioning that works with the new rules for binNMUs,
    and break a dependency loop while at it (closes: #339909)
  * Add versioned dependency on coreutils 5.1+ (closes: #337375)
  * New dpatch 60_lp_instead_of_lpr:
    Use "lp" instead of "lpr" to submit jobs (closes: #336407)
  * Ship copyright and changelogs along with hplip-data too, as it is not
    depending on hplip anymore and the /usr/share/doc/hplip-data symlink has
    to go away

d8ac879... by Matthias Klose on 2006-04-14

Import patches-applied version 0.9.6-1ubuntu8 to applied/ubuntu/dapper

Imported using git-ubuntu import.

Changelog parent: f8969621743866b456a3c2f9bd495b293dc0af7b
Unapplied parent: 738e89c80e522c3a1b2d1f43311be578ab90b4f3

New changelog entries:
  * Fix symlink in /usr/share/cups/model.

738e89c... by Matthias Klose on 2006-04-14

Import patches-unapplied version 0.9.6-1ubuntu8 to ubuntu/dapper

Imported using git-ubuntu import.

Changelog parent: da36dd23856d84ee8a42a6a684350f1228e8dc9f

New changelog entries:
  * Fix symlink in /usr/share/cups/model.

f896962... by Matthias Klose on 2006-04-11

Import patches-applied version 0.9.6-1ubuntu7 to applied/ubuntu/dapper

Imported using git-ubuntu import.

Changelog parent: eb7d40a97f6badf5a68a09d9ded152decb55abe0
Unapplied parent: da36dd23856d84ee8a42a6a684350f1228e8dc9f

New changelog entries:
  * Keep the .desktop file, add "NoDisplay=true".
  * Keep qt build dependencies, now in main.
  * hplip-data now provides hpijs-data (introduced in 0.9.8).
  * Try to open a message dialog for the "No Qt" message. Malone: #26413.
  * Install ppd files into a manufacturer specific directory.
  * Set the manufacturer name to "HP".
  * Start hplip before cupsys. Malone: #3841, #26570.
  * Put toolbox icon in category system, not application. Malone: #25627.

da36dd2... by Matthias Klose on 2006-04-11

Import patches-unapplied version 0.9.6-1ubuntu7 to ubuntu/dapper

Imported using git-ubuntu import.

Changelog parent: 6dd66f9d3d0aadcef9cc4fa586394c1b768442d1

New changelog entries:
  * Keep the .desktop file, add "NoDisplay=true".
  * Keep qt build dependencies, now in main.
  * hplip-data now provides hpijs-data (introduced in 0.9.8).
  * Try to open a message dialog for the "No Qt" message. Malone: #26413.
  * Install ppd files into a manufacturer specific directory.
  * Set the manufacturer name to "HP".
  * Start hplip before cupsys. Malone: #3841, #26570.
  * Put toolbox icon in category system, not application. Malone: #25627.

eb7d40a... by Sebastien Bacher on 2006-02-15

Import patches-applied version 0.9.6-1ubuntu6 to applied/ubuntu/dapper

Imported using git-ubuntu import.

Changelog parent: bc3b9f97e9e4cceb10d387638c02da49d8fee1b0
Unapplied parent: 6dd66f9d3d0aadcef9cc4fa586394c1b768442d1

New changelog entries:
  * Updated patch name and listed it from 00list so it's used

6dd66f9... by Sebastien Bacher on 2006-02-15

Import patches-unapplied version 0.9.6-1ubuntu6 to ubuntu/dapper

Imported using git-ubuntu import.

Changelog parent: a97c618634160666ead922cec0a7a28443a59f27

New changelog entries:
  * Updated patch name and listed it from 00list so it's used