ubuntu/+source/hplip:applied/debian/sid

Last commit made on 2009-03-09
Get this branch:
git clone -b applied/debian/sid https://git.launchpad.net/ubuntu/+source/hplip
Members of Ubuntu Server Dev import team can upload to this branch. Log in for directions.

Branch merges

Branch information

Name:
applied/debian/sid
Repository:
lp:ubuntu/+source/hplip

Recent commits

b6b02f7... by Mark Purcell on 2009-03-09

Import patches-applied version 3.9.2-1 to applied/debian/sid

Imported using git-ubuntu import.

Changelog parent: f0cf6d04aa7ea5571fd09766831cb21b2eed0aae
Unapplied parent: b32155bb0a92dcee1337c0b6dcb0f81f8ab46b0b

New changelog entries:
  [ Till Kamppeter ]
  * New upstream release
     o Fully Qt4-based
     o Added printing support for HP Color LasetJets 1600, 2600, and CP1215
     o Added support for HP OfficeJet Pro 8xxx series
     o Tons of bug fixes
  * debian/control, debian/rules: Qt3 is not needed any more
  * debian/control: hp-toolbox (package hplip-gui) needs python-qt4-dbus now.
  * debian/patches/pdf_printing_support.dpatch: Removed, applied upstream.
  * debian/patches/systray-applet-with-qt4.dpatch: Removed, not needed any
    more in Qt4-only environment.
  * debian/patches/delayed-hp-systray-start.dpatch: Delay start of HPLIP
    system tray applet, as it sometimes got started before the system tray was
    available.
  * debian/patches/kde4-kdesudo-support.dpatch,
    debian/patches/hp_photosmart_pro_b9100_support.dpatch,
    debian/patches/hpinfo-query-without-cups-queue.dpatch,
    debian/patches/85_rebuild_python_ui.dpatch: Regenerated.
  [ Till Kamppeter ]
  * debian/patches/hpinfo-query-without-cups-queue.dpatch: Allow hp-info to
    query URIs for which there is no CUPS queue (LP: #329220).
  [ Mark Purcell ]
  * debian/patches/hp-check_debian.dpatch: Fixed hp-check for the SANE driver

b32155b... by Mark Purcell on 2009-03-09

Import patches-unapplied version 3.9.2-1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 615ecfc40aff6512bae8def50912074ed847aee1

New changelog entries:
  [ Till Kamppeter ]
  * New upstream release
     o Fully Qt4-based
     o Added printing support for HP Color LasetJets 1600, 2600, and CP1215
     o Added support for HP OfficeJet Pro 8xxx series
     o Tons of bug fixes
  * debian/control, debian/rules: Qt3 is not needed any more
  * debian/control: hp-toolbox (package hplip-gui) needs python-qt4-dbus now.
  * debian/patches/pdf_printing_support.dpatch: Removed, applied upstream.
  * debian/patches/systray-applet-with-qt4.dpatch: Removed, not needed any
    more in Qt4-only environment.
  * debian/patches/delayed-hp-systray-start.dpatch: Delay start of HPLIP
    system tray applet, as it sometimes got started before the system tray was
    available.
  * debian/patches/kde4-kdesudo-support.dpatch,
    debian/patches/hp_photosmart_pro_b9100_support.dpatch,
    debian/patches/hpinfo-query-without-cups-queue.dpatch,
    debian/patches/85_rebuild_python_ui.dpatch: Regenerated.
  [ Till Kamppeter ]
  * debian/patches/hpinfo-query-without-cups-queue.dpatch: Allow hp-info to
    query URIs for which there is no CUPS queue (LP: #329220).
  [ Mark Purcell ]
  * debian/patches/hp-check_debian.dpatch: Fixed hp-check for the SANE driver

f0cf6d0... by Mark Purcell on 2009-02-17

Import patches-applied version 2.8.12-3 to applied/debian/sid

Imported using git-ubuntu import.

Changelog parent: 4f8f76f708f2a4fc52f56cd6177a554a68eb301e
Unapplied parent: 615ecfc40aff6512bae8def50912074ed847aee1

New changelog entries:
  * Fix "Breaks: udev (<< 136-1) which is only in Ubuntu; uninstallable
    on Debian" removed from debian/control (Closes: #515750)

615ecfc... by Mark Purcell on 2009-02-17

Import patches-unapplied version 2.8.12-3 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 165710626508e80f6a653895353577e35b6618dc

New changelog entries:
  * Fix "Breaks: udev (<< 136-1) which is only in Ubuntu; uninstallable
    on Debian" removed from debian/control (Closes: #515750)

4f8f76f... by Mark Purcell on 2009-02-16

Import patches-applied version 2.8.12-2 to applied/debian/sid

Imported using git-ubuntu import.

Changelog parent: d3acc45e33d10f6116ab63628f40f809f00a75cf
Unapplied parent: 165710626508e80f6a653895353577e35b6618dc

New changelog entries:
  * Add Recommends for sane-utils/ xsane
  * Conflicts: hpoj (Closes: #508008)
  * debian/rules add get-orig-source target
    - Available if gnome-pkg-tools is installed
  * Fix hp-check to work recognise Debian install
    - Fix "hp-check complains about missing SIP even when sip4 installed"
    (Closes: #483843)
    - Fix "suggests installation of already installed sane" (Closes: #494419)
    - Fix "hp-check complains for lacking hpaio support in sane but
    package configures it ok" (Closes: #494430)
    - Fix "Debian/ Ubuntu place hpaio in /etc/sane.d/dll.d/hplip, so lets
    check there too" (Closes: #512596)
  * Fix "dplip: please change default icon to
    /usr/share/pixmaps/HPmenu.xpm" patch from Fabian (Closes: #415048)
  * debian/rules: Returned UDEV rules priority to 40.
  * debian/hplip.udev, debian/rules: Ship our own UDEV rules again, the
    upstream ones have many problems (LP: #319660, LP: #319661, LP: #319662,
    LP: #319665).
  * debian/hplip.udev, debian/rules: Do not ship our own UDEV rules but use
    the upstream ones. Use also the upsttream priority (55) for these rules.
  * debian/hpdio.py, debian/rules: Removed, the file is provided upstream
    now.
  * debian/patches/hp-levels-without-tty.dpatch: Removed, problem fixed
    upstream (Upstream bug LP: #299479).
  * Restore udev rules that assign the lp group to /dev/bus/usb devices
    for certain printers. LP: #318262.
  * debian/rules, debian/hplip.install, debian/hplip.links: Automatization
    of file selection for generating symlinks to the executables and
    generating the man pages. This avoids that new tools and man pages get
    forgotten.
  * Merge from Debian
  * New upstream release
  * Distribution experimental while we await lenny
  * del debian/patches included upstream;
    - manpage-whatis.dpatch, hpssd-correct-hp-sendfax-call.dpatch,
    61_noqt_message.dpatch, qt4-systray-with-qt3-utilities.dpatch
  * Sync with Ubuntu
  * Add Breaks to ensure the right version of udev gets used.
  * debian/rules: Don't install udev rules anymore; all these do is try and
    put things in the scanner group which has been removed upstream (for
    precisely this reason - printers aren't scanners!)
  * debian/hplip.preinst: Remove udev rules on upgrade
  * debian/hpijs.postinst, debian/hpijs-ppds.postinst: Do not try to update
    the PPDs of existing print queues if CUPS is not installed or not running
    (LP: #302532).
  * Fix "New upstream version 2.8.9" sync with Ubuntu
  (Closes: #501275)
  * Distribution experimental while we await lenny
  * debian/control: Really fix the updating conflict of hplip and hplip-gui
    due to the move of /usr/share/pixmaps/HPmenu.xpm in HPLIP 2.8.6.b-2
    (Closes: #502055, LP: #299542).
  * debian/hpijs.postinst, debian/hpijs-ppds.postinst: Make maintainer scripts
    silent if there are no PPDs of existing print queues (LP: #299889).
  * debian/rules: Set Python module path for calls of HPLIP components
    during package build.
  * debian/patches/hp-levels-without-tty.dpatch: Make hp-levels working
    also without access to a TTY, for example to generate the man page with
    "--help-man" during package build.
  * New upstream release
    - Closes: #501275, LP: #296399
  * debian/hpijs.postinst, debian/hpijs-ppds.postinst: Let the PPD files of the
    existing print queues get automatically updated after each installation of
    this package.
  * Refresh 85_rebuild_python_ui.dpatch,
    hp_photosmart_pro_b9100_support.dpatch, systray-applet-with-qt4.dpatch
  * bugs-in-generated-ppds.dpatch: Removed, applied upstream.
  * text-only-without-systray-applet-traceback.dpatch: Removed, problem solved
    upstream.
  * Add manpages at build using --help-man option
  * Add hp_photosmart_pro_b9100_support.dpatch description
  * Add manpage-whatis.dpatch
  * debian/rules: The fax PPDs are gzipped in the source tree now, unzip
    them before patching
  * debian/hpdio.py, debian/rules: Added file which was missing in the source
    tarball, closes LP: #299011
  * qt4-systray-with-qt3-utilities.dpatch: Suppress warning that Qt4 support
    is not completed and let systray applet not force the hp-toolbox into Qt4
    mode (LP: #299011).
  * debian/rules: Let package build with both Qt3 and Qt4 support, let Qt3
    be used by default ("ui-toolkit=qt3" in /etc/hp/hplip.conf), closes
    LP: #299011
  * hpssd-correct-hp-sendfax-call.dpatch: Correct call of hp-sendfax,
    specifying the print queue needs "--printer" now and not "--fax".
  * Distribution experimental while lenny is unreleased
    - hplip/2.8.6.b is target for lenny
  * Merge my branches/lenny changes r184:212 into trunk
  * Update dpatch descriptions DP:
  * unused-override debian/{hpijs,hplip-data}.lintian

1657106... by Mark Purcell on 2009-02-16

Import patches-unapplied version 2.8.12-2 to debian/sid

Imported using git-ubuntu import.

Changelog parent: a9a35f32618e60c57bc696afaae205efa77f1358

New changelog entries:
  * Add Recommends for sane-utils/ xsane
  * Conflicts: hpoj (Closes: #508008)
  * debian/rules add get-orig-source target
    - Available if gnome-pkg-tools is installed
  * Fix hp-check to work recognise Debian install
    - Fix "hp-check complains about missing SIP even when sip4 installed"
    (Closes: #483843)
    - Fix "suggests installation of already installed sane" (Closes: #494419)
    - Fix "hp-check complains for lacking hpaio support in sane but
    package configures it ok" (Closes: #494430)
    - Fix "Debian/ Ubuntu place hpaio in /etc/sane.d/dll.d/hplip, so lets
    check there too" (Closes: #512596)
  * Fix "dplip: please change default icon to
    /usr/share/pixmaps/HPmenu.xpm" patch from Fabian (Closes: #415048)
  * debian/rules: Returned UDEV rules priority to 40.
  * debian/hplip.udev, debian/rules: Ship our own UDEV rules again, the
    upstream ones have many problems (LP: #319660, LP: #319661, LP: #319662,
    LP: #319665).
  * debian/hplip.udev, debian/rules: Do not ship our own UDEV rules but use
    the upstream ones. Use also the upsttream priority (55) for these rules.
  * debian/hpdio.py, debian/rules: Removed, the file is provided upstream
    now.
  * debian/patches/hp-levels-without-tty.dpatch: Removed, problem fixed
    upstream (Upstream bug LP: #299479).
  * Restore udev rules that assign the lp group to /dev/bus/usb devices
    for certain printers. LP: #318262.
  * debian/rules, debian/hplip.install, debian/hplip.links: Automatization
    of file selection for generating symlinks to the executables and
    generating the man pages. This avoids that new tools and man pages get
    forgotten.
  * Merge from Debian
  * New upstream release
  * Distribution experimental while we await lenny
  * del debian/patches included upstream;
    - manpage-whatis.dpatch, hpssd-correct-hp-sendfax-call.dpatch,
    61_noqt_message.dpatch, qt4-systray-with-qt3-utilities.dpatch
  * Sync with Ubuntu
  * Add Breaks to ensure the right version of udev gets used.
  * debian/rules: Don't install udev rules anymore; all these do is try and
    put things in the scanner group which has been removed upstream (for
    precisely this reason - printers aren't scanners!)
  * debian/hplip.preinst: Remove udev rules on upgrade
  * debian/hpijs.postinst, debian/hpijs-ppds.postinst: Do not try to update
    the PPDs of existing print queues if CUPS is not installed or not running
    (LP: #302532).
  * Fix "New upstream version 2.8.9" sync with Ubuntu
  (Closes: #501275)
  * Distribution experimental while we await lenny
  * debian/control: Really fix the updating conflict of hplip and hplip-gui
    due to the move of /usr/share/pixmaps/HPmenu.xpm in HPLIP 2.8.6.b-2
    (Closes: #502055, LP: #299542).
  * debian/hpijs.postinst, debian/hpijs-ppds.postinst: Make maintainer scripts
    silent if there are no PPDs of existing print queues (LP: #299889).
  * debian/rules: Set Python module path for calls of HPLIP components
    during package build.
  * debian/patches/hp-levels-without-tty.dpatch: Make hp-levels working
    also without access to a TTY, for example to generate the man page with
    "--help-man" during package build.
  * New upstream release
    - Closes: #501275, LP: #296399
  * debian/hpijs.postinst, debian/hpijs-ppds.postinst: Let the PPD files of the
    existing print queues get automatically updated after each installation of
    this package.
  * Refresh 85_rebuild_python_ui.dpatch,
    hp_photosmart_pro_b9100_support.dpatch, systray-applet-with-qt4.dpatch
  * bugs-in-generated-ppds.dpatch: Removed, applied upstream.
  * text-only-without-systray-applet-traceback.dpatch: Removed, problem solved
    upstream.
  * Add manpages at build using --help-man option
  * Add hp_photosmart_pro_b9100_support.dpatch description
  * Add manpage-whatis.dpatch
  * debian/rules: The fax PPDs are gzipped in the source tree now, unzip
    them before patching
  * debian/hpdio.py, debian/rules: Added file which was missing in the source
    tarball, closes LP: #299011
  * qt4-systray-with-qt3-utilities.dpatch: Suppress warning that Qt4 support
    is not completed and let systray applet not force the hp-toolbox into Qt4
    mode (LP: #299011).
  * debian/rules: Let package build with both Qt3 and Qt4 support, let Qt3
    be used by default ("ui-toolkit=qt3" in /etc/hp/hplip.conf), closes
    LP: #299011
  * hpssd-correct-hp-sendfax-call.dpatch: Correct call of hp-sendfax,
    specifying the print queue needs "--printer" now and not "--fax".
  * Distribution experimental while lenny is unreleased
    - hplip/2.8.6.b is target for lenny
  * Merge my branches/lenny changes r184:212 into trunk
  * Update dpatch descriptions DP:
  * unused-override debian/{hpijs,hplip-data}.lintian

d3acc45... by Mark Purcell on 2008-10-15

Import patches-applied version 2.8.6.b-3 to applied/debian/sid

Imported using git-ubuntu import.

Changelog parent: 5924a6ea151764738fbc1b59353d8462aa31bb10
Unapplied parent: a9a35f32618e60c57bc696afaae205efa77f1358

New changelog entries:
  * hplip Replaces hplip-gui (<< 2.8.6.b-2)
    - File conflict with hplip-gui (Closes: #502055)
  * Apply patch (faulty scanext.so) from dwelsh
    - hp-scan: Aborts with a traceback when trying to scan.
    hplip-2.8.6-hp_scan_link.dpatch (Closes: #490640)
  * Sync Ubuntu patches & changes:
      debian/patches/pdf_printing_support.dpatch
      debian/patches/pjl-duplex-binding.dpatch
      debian/patches/kde4-kdesudo-support.dpatch
      debian/patches/bugs-in-generated-ppds.dpatch
    - Exclude /usr/share/hplip/install.py
    - hplip-gui requires one of "gksu", "kdesu", and "kdesudo"
    - debian/rules: Add *cupsFilter lines for PDF input
  * unused-override debian/{hpijs,hplip-data}.lintian
  * Lintian cleanup:
  * hpijs-ppds Depends: hpijs - lintian:stronger-dependency-implies-weaker
  * Update 14_charsign_fixes.dpatch
    - lintian:dpatch-missing-description
  * hplip.NEWS & hpijs-ppds.NEWS - lintian:syntax-error-in-debian-news-file
  * hplip-data Depends: python - perhaps should be called hplip-common?
    - lintian:python-script-but-no-python-dep
  * -x colorcal4form_base.ui distros.dat executable-not-elf-or-script
  * Ship small .xpm with hplip not -gui package
    - lintian:menu-icon-missing
  * hplip.lintian libhpip0 & libhpmud0 - not shared libs internal only
    - lintian:package-name-doesnt-match-sonames
  * Update debian/hplip-doc.doc-base
    - lintian:doc-base-abstract-might-contain-extra-leading-whitespaces
  * hplip-doc.doc-base Section: System/Administration
    - lintian:doc-base-unknown-section
  * Cleanup hplip.lintian - linitan:unused-override
  * Cleanup *.desktop - lintian:desktop-entry-contains-encoding-key
  * Fixup hplip/presubj lintian:executable-not-elf-or-script
  * Add URL to hp-makeuri-uri-only-output.dpatch Description ##DP
  * Other issues:
  * Enable GNU/kFreeBSD builds - thanks Petr Salinger
    - FTBFS on GNU/kFreeBSD (fixup of debian/rules needed) (Closes:
    #497625)
  * Fixup hpojs-ppds.postinst s/cupsys/cups/ - thanks Michael Wagner
    - postinst invokes cupsys instead of cups (Closes: #498156)
  * Really apply hp-makeuri-uri-only-output.dpatch - thanks Avi Rozen
    - hp-makeuri -c does not print cups uri (Closes: #500183)

a9a35f3... by Mark Purcell on 2008-10-15

Import patches-unapplied version 2.8.6.b-3 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 5e9736ce4393f93cf06991f3f26fc248b1c79c1f

New changelog entries:
  * hplip Replaces hplip-gui (<< 2.8.6.b-2)
    - File conflict with hplip-gui (Closes: #502055)
  * Apply patch (faulty scanext.so) from dwelsh
    - hp-scan: Aborts with a traceback when trying to scan.
    hplip-2.8.6-hp_scan_link.dpatch (Closes: #490640)
  * Sync Ubuntu patches & changes:
      debian/patches/pdf_printing_support.dpatch
      debian/patches/pjl-duplex-binding.dpatch
      debian/patches/kde4-kdesudo-support.dpatch
      debian/patches/bugs-in-generated-ppds.dpatch
    - Exclude /usr/share/hplip/install.py
    - hplip-gui requires one of "gksu", "kdesu", and "kdesudo"
    - debian/rules: Add *cupsFilter lines for PDF input
  * unused-override debian/{hpijs,hplip-data}.lintian
  * Lintian cleanup:
  * hpijs-ppds Depends: hpijs - lintian:stronger-dependency-implies-weaker
  * Update 14_charsign_fixes.dpatch
    - lintian:dpatch-missing-description
  * hplip.NEWS & hpijs-ppds.NEWS - lintian:syntax-error-in-debian-news-file
  * hplip-data Depends: python - perhaps should be called hplip-common?
    - lintian:python-script-but-no-python-dep
  * -x colorcal4form_base.ui distros.dat executable-not-elf-or-script
  * Ship small .xpm with hplip not -gui package
    - lintian:menu-icon-missing
  * hplip.lintian libhpip0 & libhpmud0 - not shared libs internal only
    - lintian:package-name-doesnt-match-sonames
  * Update debian/hplip-doc.doc-base
    - lintian:doc-base-abstract-might-contain-extra-leading-whitespaces
  * hplip-doc.doc-base Section: System/Administration
    - lintian:doc-base-unknown-section
  * Cleanup hplip.lintian - linitan:unused-override
  * Cleanup *.desktop - lintian:desktop-entry-contains-encoding-key
  * Fixup hplip/presubj lintian:executable-not-elf-or-script
  * Add URL to hp-makeuri-uri-only-output.dpatch Description ##DP
  * Other issues:
  * Enable GNU/kFreeBSD builds - thanks Petr Salinger
    - FTBFS on GNU/kFreeBSD (fixup of debian/rules needed) (Closes:
    #497625)
  * Fixup hpojs-ppds.postinst s/cupsys/cups/ - thanks Michael Wagner
    - postinst invokes cupsys instead of cups (Closes: #498156)
  * Really apply hp-makeuri-uri-only-output.dpatch - thanks Avi Rozen
    - hp-makeuri -c does not print cups uri (Closes: #500183)

5924a6e... by Mark Purcell on 2008-09-01

Import patches-applied version 2.8.6.b-1 to applied/debian/lenny

Imported using git-ubuntu import.

Unapplied parent: 5e9736ce4393f93cf06991f3f26fc248b1c79c1f

5e9736c... by Mark Purcell on 2008-09-01

Import patches-unapplied version 2.8.6.b-1 to debian/lenny

Imported using git-ubuntu import.