ubuntu/+source/heat:applied/ubuntu/trusty-security

Last commit made on 2014-06-18
Get this branch:
git clone -b applied/ubuntu/trusty-security https://git.launchpad.net/ubuntu/+source/heat
Members of Ubuntu Server Dev import team can upload to this branch. Log in for directions.

Branch merges

Branch information

Name:
applied/ubuntu/trusty-security
Repository:
lp:ubuntu/+source/heat

Recent commits

d8b4c37... by Marc Deslauriers on 2014-05-23

Import patches-applied version 2014.1-0ubuntu1.1 to applied/ubuntu/trusty-security

Imported using git-ubuntu import.

Changelog parent: 1362941435705579ec66dad97b302fbbd2731bda
Unapplied parent: 8094dd670db65d97f3132c3a94bca021ac9f8764

New changelog entries:
  * SECURITY UPDATE: template URL information leakage
    - debian/patches/CVE-2014-3801.patch: Don't dynamically create provider
      types in the global env in heat/engine/environment.py, added test to
      heat/tests/test_provider_template.py.
    - CVE-2014-3801

8094dd6... by Marc Deslauriers on 2014-05-23

Don't dynamically create provider types in the global env

Gbp-Pq: CVE-2014-3801.patch.

14751e6... by Marc Deslauriers on 2014-05-23

Change sudoers directory to be sudoers.d

Gbp-Pq: sudoers_patch.patch.

247978e... by Marc Deslauriers on 2014-05-23

Dont install python-qpid

Gbp-Pq: fix-requirements.patch.

952ee49... by Marc Deslauriers on 2014-05-23

Default to using sqlite

Gbp-Pq: default-sqlite.patch.

24f316b... by Marc Deslauriers on 2014-05-23

Import patches-unapplied version 2014.1-0ubuntu1.1 to ubuntu/trusty-security

Imported using git-ubuntu import.

Changelog parent: 0d1c209326a297304e8fbbcfae68b89e4d04b119

New changelog entries:
  * SECURITY UPDATE: template URL information leakage
    - debian/patches/CVE-2014-3801.patch: Don't dynamically create provider
      types in the global env in heat/engine/environment.py, added test to
      heat/tests/test_provider_template.py.
    - CVE-2014-3801

1362941... by Chuck Short on 2014-04-17

Import patches-applied version 2014.1-0ubuntu1 to applied/ubuntu/trusty-proposed

Imported using git-ubuntu import.

Changelog parent: fb56d0824630c8b1954e37a6620db293beaa6c80
Unapplied parent: 806017fbd414cf12dfba413aba5f59519aa34878

New changelog entries:
  [ Chuck Short ]
  * New upstream release. (LP: #1299055)
  * debian/heat-common.postinst: Create directory before changing
    permissions. (LP: #1267557)
  [ Corey Bryant ]
  * New upstream release (LP: #1299055).

0d1c209... by Chuck Short on 2014-04-17

Import patches-unapplied version 2014.1-0ubuntu1 to ubuntu/trusty-proposed

Imported using git-ubuntu import.

Changelog parent: 13b72fd4539694327398092628ac6709b375ac0b

New changelog entries:
  [ Chuck Short ]
  * New upstream release. (LP: #1299055)
  * debian/heat-common.postinst: Create directory before changing
    permissions. (LP: #1267557)
  [ Corey Bryant ]
  * New upstream release (LP: #1299055).

806017f... by Chuck Short on 2014-04-17

Change sudoers directory to be sudoers.d

Gbp-Pq: sudoers_patch.patch.

9205c4f... by Chuck Short on 2014-04-17

Dont install python-qpid

Gbp-Pq: fix-requirements.patch.