ubuntu/+source/gvfs:debian/buster

Last commit made on 2019-06-11
Get this branch:
git clone -b debian/buster https://git.launchpad.net/ubuntu/+source/gvfs
Members of Ubuntu Server Dev import team can upload to this branch. Log in for directions.

Branch merges

Branch information

Name:
debian/buster
Repository:
lp:ubuntu/+source/gvfs

Recent commits

3fe3cdd... by Simon McVittie on 2019-06-11

Import patches-unapplied version 1.38.1-5 to debian/sid

Imported using git-ubuntu import.

Changelog parent: a98d9378cf79de79adafc5eba50aaa0a695c7b61

New changelog entries:
  * Team upload
  * d/p/gvfsdaemon-Check-that-the-connecting-client-is-the-same-u.patch:
    Add missing authentication, preventing a local attacker from connecting
    to an abstract socket address learned from netstat(8) and issuing
    arbitrary D-Bus method calls
  * d/p/gvfsdaemon-Only-accept-EXTERNAL-authentication.patch:
    Harden private D-Bus connection by rejecting the more complicated
    DBUS_COOKIE_SHA1 authentication mechanism and only accepting EXTERNAL.

a98d937... by Simon McVittie on 2019-06-05

Import patches-unapplied version 1.38.1-4 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 4594943e224ae6a5b7e22f869d81b3a8a74fa98d

New changelog entries:
  * Team upload
  * Update from upstream gnome-3-30 branch to fix the admin backend
    (Closes: #929755)
    - Implement query_info_on_read/write to fix some race conditions
      (CVE-2019-12448)
    - Ensure that created files get the correct ownership (CVE-2019-12247)
    - Ensure that copied files get the correct ownership (CVE-2019-12449)
  * Remove obsolete version number from fuse dependency.
    gvfs needs fuse (>= 2.8.4), but that version is older than oldstable,
    so we can safely simplify to "Depends: fuse".
    The versioned dependency is not satisfied by fuse3's unversioned
    "Provides: fuse", but the unversioned dependency is. (Closes: #927221)

4594943... by Simon McVittie on 2019-02-09

Import patches-unapplied version 1.38.1-3 to debian/sid

Imported using git-ubuntu import.

Changelog parent: a946d40d9cdd77187c7d5885e675ae5055c3b02d

New changelog entries:
  * Team upload
  * d/p/admin-Prevent-access-if-any-authentication-agent-isn-t-av.patch:
    Add patch from upstream to prevent members of the sudo group from
    bypassing the intended password check for privileged access to files
    via the admin: backend if no polkit authentication agents are
    available (CVE-2019-3827, Closes: #921816)
  * d/p/*: Update to upstream gnome-3-30 branch, commit 1.38.1-9-gd4dab113
    - admin: Fix CVE-2019-3827 (see above)
    - autorun: Don't crash if an autorun file is not valid UTF-8
    - mtp: Don't busy-loop retrying reading an event after failure
    - udisks2: Reinstate support for deprecated comment=x-gvfs-show fstab
      option syntax (but please use x-gvfs-show instead)
    - tests: Use the right SMB port if running in the sandbox
    - Update translations: eu, sk, sr
  * d/gbp.conf: Configure for debian/buster and upstream/1.38.x branches
  * d/control: Use debian/buster branch in Vcs-Git

a946d40... by Jeremy Bicha on 2018-12-27

Import patches-unapplied version 1.38.1-2 to debian/sid

Imported using git-ubuntu import.

Changelog parent: a2f1da359025ac3c42ed5f1f38620d46af45b0f1

New changelog entries:
  * Add -Wl,-O1 to our LDFLAGS
  * debian/rules: Use dh_auto_build instead of make
  * Bump Standards-Version to 4.3.0

a2f1da3... by Sebastien Bacher on 2018-11-13

Import patches-unapplied version 1.38.1-1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 65f5f3c2f1530fe0070e3acc1551522c6ebc674b

New changelog entries:
  * New upstream release

65f5f3c... by Iain Lane on 2018-09-11

Import patches-unapplied version 1.38.0-2 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 1319a484ba6cb507878fc7ab15c9b2bc644c7963

New changelog entries:
  * Install manpages into gvfs-common, as they were previously

1319a48... by Iain Lane on 2018-09-11

Import patches-unapplied version 1.38.0-1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 0a713d2b1716e7f9decb543bbe3f6412ae8e7c85

New changelog entries:
  * New upstream translation release
  * Update gbp.conf to pkg-gnome's common file
  * Bump Standards-Version to 4.2.1 (no changes required)
  * Revert "d/watch: Watch for development versions"
  * Build manpages for the deprecated commands too

0a713d2... by Simon McVittie on 2018-08-17

Import patches-unapplied version 1.37.90-1 to debian/experimental

Imported using git-ubuntu import.

Changelog parent: 68eb789c132ad7c5203150dfd03e5865835b3cc5

New changelog entries:
  * Team upload
  * d/watch: Watch for development versions
  * New upstream release
  * debian/docs: Don't install AUTHORS, no longer provided upstream
  * debian/docs: Install README.md
  * d/source/lintian-overrides: Remove, no longer needed
    (the Autotools build system has been removed)
  * Update Meson build-dependency to 0.46.0
  * Update GLib build-dependency to 2.57.2
  * Reinstate deprecated command-line tools via debian/extra/ for now
  * d/p/01_modules_dir.patch: Drop, no longer required
  * d/p/04_hurd_path_max.patch: Drop, no longer required
  * Build-depend on polkit 0.105-18~ for ITS rules
  * d/p/Remove-version-from-polkit-gobject-dependency.patch:
    Don't require polkit 0.114 for ITS rules since we have backported
    that feature
  * Normalize packaging with wrap-and-sort -ab
  * Standards-Version: 4.2.0
  * Deprecate the gvfs-bin package
  * Use /usr/share/dpkg/default.mk
  * Tell dpkg-shlibdeps about our private libraries

68eb789... by Simon McVittie on 2018-07-26

Import patches-unapplied version 1.36.2-1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: c6adc3a584137fd7230b9e34e940109fbfa2628f

New changelog entries:
  * Team upload
  [ Rob McQueen ]
  * Add missing lsof dependency to fix UDisks2VolumeMonitor (!1)
  [ Simon McVittie ]
  * New upstream release
  * d/control.in: Remove trailing spaces
  * Refresh patch series
  * d/tests/control: Depend on dbus, not dbus-x11 (Closes: #835892)
  * tests: Depend on openssh-client, for ssh-keygen
  * tests: Depend on policykit-1, for pkcheck
  * tests: Depend on python3-dbus, for `import dbus`
  * Standards-Version: 4.1.5 (no changes required)
  * Set Rules-Requires-Root to no
  * Override Lintian warning for configure.ac. Now that this package
    builds with meson, Autotools bugs are harmless.

c6adc3a... by Jeremy Bicha on 2018-04-14

Import patches-unapplied version 1.36.1-1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: e498063f376eaed13fae271c4237c56275c10ad3

New changelog entries:
  * New upstream release
  * Drop obsolete dh_translations override
  * Bump Standards-Version to 4.1.4