ubuntu/+source/grub:debian/squeeze

Last commit made on 2010-12-09
Get this branch:
git clone -b debian/squeeze https://git.launchpad.net/ubuntu/+source/grub
Members of Ubuntu Server Dev import team can upload to this branch. Log in for directions.

Branch merges

Branch information

Name:
debian/squeeze
Repository:
lp:ubuntu/+source/grub

Recent commits

4f74cfb... by Colin Watson on 2010-12-08

Import patches-unapplied version 0.97-64 to debian/sid

Imported using git-ubuntu import.

Changelog parent: ae9164c503b6ffe85b634b923cc76bdfb3808edc

New changelog entries:
  * Exit silently from zz-update-grub kernel hook if update-grub does not
    exist (e.g. if grub has been removed but not purged; closes: #606377).

ae9164c... by Colin Watson on 2010-09-03

Import patches-unapplied version 0.97-63 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 6c9d8619d89ca89b1465f4f101e5997dd65122e1

New changelog entries:
  * Make /etc/kernel/postrm.d/zz-update-grub a real file rather than a
    symlink (closes: #592105).
  * Restrict watch file to match only GRUB Legacy versions.
  * Escape single quotes when removing them from $mode in zz-update-grub, so
    that this works when /bin/sh is bash (thanks, Will Dyson).
  * Run update-grub from kernel hooks if DEB_MAINT_PARAMS is unset, for
    compatibility with old kernel packages. This may produce duplicate runs
    of update-grub, but that's better than not running it at all.
  * Adjust Maintainer field capitalisation to be consistent with grub2.

6c9d861... by Colin Watson on 2010-08-06

Import patches-unapplied version 0.97-62 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 418a7548e5d86fbe234a68b36c4c6173ae4b89aa

New changelog entries:
  * Lower priority to extra (also done in archive overrides).
  * Add kernel hook scripts and remove any uses of update-grub as a
    postinst_hook or postrm_hook in /etc/kernel-img.conf (closes: #587266).
    Thanks to Ben Hutchings for advice and to Harald Braumann for an early
    implementation.

418a754... by Colin Watson on 2010-04-19

Import patches-unapplied version 0.97-61 to debian/squeeze

Imported using git-ubuntu import.

Changelog parent: cf9ce153b6e46bbf12a6338d8da168debfc97a5d

New changelog entries:
  * Build-depend on gcc-4.3 (closes: #564451).
  * Add myself to Uploaders.

cf9ce15... by Felix Zielcke on 2010-01-03

Import patches-unapplied version 0.97-60 to debian/sid

Imported using git-ubuntu import.

Changelog parent: b7d7d45b6f0cc6ba58706f0b926afbf02eff629b

New changelog entries:
  [ Robert Millan ]
  * Turn multiboot-doc into a dummy transitional package.
  * Keep building with GCC 4.3. We didn't test GRUB Legacy with GCC 4.4,
    and it's not worth the risk since it's being replaced by GRUB 2.
  * Remove patches/cvs-sync.patch. We use Bazaar branching now.
  * Fix FTBFS due to texi2html change in default output directory.

b7d7d45... by Robert Millan <email address hidden> on 2009-10-02

Import patches-unapplied version 0.97-59 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 86ce343439bec3c33c10ef2642d9b9b7d03039df

New changelog entries:
  [ Felix Zielcke ]
  * Use /usr/lib/grub-legacy/grub-set-default if it exists in
    update-grub, in preparation for GRUB 2's grub-set-default.
  [ Robert Millan ]
  * Rename grub.info to grub-legacy.info to avoid conflict with upcoming
    GRUB 2 manual.

86ce343... by Robert Millan <email address hidden> on 2009-09-04

Import patches-unapplied version 0.97-58 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 89cf3c91e94e1df4328a327362449272d10b655d

New changelog entries:
  * Upgrade path is now GRUB 2.
  * Remove the /sbin/grub-install and update-grub wrapper.
  * Edit /etc/kernel-img.conf with sed in grub-legacy.postinst if it
    still uses /sbin/update-grub. According to Colin Watson policy seems
    to allow this.
  * Add to all packages.
  * Add a depency on `dpkg (>= 1.15.4) | install-info' for grub-legacy-
    doc.
  * Fix the 2 statically-linked-binary lintian overrides.
  * Update Standards-Version to 3.8.3.
  * Build depend on lib32ncurses5-dev on amd64. (Closes: #423273)
  * Change the grub/migrate_from_legacy template a bit to fix the
    lintian warnings for it.
  * Add #DEBHELPER# token to grub.postinst.

89cf3c9... by Robert Millan <email address hidden> on 2009-08-12

Import patches-unapplied version 0.97-56 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 20fe2b070a5bc842d944997ca0dade6b49f434a9

New changelog entries:
  [ Felix Zielcke ]
  * Really add DM-Upload-Allowed: yes.
  [ Robert Millan ]
  * Remove GNU/kFreeBSD support, since it can't be used without an external
    loader that is not in Debian. GNU/kFreeBSD users should upgrade to
    GRUB 2.

20fe2b0... by Felix Zielcke on 2009-07-21

Import patches-unapplied version 0.97-55 to debian/sid

Imported using git-ubuntu import.

Changelog parent: d3c149357262232aab4bb5647be7a38596db788b

New changelog entries:
  * Add a Provides: grub to grub-legacy.
  * Update Standards version to 3.8.2. No changes needed.
  * patches/xfs_freeze.diff: Fix "/usr/sbin/grub-install: line 374: [:
    =: unary operator expected". (Closes: #513216)
  * Add myself to Uploaders and set DM-Upload-Allowed: yes.
  * Remove Jason and Otavio from Uploaders with their permission.
  * Fix a spelling error in grub/migrate_from_legacy template
    (s/untill/until). (Closes: #537815)
  * Rename XS-X-Vcs-Svn flag to Vcs-Svn.
  * Don't ignore make distclean errors
  * Fix a spelling error in the description of grub-legacy
    (s/maintainance/maintenance/).
  * Bump to debhelper compat level 5.

d3c1493... by Robert Millan <email address hidden> on 2009-07-11

Import patches-unapplied version 0.97-54 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 114d32840b596e5188689def3e191cd4691ba658

New changelog entries:
  * Rename grub to grub-legacy.
  * Add a debconf note explaining that GRUB Legacy is now deprecated.