ubuntu/+source/gnutls26:ubuntu/vivid-devel

Last commit made on 2015-03-27
Get this branch:
git clone -b ubuntu/vivid-devel https://git.launchpad.net/ubuntu/+source/gnutls26
Members of Ubuntu Server Dev import team can upload to this branch. Log in for directions.

Branch merges

Branch information

Name:
ubuntu/vivid-devel
Repository:
lp:ubuntu/+source/gnutls26

Recent commits

5712b46... by Adam Conrad on 2015-03-27

Import patches-unapplied version 2.12.23-18ubuntu1 to ubuntu/vivid-proposed

Imported using git-ubuntu import.

Changelog parent: c596d4127a67434bf85eb565e67d3ad12dbe9573

New changelog entries:
  * Merge with Debian; remaining changes:
    - Link test-lock and test-thread_create with -Wl,--no-as-needed; see
      https://lists.gnu.org/archive/html/bug-gnulib/2013-10/msg00017.html.
    - debian/rules: Set CC on cross-builds, so autoconf doesn't lose its mind.
  * Dropped changes:
    - restore sipsak Breaks, ours is now new enough to deal with this.
    - drop CVE-2014-3466 security upload, included in debian.
    - debian/patches/99_update-libtool.patch: Debian uses autoreconf.

c596d41... by Andreas Metzler <email address hidden> on 2014-08-23

Import patches-unapplied version 2.12.23-18 to debian/experimental

Imported using git-ubuntu import.

Changelog parent: f59f84c529a97f7db9418a2b1e7b65993c0e6303

New changelog entries:
  * 32_fix-gcrypt-private-api-usage.patch from gpg4win: Allow building
    against libgcrypt20. (Thanks, Werner Koch for the pointer.)
  * (Build-)depend on libgcrypt20-dev.

f59f84c... by Andreas Metzler <email address hidden> on 2014-07-03

Import patches-unapplied version 2.12.23-17 to debian/sid

Imported using git-ubuntu import.

Changelog parent: abc82e82715cade3b9b264b2b2bcca7805f82ea1

New changelog entries:
  [ Mauricio Faria de Oliveira ]
  * Add fixes for automake (30_fix_automake_oldies.patch).
  * Run dh-autoreconf on build. (Closes: #751796)
  [ Andreas Metzler ]
  * 31_linkage-gpgerror.diff: Stop unnecessary linkage against libgpg-error
    caused by buildung with up to date lib-link.m4.

abc82e8... by Andreas Metzler <email address hidden> on 2014-05-31

Import patches-unapplied version 2.12.23-16 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 28881554044d81cc0556e44c2aa7de62a213958a

New changelog entries:
  * Drop libgnutls26-dbg Conflicts with libgnutls13-dbg, libgnutls28-dbg.
    These have been unnecessary since we started using dh compat v9, where
    debugging symbols are installed to /usr/lib/debug/.build-id.
  * 29_Prevent-memory-corruption.diff from upstream GIT. Fix memory corruption
    on client side caused by specifically crafted ServerHello.
    GNUTLS-SA-2014-3 / CVE-2014-3466

2888155... by Andreas Metzler <email address hidden> on 2014-04-27

Import patches-unapplied version 2.12.23-15 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 4f3a298367df4ace02fe175e84254dab5075bee5

New changelog entries:
  * 28_use_gnutls_global_set_time.diff: Use gnutls_global_set_time_function()
    in chainverify test to fix a testsuite failure on amd64. Closes: #746018

4f3a298... by Andreas Metzler <email address hidden> on 2014-04-16

Import patches-unapplied version 2.12.23-14 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 0ead79e4c01a1687d77af950b8db6c4cef3339a1

New changelog entries:
  * Move OpenSSL wrappper over to gnutls28. Stop providing
    libgnutls-openssl-dev and building libgnutls-openssl27.

0ead79e... by Andreas Metzler <email address hidden> on 2014-03-01

Import patches-unapplied version 2.12.23-13 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 9b49688af9e6dae7dc7ab8f9298b50ea91931ec3

New changelog entries:
  * 27_CVE-2014-0092.diff by Nikos Mavrogiannopoulos: Fix certificate
    validation issue. CVE-2014-0092

9b49688... by Andreas Metzler <email address hidden> on 2014-02-15

Import patches-unapplied version 2.12.23-12 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 06b9349567402c88984dcab2164f1e2b8e888d52

New changelog entries:
  * 26_fix_rejection-of-v1-intermedi.diff pulled and unfuzzed from GIT 3.x:
    A version 1 intermediate certificate will be considered as a CA
    certificate by default (something that deviates from the documented
    behavior).
    CVE-2014-1959 / GNUTLS-SA-2014-1

06b9349... by Andreas Metzler <email address hidden> on 2014-02-08

Import patches-unapplied version 2.12.23-11 to debian/sid

Imported using git-ubuntu import.

Changelog parent: cb056311dc675b1af9b274ce012626457231e0bd

New changelog entries:
  * (Build-)Depend on libtasn1-6-dev instead of on transitional libtasn1-3-dev
    package.

cb05631... by Andreas Metzler <email address hidden> on 2014-01-27

Import patches-unapplied version 2.12.23-10 to debian/sid

Imported using git-ubuntu import.

Changelog parent: aeea19313f9593cd4ba059fde02d66773c3b746c

New changelog entries:
  * Point vcs* to git.
  * Fix build on or1k (OpenRISC), thanks to Christian Svensson.
    Closes: #736750
    + Drop (build-)depends on libp11-kit-dev on or1k which is lacking libffi
      currently.
    + Do not use chrpath if we are cross compiling.
  * Upload to experimental.
  * Built against libtasn1-6.