ubuntu/+source/gnutls26:debian/lenny

Last commit made on 2010-01-30
Get this branch:
git clone -b debian/lenny https://git.launchpad.net/ubuntu/+source/gnutls26
Members of Ubuntu Server Dev import team can upload to this branch. Log in for directions.

Branch merges

Branch information

Name:
debian/lenny
Repository:
lp:ubuntu/+source/gnutls26

Recent commits

d8b772e... by Giuseppe Iuculano on 2009-11-01

Import patches-unapplied version 2.4.2-6+lenny2 to debian/lenny

Imported using git-ubuntu import.

Changelog parent: 02a21dec3e9d6033220560f0c8893b270af5d55b

New changelog entries:
  * Non-maintainer upload by the Security Team.
  * Fixed CVE-2009-2730: a vulnerability related to NUL bytes in X.509
    certificate name fields. (Closes: #541439) GNUTLS-SA-2009-4

02a21de... by Florian Weimer on 2009-02-23

Import patches-unapplied version 2.4.2-6+lenny1 to debian/lenny

Imported using git-ubuntu import.

Changelog parent: ebf14c864ad8894a1fcef108ef5501f02031fca3

New changelog entries:
  * Add patch from Simon Josefsson to reenable X.509v1 support for root
    CAs. Closes: #514807, #514735.

ebf14c8... by Andreas Metzler <email address hidden> on 2009-02-07

Import patches-unapplied version 2.4.2-6 to debian/sid

Imported using git-ubuntu import.

Changelog parent: ace2dc3df0150bbc8b0dd42b087db10a65ab5d54

New changelog entries:
  * New patches, syncing with 2.4.3 upstream oldstable release:
    + 24_intermedcertificate.patch If a non-root certificate ist trusted
      gnutls certificateificate verification stops there instead of checking
      up to the root of the certificate chain.
    + 22_whitespace.patch - Whitespace only changes, to make it possible to
      apply upstream fixes without manual changes.
    + 25_bufferoverrun.patch. Fix buffer overrun bug in
      gnutls_x509_crt_list_import.
      http://news.gmane.org/find-root.php?message_id=%3c000001c91d6e%2463059c90%242910d5b0%24%40com%3e

ace2dc3... by Andreas Metzler <email address hidden> on 2009-01-31

Import patches-unapplied version 2.4.2-5 to debian/sid

Imported using git-ubuntu import.

Changelog parent: fd6446129caa757cee8d9bda7a1ffe624ff9232c

New changelog entries:
  * Pull two patches from upstream stable branch to make gnutls behavior
    match documentation:
   + patch 23_permit_v1_CA.diff:Accept v1 x509 CA
     certs if GNUTLS_VERIFY_ALLOW_ANY_X509_V1_CA_CRT and/or
     GNUTLS_VERIFY_ALLOW_X509_V1_CA_CRT were supplied. Closes: #509593
   + 22_deprecate_md2_md5_x509_validation.diff: Verifying untrusted X.509
     certificates signed with RSA-MD2 or RSA-MD5 will now fail with a
     GNUTLS_CERT_INSECURE_ALGORITHM verification output.

fd64461... by Andreas Metzler <email address hidden> on 2008-12-06

Import patches-unapplied version 2.4.2-4 to debian/sid

Imported using git-ubuntu import.

Changelog parent: e1007a83f982a25ef842b356e5f2ee26d6491ec1

New changelog entries:
  * Add Simon Josefsson to uploaders.
  * Another fix for the verification fix. Some correct certificate chains were
    not recognized as verified. Closes: #507633

e1007a8... by Andreas Metzler <email address hidden> on 2008-11-12

Import patches-unapplied version 2.4.2-3 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 6b7a4daceddf4a520936732320146f3923ed1432

New changelog entries:
  * Fix a crash on trying to verify self-signed certificates introduced by the
    patch for CVE-2008-4989. Closes: #505279

6b7a4da... by Andreas Metzler <email address hidden> on 2008-11-10

Import patches-unapplied version 2.4.2-2 to debian/sid

Imported using git-ubuntu import.

Changelog parent: d93374881c52d62cfe1fed2535a25fefe5872614

New changelog entries:
  * [CVE-2008-4989.diff] Fix man in the middle attack for certificate
    verification. CVE-2008-4989 GNUTLS-SA-2008-3

d933748... by Andreas Metzler <email address hidden> on 2008-07-01

Import patches-unapplied version 2.4.2-1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 6ff7d79365d6491a13463bc82183d417eae63830

New changelog entries:
  * New upstream bugfix release.
  * Up to date gnutls-cli manpage. Closes: #492775

6ff7d79... by Andreas Metzler <email address hidden> on 2008-07-01

Import patches-unapplied version 2.4.1-1 to debian/lenny

Imported using git-ubuntu import.