ubuntu/+source/gnutls26:applied/ubuntu/trusty-updates

Last commit made on 2017-06-13
Get this branch:
git clone -b applied/ubuntu/trusty-updates https://git.launchpad.net/ubuntu/+source/gnutls26
Members of Ubuntu Server Dev import team can upload to this branch. Log in for directions.

Branch merges

Branch information

Name:
applied/ubuntu/trusty-updates
Repository:
lp:ubuntu/+source/gnutls26

Recent commits

d8df2c3... by Marc Deslauriers on 2017-06-12

Import patches-applied version 2.12.23-12ubuntu2.8 to applied/ubuntu/trusty-security

Imported using git-ubuntu import.

Changelog parent: f3b156cbbdf6628397aa225d62d83c69803f094e
Unapplied parent: 92dc66b2d2ec733517d4688cecbd32f2473d6990

New changelog entries:
  * SECURITY UPDATE: DoS and possible code execution via OpenPGP
    certificate decoding
    - debian/patches/CVE-2017-7869.patch: enforce packet limits in
      lib/opencdk/read-packet.c.
    - CVE-2017-7869

92dc66b... by Marc Deslauriers on 2017-06-12

[PATCH] cdk_pkt_read: enforce packet limits

Gbp-Pq: CVE-2017-7869.patch.

661ee42... by Marc Deslauriers on 2017-06-12

fix denial of service via warning alerts

Gbp-Pq: CVE-2016-8610.patch.

c9c3962... by Marc Deslauriers on 2017-06-12

[PATCH] opencdk: read_attribute: added more precise checks when reading stream

Gbp-Pq: CVE-2017-5337.patch.

5482ec7... by Marc Deslauriers on 2017-06-12

[PATCH] opencdk: cdk_pk_get_keyid: fix stack overflow

Gbp-Pq: CVE-2017-5336.patch.

8ed7171... by Marc Deslauriers on 2017-06-12

[PATCH] opencdk: added error checking in the stream reading functions

Gbp-Pq: CVE-2017-5335.patch.

6ddd383... by Marc Deslauriers on 2017-06-12

when comparing a CA certificate with the trusted list compare

Gbp-Pq: compare_ca_name_and_key.patch.

d18d365... by Marc Deslauriers on 2017-06-12

[PATCH] _gnutls_session_sign_algo_enabled: do not consider any values from the extension data to decide acceptable algorithms

Gbp-Pq: CVE-2015-7575.patch.

ede522d... by Marc Deslauriers on 2017-06-12

Fix TLS Poodle

Gbp-Pq: fix_tls_poodle.patch.

abade9e... by Marc Deslauriers on 2017-06-12

[PATCH] Added fix for GNUTLS-SA-2015-1

Gbp-Pq: CVE-2015-0282.patch.