ubuntu/+source/gnome-user-share:ubuntu/natty-devel

Last commit made on 2011-04-13
Get this branch:
git clone -b ubuntu/natty-devel https://git.launchpad.net/ubuntu/+source/gnome-user-share
Members of Ubuntu Server Dev import team can upload to this branch. Log in for directions.

Branch merges

Branch information

Name:
ubuntu/natty-devel
Repository:
lp:ubuntu/+source/gnome-user-share

Recent commits

7388e88... by Sebastien Bacher on 2011-04-13

Import patches-unapplied version 2.30.2-0ubuntu2 to ubuntu/natty

Imported using git-ubuntu import.

Changelog parent: 87661b875683ed5c530fab94823cfc65483c83f0

New changelog entries:
  * No change rebuild after promotion to get the translations exported

87661b8... by Robert Ancell on 2011-03-11

Import patches-unapplied version 2.30.2-0ubuntu1 to ubuntu/natty

Imported using git-ubuntu import.

Changelog parent: a94b0e86e3562e5c62fd93a3dc0e3dcf9f85fee6

New changelog entries:
  * New upstream release
  * debian/control:
    - Use libnotify4-dev instead of libnotify-dev

a94b0e8... by Artur Rona on 2010-12-26

Import patches-unapplied version 2.30.1-1ubuntu2 to ubuntu/natty

Imported using git-ubuntu import.

Changelog parent: fecdeea33e9d2d48f84aebc71356054facc8cc4b

New changelog entries:
  * debian/control: Drop [!linux-any] from Build-Depends to fix FTBFS.

fecdeea... by Artur Rona on 2010-12-26

Import patches-unapplied version 2.30.1-1ubuntu1 to ubuntu/natty

Imported using git-ubuntu import.

Changelog parent: 637cbf022284a904b3b98cbfccae3a3ae7d348db

New changelog entries:
  * Merge from debian unstable. Remaining changes:
    - debian/control:
      + Build-depend on rarian-compat rather than scrollkeeper.
      + Add Vcs-Bzr link related to Ubuntu Desktop Team.
      + Suggests the apache2.2-bin and libapache2-mod-dnssd binaries
        rather than depends on those, we want obex push to work out
        of the box but we don't really need webdav and the apache
        binaries on the default installation.
    - debian/dirs: Dropped, we don't need to create /usr/share/gnome.
    - debian/gconf-defaults: Enable notifications on receipt of files
      by default, when obex push is enabled.
    - debian/patches/01_notification.patch: Display an alert box instead
      of a notification for files received.
    - debian/patches/02_bluetooth_optional.patch: Dropped, it's enables
      Bluetooth support to be configurable at build-time. We don't
      actually use it, it adds a lot of #ifdef's to the code, and requires
      some effort to port it to the new version.
    - debian/patches/04_webdav_optional.patch:
      + Ensure the WebDAV sharing toggle button clears if Apache could
        not be started.
      + De-senstize the WebDAV UI components if the suggested packages
        are not available for WebDAV sharing. Display a notice explaining
        why sharing cannot be enabled. This is a stop-gap measure until
        add a button in the UI for installing the required components
        via AptDaemon.
    - debian/patches/05_autostart_delay.patch: Add X-GNOME-Autostart-Delay
      key to autostart file to delay starting by 15 seconds.
    - debian/patches/90_relibtoolize.patch: Dropped, not needed anymore.
    - debian/{preinst,rules}: Don't move autostart file from
      /etc/xdg/autostart to /usr/share/gnome/autostart.
      Upstream use the former.
    - debian/rules: Don't install the Nautilus bar for Lucid. It's not
      that useful to people who don't have bluetooth hardware and is not
      easily disabled. In the future, this bar will hide when the
      hardware is not available.
  * debian/control: Use [!linux-any] instead [linux-any] to satisfy
    Build-Depends.

637cbf0... by Josselin Mouette <email address hidden> on 2010-10-19

Import patches-unapplied version 2.30.1-1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: cd0aa5eacfc347a491a131bc58a4ff4d60f203d4

New changelog entries:
  * Drop type-handling usage. Closes: #587876.
  * Bump standards version accordingly.
  * New upstream translation and bugfix release.
  * 03_NAUTILUS_IS_USER_SHARE.patch: dropped, merged upstream.
  * 90_relibtoolize.patch: regenerated.

cd0aa5e... by Luca Falavigna on 2010-04-04

Import patches-unapplied version 2.30.0-1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 1771a2cf873e6694ee074ce8043c3fc9b2bd0795

New changelog entries:
  [ Emilio Pozuelo Monfort ]
  * debian/watch:
    - Only track stable releases.
  [ Luca Falavigna ]
  * New upstream release.
  * Refresh patches for new upstream release:
    - 02_bluetooth_optional.patch
    - 90_relibtoolize.patch
  * debian/patches/03_makefile_error.patch:
    - Removed, fixed upstream.
  * debian/patches/03_NAUTILUS_IS_USER_SHARE.patch:
    - Fix use of undefined macro NAUTILUS_IS_SHARE.
  * debian/control.in:
    - Build-depend on libnautilus-extension-dev.
    - Bump Standards-Version to 3.8.4, no changes required.
  * debian/rules:
    - Do not consider libnautilus-share-extension a shared library.

1771a2c... by Luca Falavigna on 2010-01-17

Import patches-unapplied version 2.28.2-4 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 081b4a0110d74cd976eee4877e9b9581bf4b6468

New changelog entries:
  * debian/patches/02_bluetooth_optional.patch:
    - Re-add HAVE_BLUETOOTH macro, erroneously removed (Closes: #563614).
  * debian/patches/90_relibtoolize.patch:
    - Regenerate to pick the above change.

081b4a0... by Andrea Veri on 2010-01-15

Import patches-unapplied version 2.28.2-3 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 12fdf2b30992ebef87420173071114bd089fe8d1

New changelog entries:
  * debian/control.in:
    - adding back obex-data-server depends since g-u-s
      actually needs it and not obexd-server itself. (there's
      no GNOME package using obexd-server at the moment)

12fdf2b... by Luca Falavigna on 2009-12-22

Import patches-unapplied version 2.28.2-2 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 899af6f3a7b1a2a9d699b0b0d23f4656c9c5b331

New changelog entries:
  * debian/patches/90_relibtoolize.patch:
    - Regenerate it from scratch, previous attempt was unsuccessful and
      caused build failures on some ports.
  [ Josselin Mouette ]
  * Depend on obexd-server, not obex-data-server.
  [ Luca Falavigna ]
  * New upstream bugfix release.
  * Refresh patches for new upstream release.
  * debian/control:
    - Add libunique-dev to Build-Depends.

899af6f... by Josselin Mouette <email address hidden> on 2009-11-14

Import patches-unapplied version 2.28.1-3 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 569dacfaca9186590a909f9b8d3810155d57509a

New changelog entries:
  * Oops, it’s not+linux-gnu, not not+linux.