ubuntu/+source/gnome-user-share:ubuntu/hardy-devel

Last commit made on 2008-03-28
Get this branch:
git clone -b ubuntu/hardy-devel https://git.launchpad.net/ubuntu/+source/gnome-user-share
Members of Ubuntu Server Dev import team can upload to this branch. Log in for directions.

Branch merges

Branch information

Name:
ubuntu/hardy-devel
Repository:
lp:ubuntu/+source/gnome-user-share

Recent commits

b9403ca... by Baptiste Mille-Mathias on 2008-02-29

Import patches-unapplied version 0.22-0ubuntu1 to ubuntu/hardy

Imported using git-ubuntu import.

Changelog parent: a191f0a00e55ef1fdfd23186d3ab0b237aede84f

New changelog entries:
  * New upstream release:
    - Add a simple ObexPush server
    - Add support for "Require pairing" for ObexFTP, for better security
    - Update to run with obex-data-server 0.3
    - Clarify a string in the UI
  * debian/control:
    - Add obex-data-server as Depends
    - Update the description to add it handles ObexFTP now
  * debian/copyright:
    - Added Bastien Nocera <email address hidden> as upstream author

a191f0a... by Loïc Minier on 2008-01-25

Import patches-unapplied version 0.21-0ubuntu1 to ubuntu/hardy

Imported using git-ubuntu import.

Changelog parent: 3ab4d4806907b68474635b7e2b27badf12c0bdbf

New changelog entries:
  * New upstream stable release.
    - Upstream NEWS:
      . Fix ObexFTP sharing allow deletes/writes when it shouldn't

3ab4d48... by Loïc Minier on 2008-01-22

Import patches-unapplied version 0.20-0ubuntu1 to ubuntu/hardy

Imported using git-ubuntu import.

Changelog parent: 1e000bdfd59bb4602a1a8aff91f6384284ed6e4d

New changelog entries:
  * New upstream stable release.
    - Upstream NEWS:
      . Add ObexFTP sharing through obex-data-server
      . Use XDG autostart to start gnome-user-share on login, exit
        straight-away if we're not sharing any files
      . Use glib to get the Public directory and set the password for our HTTP
        share
      . Disable the password entry if the password setting is "never"
      . Exit the configuration tool when the "Close" button from the window
        manager is pressed
    - Bump up build-deps to libdbus-1-dev >= 1.1.1, libglib2.0-dev >= 2.15.2.
    - Build-dep on libdbus-glib-1-dev.

1e000bd... by Sebastian Dröge on 2007-04-15

Import patches-unapplied version 0.11-2 to ubuntu/gutsy

Imported using git-ubuntu import.

Changelog parent: b73b1c70cbdfb92f4bc9bcdf5bf5d823a148d883

New changelog entries:
  * Upload to unstable
  * New upstream release
  * debian/rules,
    debian/control:
    + Use gnome-pkg-tools to add the Gnome team to Uploaders
    + Add get-orig-source target
  * debian/patches/01_debianise-dav-user-conf.diff:
    + Updated for new upstream version

b73b1c7... by Sebastian Dröge on 2007-02-18

Import patches-unapplied version 0.10-4 to ubuntu/feisty

Imported using git-ubuntu import.

Changelog parent: 50c0b80b70b0366535a74f4defe617b542d23b6a

New changelog entries:
  * Urgency medium because of RC bugfix. This should go to etch.
  * debian/patches/01_debianise-dav-user-conf.diff:
    + Also load the mime module to allow usage of the TypesConfig directive
      (Closes: #411171)
  * debian/control:
    + Only build-depend on libselinux-dev on Linux platforms (Closes: #402135)
    + Updated to use my debian.org mail address

50c0b80... by Sebastian Dröge on 2006-10-17

Import patches-unapplied version 0.10-2 to ubuntu/feisty

Imported using git-ubuntu import.

Changelog parent: 56d807604540f6258045f5d8bf31453e9eacb7b4

New changelog entries:
  * Acknowledge NMU (Closes: #391259)
  * debian/control,
    debian/rules:
    + Add versioned apache2 dependency back but require apache 2.2
  * debian/control:
    + Update Standards-Version to 3.7.2
  * Non-maintainer upload.
  * Don't use a versioned dependency on apache2 (Closes: #391259).

56d8076... by Sebastian Dröge on 2006-04-19

Import patches-unapplied version 0.10-1 to ubuntu/edgy

Imported using git-ubuntu import.

Changelog parent: 7eeb16dc4347f7bcc971679c610051fb9993b9e5

New changelog entries:
  * New upstream release
  * debian/patches/01_debianise-dav-user-conf.diff:
    + Update for the new filenames and patch the apache 2.0 and 2.2 configs
  * Depend on apache2 (>= 2.0) and (<< 2.1). We need to rebuild when apache
    2.2 gets into Debian to get the correct config file link for apache
    created.
  * Add a autostart .desktop file and a small loader that loads
    gnome-user-share when it was enabled in the capplet. This way
    gnome-user-share is started again with the session when it was enabled
    before.
  * Added debian/watch
  * Added README to the package and patch it to include informations about
    avahi and improve the language a bit (02_README.diff) (Closes: #353180)
  * Updated to debhelper compat version 5
  * Upload to unstable
  * Add libxt-dev to Build-Depends to fix the failed configure check for X
  * Use --as-needed to get rid of unneeded dependencies

7eeb16d... by Sebastian Dröge on 2005-12-21

Import patches-unapplied version 0.9-1 to ubuntu/dapper

Imported using git-ubuntu import.

Changelog parent: 412ed719aa0219a28448d5620d9cd2a4ca165877

New changelog entries:
  * New upstream release
  * Adjusted Build-Depends for avahi 0.6
  * Upload to Debian (Closes: #283088)
  * New upstream release
  * Add new FSF address to the copyright file
  * New upstream release
  * Use avahi instead of howl and added Build-Depends for it
  * Made Build-Depends stricter

412ed71... by Jeff Waugh <email address hidden> on 2004-12-03

Import patches-unapplied version 0.4-1 to ubuntu/hoary

Imported using git-ubuntu import.