ubuntu/+source/gnome-shell:ubuntu/zesty-proposed

Last commit made on 2017-05-29
Get this branch:
git clone -b ubuntu/zesty-proposed https://git.launchpad.net/ubuntu/+source/gnome-shell
Members of Ubuntu Server Dev import team can upload to this branch. Log in for directions.

Branch merges

Branch information

Name:
ubuntu/zesty-proposed
Repository:
lp:ubuntu/+source/gnome-shell

Recent commits

ff0bd7c... by Jeremy Bicha on 2017-05-15

Import patches-unapplied version 3.24.2-0ubuntu0.1 to ubuntu/zesty-proposed

Imported using git-ubuntu import.

Changelog parent: f6143a5d9172029364bef7073063833215898d16

New changelog entries:
  * New upstream release (LP: #1690182)
  * Extend ubuntu-lightdm-user-switching.patch to allow
    locking screen using LightDM (LP: #1684205)
  * Allow lightdm to be an alternate recommends for gdm3 to avoid debconf
    question if a display manager is already installed (LP: #1690938)
  * Depend on caribou, needed for the Screen Keyboard (LP: #1589240)

f6143a5... by Jeremy Bicha on 2017-04-12

Import patches-unapplied version 3.24.1-0ubuntu1 to ubuntu/zesty-proposed

Imported using git-ubuntu import.

Changelog parent: c3d28d55d95b37cf3aecd82fc8ed6a37c5e828a3

New changelog entries:
  * New upstream release (LP: #1682238)

c3d28d5... by Jeremy Bicha on 2017-03-24

Import patches-unapplied version 3.24.0-0ubuntu2 to ubuntu/zesty-proposed

Imported using git-ubuntu import.

Changelog parent: a95aaf2917bb6836470fe4f96aeac262c27a4c44

New changelog entries:
  * Recommend switcheroo-control for dual GPU support (LP: #1671828)

a95aaf2... by Jeremy Bicha on 2017-03-21

Import patches-unapplied version 3.24.0-0ubuntu1 to ubuntu/zesty-proposed

Imported using git-ubuntu import.

Changelog parent: fe2167031feb580859cc4895ac6e8e79573e566f

New changelog entries:
  * New upstream translations release.
  * Bump minimum mutter to 3.24.0

fe21670... by Jeremy Bicha on 2017-03-14

Import patches-unapplied version 3.23.92-0ubuntu1 to ubuntu/zesty-proposed

Imported using git-ubuntu import.

Changelog parent: 5db682a9602da6108b4fbd65c06d101adb46a16d

New changelog entries:
  * New upstream release
  * debian/control.in:
    - Drop obsolete Build-Depends against telepathy-glib
    - Bump minimum mutter to 3.23.92
  * Drop git patches applied in new release

5db682a... by Jeremy Bicha on 2017-03-11

Import patches-unapplied version 3.23.91-0ubuntu4 to ubuntu/zesty-proposed

Imported using git-ubuntu import.

Changelog parent: 65133684cf5734678918e0ef4605b26e3e23ce3a

New changelog entries:
  * debian/control.in:
    - Recommend chrome-gnome-shell
    - Recommend xserver-xorg-legacy until all the proprietary NVIDIA
      drivers depend on it (LP: #1559576)

6513368... by Jeremy Bicha on 2017-03-10

Import patches-unapplied version 3.23.91-0ubuntu3 to ubuntu/zesty-proposed

Imported using git-ubuntu import.

Changelog parent: 50d1c5a82c72b27a6fd01867d4a88815fa53dc05

New changelog entries:
  * debian/control.in:
    - Depend on gir1.2-geoclue-2.0 (LP: #1671823)

50d1c5a... by Jeremy Bicha on 2017-03-02

Import patches-unapplied version 3.23.91-0ubuntu2 to ubuntu/zesty-proposed

Imported using git-ubuntu import.

Changelog parent: bbbc308e4be5b3f4c0fd9617519c0069f8145d68

New changelog entries:
  * Add patches to backport some commits from git:
    - git_fix_typos.patch
    - git_fix_telepathy_notifications.patch

bbbc308... by Jeremy Bicha on 2017-03-01

Import patches-unapplied version 3.23.91-0ubuntu1 to ubuntu/zesty-proposed

Imported using git-ubuntu import.

Changelog parent: 0f7335847693c600f8e60484438bf4e1751cccf7

New changelog entries:
  * Merge with Debian unstable. Remaining changes:
    - debian/control.in:
      + Update mutter dependencies
      + Depend on gir1.2-rsvg-2.0
      + Bump minimum gjs to 1.47.90
      + Depend on gnome-session which due to package
        split now contains only the session files
    - debian/patches/ubuntu-lightdm-user-switching.patch:
      + Allow user switching when using LightDM.
    - debian/patches/ubuntu_lock_on_suspend.patch
      + Respect Ubuntu's lock-on-suspend setting.
    - debian/gnome-shell.gsettings-override:
      + Replace firefox-esr with firefox
    - Don't install the 3.14 process-working file since
      we already did the 3.14 upgrade for 16.04 LTS
  * New upstream release

0f73358... by Simon McVittie on 2017-03-01

Import patches-unapplied version 3.22.3-2 to debian/sid

Imported using git-ubuntu import.

Changelog parent: b4b222563fa1865bed0623e65f8cdbcf874a0f03

New changelog entries:
  * d/control: Drop dependency on telepathy-mission-control-5. GNOME Shell
    has special integration for Telepathy if present, but does not depend
    on it. (Closes: #853908)
  * d/gnome-shell.gsettings-override: Do not force Empathy to be considered
    a favourite app