ubuntu/+source/gnome-disk-utility:ubuntu/raring

Last commit made on 2012-11-15
Get this branch:
git clone -b ubuntu/raring https://git.launchpad.net/ubuntu/+source/gnome-disk-utility
Members of Ubuntu Server Dev import team can upload to this branch. Log in for directions.

Branch merges

Branch information

Name:
ubuntu/raring
Repository:
lp:ubuntu/+source/gnome-disk-utility

Recent commits

cd59871... by Jeremy Bicha on 2012-11-15

Import patches-unapplied version 3.6.1-1ubuntu1 to ubuntu/raring-proposed

Imported using git-ubuntu import.

Changelog parent: 2f1e117f49aaa9f2d05d349afdc3437b1a9732c8

New changelog entries:
  * Resynchronize with Debian (LP: #1041665). Remaining change:
  * debian/control, debian/rules
    - Build-depend on and run dh-translations

2f1e117... by Michael Biebl on 2012-11-13

Import patches-unapplied version 3.6.1-1 to debian/experimental

Imported using git-ubuntu import.

Changelog parent: 50ace27dcd5f9b61eb991cd7fc4833ae4757125c

New changelog entries:
  * New upstream release. (Closes: #671494)
    - Major rewrite.
    - Renamed to GNOME Disks or simply Disks.
    - The libgdu library has been removed in favour of libudisks2.
  * Use xz compression for source tarballs.
  * Drop all binary packages besides gnome-disk-utility. (Closes: #646204)
  * Drop all patches, they are obsolete.
  * Bump debhelper compat level to 9.
  * Bump Standards-Version to 3.9.3.
  * Update Build-Depends according to configure.ac.
  * Make gnome-disk-utility depend on udisks2.
  * Remove the obsolete /etc/xdg/autostart/gdu-notification-daemon.desktop
    conffile on upgrades using the dh_installdeb maintscript facility.
  * Remove obsolete configure switch.
  * Update package description: palimpsest → GNOME Disks.
  * Update debian/copyright.

50ace27... by Michael Biebl on 2012-08-24

Import patches-unapplied version 3.0.2-3 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 753c79d306b7ed858631df32b828d8397e3eaf2e

New changelog entries:
  [ Ansgar Burchardt ]
  * debian/rules: Use xz compression for binary packages. (Closes: #683841)

753c79d... by Michael Biebl on 2011-10-13

Import patches-unapplied version 3.0.2-2 to debian/sid

Imported using git-ubuntu import.

Changelog parent: d5c809ec3e928edc4478adf46db386785da03273

New changelog entries:
  * Upload to unstable.
  * Update debian/libgdu0.symbols.

d5c809e... by Michael Biebl on 2011-07-08

Import patches-unapplied version 3.0.2-1 to debian/experimental

Imported using git-ubuntu import.

Changelog parent: e652ae9288f0234b2db8f61371ae2ab4999377e2

New changelog entries:
  * New upstream release.

e652ae9... by Michael Biebl on 2011-05-19

Import patches-unapplied version 3.0.0-2 to debian/experimental

Imported using git-ubuntu import.

Changelog parent: a26149768e1f43cdec6d5a442d32f2ce073226eb

New changelog entries:
  [ Martin Pitt ]
  * debian/watch: Update for new upstream URL.
  [ Michael Biebl ]
  * Merge changes from unstable branch.
  * Refresh debian/patches/00git-palimpsest-small-screens.patch.
  * Avoid partial upgrades involving gnome-disk-utility and libgdu-gtk.
    Bump the symbol versions in libgdu-gtk0.symbols to 3.0.0 and add
    Breaks: gnome-disk-utility (<< 3.0.0) to libgdu-gtk0 as a workaround for
    libgdu-gtk building against GTK3 (which changes its ABI) but not bumping
    the soname. (Closes: #626821)

a261497... by Sjoerd Simons on 2011-05-14

Import patches-unapplied version 3.0.0-1 to debian/experimental

Imported using git-ubuntu import.

Changelog parent: 5c4893dc143b2526fd03d3b3803714543c800272

New changelog entries:
  * New upstream release
  * debian/patches/01_delay_autostart.patch: Updated
  * debian/control: Update build-depends
  * debian/gbp.conf: Change tarball compression to bz2
  * debian/libgdu-dev.install: Don't try to install gtk-doc documentation,
    it's not available anymore
  * Update symbols files

5c4893d... by Martin Pitt on 2010-03-04

Import patches-unapplied version 2.29.90-2 to debian/experimental

Imported using git-ubuntu import.

Changelog parent: 748e9a26e4a3c07b9b8b10f9f00ae9dedf7721e1

New changelog entries:
  [ Michael Biebl ]
  * debian/libgdu-gtk0.symbols
    - Bump symbol versions to 2.29.90 for all symbols that were added after
      version 2.28.1.
  * debian/control
    - Bump Build-Depends on libglib2.0-dev to (>= 2.22).
  [ Martin Pitt ]
  * Move gtk-doc files (which describe the API, not the palimpsest program)
    from gnome-disk-utility to libgdu-dev. Add an appropriate
    Conflicts/Replaces. (LP: #517698)

748e9a2... by Martin Pitt on 2010-02-23

Import patches-unapplied version 2.29.90-1 to debian/experimental

Imported using git-ubuntu import.

Changelog parent: 652a02ff45449f783dd95b3020a4192a2d328a62

New changelog entries:
  * New upstream release.
  * 01_delay_autostart.patch: Refresh for new release.
  * debian/libgdu0.symbols: Add new symbol from this release, and bump symbol
    versions from previous git snapshot versions to 2.29.90.

652a02f... by Martin Pitt on 2010-02-23

Import patches-unapplied version 2.29.0~git20100222.e85476-1 to debian/experimental

Imported using git-ubuntu import.

Changelog parent: 34021c9fdbb462bf406840688dd0b7bc7190586c

New changelog entries:
  [ Michael Biebl ]
  * Git snapshot of the upcoming 2.29.0 release:
    - Port to udisks.
    - Grid based UI for palimpsest.
    - Initial support for LVM2.
  * Remove patches
    - debian/patches/01-reiserfs-support.patch (merged upstream)
    - debian/patches/02-link-against-libx11-for-xkb.patch (merged upstream)
    - debian/patches/99-autoreconf.patch (no longer required)
  * debian/control
    - Update package descriptions for the DeviceKit-disks → udisks renaming.
    - Add Build-Depends on libavahi-ui-dev (>= 0.6.25), and replace
      devicekit-disks (>= 007) Build-Depends with udisks (>= 1.0.0~).
    - Replace Depends on devicekit-disks (>= 007) with
      udisks (>= 1.0.0~), udisks (<< 1.1.0).
    - Bump Standards-Version to 3.8.4. No further changes.
  * debian/*.symbols
    - Update symbols files for libgdu0 and libgdu-gtk0.
  [ Martin Pitt ]
  * Add 01_delay_autostart.patch: Delay autostart of the gdu daemon for 10
    seconds. It is not needed immediately (thus no need to slow down initial
    session startup) and is not visible permanently (thus it won't cause
    visual disruptions later on). This depends on the patch in GNOME #608402,
    and will be a no-op if that's not available.
  * debian/control: Move udisks dependency from g-d-u to libgdu0, since it's
    really the library which talks to it. Otherwise you could not install
    g-d-u and get crashes in GNOME. (LP: #523634)