ubuntu/+source/gjs:applied/ubuntu/cosmic

Last commit made on 2018-10-05
Get this branch:
git clone -b applied/ubuntu/cosmic https://git.launchpad.net/ubuntu/+source/gjs
Members of Ubuntu Server Dev import team can upload to this branch. Log in for directions.

Branch merges

Branch information

Name:
applied/ubuntu/cosmic
Repository:
lp:ubuntu/+source/gjs

Recent commits

63f8bef... by Simon McVittie on 2018-10-05

Import patches-applied version 1.54.1-1 to applied/debian/experimental

Imported using git-ubuntu import.

Changelog parent: f9dd093e62c8af34ab539a8d15fbc145841770aa
Unapplied parent: 221b4c17417216033874ff75432b743e249b490d

New changelog entries:
  * Team upload
  * New upstream release

221b4c1... by Simon McVittie on 2018-10-05

Import patches-unapplied version 1.54.1-1 to debian/experimental

Imported using git-ubuntu import.

Changelog parent: 96179de2ce41c68d45bc8f3e75b1b9fbbb25055d

New changelog entries:
  * Team upload
  * New upstream release

f9dd093... by Simon McVittie on 2018-09-20

Import patches-applied version 1.54.0-1 to applied/debian/experimental

Imported using git-ubuntu import.

Changelog parent: 22bb37c46ba0700faab0ba765a9bbfddf99176be
Unapplied parent: 96179de2ce41c68d45bc8f3e75b1b9fbbb25055d

New changelog entries:
  * Team upload
  [ Simon McVittie ]
  * New upstream development release (Closes: #904994)
  * Depend and build-depend on mozjs60 instead of mozjs52
  * d/copyright: Update
  * Explicitly disable -Werror
  * Drop build-dependency on gnome-common which does not appear to be
    needed since 1.47.0
  * d/gbp.conf: Don't number patches
  * Add Breaks on gnome-documents, gnome-sound-recorder and polari
    versions that use conditional catch clauses, which are a
    Mozilla-specific extension that is no longer supported in mozjs60
  * Add Breaks on gnome-shell (<< 3.29.90) for ByteArray changes
  * dh_makeshlibs: Only generate a dependency on libgjs0g, not on the
    virtual package libgjs0-libmozjs-60-0. Since the gjs-internals
    module was removed in version 1.47.0, gjs does not expose mozjs
    API/ABI in its own ABI, so it is unnecessary for gjs users like
    gnome-shell, gnome-sushi and polari to depend on their gjs having
    been compiled against a specific version of mozjs.
  * Provide libgjs0-libmozjs-52-0 to indicate that our ABI is
    compatible with the gjs that used libmozjs-52-0, until all
    dependent packages have been rebuilt
  [ Tim Lunn ]
  * New upstream release

96179de... by Simon McVittie on 2018-09-20

Import patches-unapplied version 1.54.0-1 to debian/experimental

Imported using git-ubuntu import.

Changelog parent: 8401606e1bb9f6d2a85c65266ab051a95bd31e47

New changelog entries:
  * Team upload
  [ Simon McVittie ]
  * New upstream development release (Closes: #904994)
  * Depend and build-depend on mozjs60 instead of mozjs52
  * d/copyright: Update
  * Explicitly disable -Werror
  * Drop build-dependency on gnome-common which does not appear to be
    needed since 1.47.0
  * d/gbp.conf: Don't number patches
  * Add Breaks on gnome-documents, gnome-sound-recorder and polari
    versions that use conditional catch clauses, which are a
    Mozilla-specific extension that is no longer supported in mozjs60
  * Add Breaks on gnome-shell (<< 3.29.90) for ByteArray changes
  * dh_makeshlibs: Only generate a dependency on libgjs0g, not on the
    virtual package libgjs0-libmozjs-60-0. Since the gjs-internals
    module was removed in version 1.47.0, gjs does not expose mozjs
    API/ABI in its own ABI, so it is unnecessary for gjs users like
    gnome-shell, gnome-sushi and polari to depend on their gjs having
    been compiled against a specific version of mozjs.
  * Provide libgjs0-libmozjs-52-0 to indicate that our ABI is
    compatible with the gjs that used libmozjs-52-0, until all
    dependent packages have been rebuilt
  [ Tim Lunn ]
  * New upstream release

22bb37c... by Iain Lane on 2018-06-27

Import patches-applied version 1.53.3-1 to applied/debian/experimental

Imported using git-ubuntu import.

Changelog parent: 9d9ce32dc028dabd34540bca21b92cfeb9f86d7a
Unapplied parent: 8401606e1bb9f6d2a85c65266ab051a95bd31e47

New changelog entries:
  [ Simon McVittie ]
  * d/watch: Watch for development releases
  * New upstream development release
  [ Iain Lane ]
  * New upstream development releases 1.53.2 and 1.53.3

8401606... by Iain Lane on 2018-06-27

Import patches-unapplied version 1.53.3-1 to debian/experimental

Imported using git-ubuntu import.

Changelog parent: b1a6678c1c07d86c3042e8bd49f35cc0a497aa59

New changelog entries:
  [ Simon McVittie ]
  * d/watch: Watch for development releases
  * New upstream development release
  [ Iain Lane ]
  * New upstream development releases 1.53.2 and 1.53.3

9d9ce32... by Simon McVittie on 2018-05-17

Import patches-applied version 1.52.3-2 to applied/debian/sid

Imported using git-ubuntu import.

Changelog parent: d7d9ba133b9b4e503f06fcc3f16c95ee15bed001
Unapplied parent: ba71d269cd4764d5e7d55eb7a665736a80a955f0

New changelog entries:
  * Team upload
  * d/p/context-Add-API-to-force-GC-schedule.patch,
    d/p/object-Queue-a-forced-GC-when-toggling-down.patch,
    d/p/context-Ensure-force_gc-flag-is-not-lost-if-the-idle-is-s.patch:
    Add patches from upstream version 1.53.1 to make GC more aggressive
    (LP: #1672297)

b1a6678... by Simon McVittie on 2018-05-17

Import patches-unapplied version 1.52.3-2 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 26b174d99810218a4a68ab5d72e33a6c33c7e766

New changelog entries:
  * Team upload
  * d/p/context-Add-API-to-force-GC-schedule.patch,
    d/p/object-Queue-a-forced-GC-when-toggling-down.patch,
    d/p/context-Ensure-force_gc-flag-is-not-lost-if-the-idle-is-s.patch:
    Add patches from upstream version 1.53.1 to make GC more aggressive
    (LP: #1672297)

ba71d26... by Simon McVittie on 2018-05-17

context: Ensure force_gc flag is not lost if the idle is scheduled

Gbp-Pq: context-Ensure-force_gc-flag-is-not-lost-if-the-idle-is-s.patch.

59c6baf... by Simon McVittie on 2018-05-17

object: Queue a forced GC when toggling down

Gbp-Pq: object-Queue-a-forced-GC-when-toggling-down.patch.