ubuntu/+source/gimp:ubuntu/lucid

Last commit made on 2010-02-26
Get this branch:
git clone -b ubuntu/lucid https://git.launchpad.net/ubuntu/+source/gimp
Members of Ubuntu Server Dev import team can upload to this branch. Log in for directions.

Branch merges

Branch information

Name:
ubuntu/lucid
Repository:
lp:ubuntu/+source/gimp

Recent commits

2f42365... by Didier Roche on 2010-02-26

Import patches-unapplied version 2.6.8-2ubuntu1 to ubuntu/lucid

Imported using git-ubuntu import.

Changelog parent: c806b46b519d10d917e6fe3943bc436450c9ba7b

New changelog entries:
  * Merge with debian, remaining changes:
    + debian/patches/02_help-message.patch,
      debian/patches/03_gimp.desktop.in.in.patch:
      - updated some strings for ubuntu
    + debian/rules:
      - updated translation templates
    + debian/control:
      - set Vcs-Bzr url

c806b46... by Ari Pollak on 2010-02-25

Import patches-unapplied version 2.6.8-2 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 55b218a633fe8113e24a41b9f9d9ec94778dae62

New changelog entries:
  * Fix dependencies in libgimp2.0-dev (Closes: #569420)
  * Change libjpeg62-dev build-depend to libjpeg-dev

55b218a... by Ari Pollak on 2010-01-08

Import patches-unapplied version 2.6.8-1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 62ec2fae42f84f00eccf2bd5fb6d6b23cb9d2282

New changelog entries:
  * New upstream release
  * Switch to 3.0 (quilt) format

62ec2fa... by Nico Golde <email address hidden> on 2009-11-21

Import patches-unapplied version 2.6.7-1.1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 9734b756c397e96f1c814c92f7d45fa144164691

New changelog entries:
  * Non-maintainer upload by the Security Team.
  * This update fixes the following security issues:
    - CVE-2009-3909: integer overflow in PSD file loader leading to
      a heap-based buffer overflow (Closes: #556750).
    - CVE-2009-1570: integer overflow in BMP file loader leading to
      a heap-based buffer overflow (Closes: #555929).
  * Add ${shlibs: Depends} to depends of libgimp-dev (Closes: #553234).

9734b75... by Ari Pollak on 2009-08-14

Import patches-unapplied version 2.6.7-1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 82fe7c02e6b92d3ea56146260f3ab1f03d1e1fad

New changelog entries:
  * New upstream release
    - Fixes help browser crash (Closes: #536521)
    - Fixes error in Finnish translation (Closes: #538294)

82fe7c0... by Ari Pollak on 2009-07-10

Import patches-unapplied version 2.6.6-2 to debian/sid

Imported using git-ubuntu import.

Changelog parent: f0ee3145439051158dbd62b676e6f91f55db18b7

New changelog entries:
  * Add Build-Depends-Package to libgimp2.0.symbols
  * Use gnome.mk for dh_icons and dh_desktop
  * Fix missing comma in debian/control (Closes: #535643)

f0ee314... by Ari Pollak on 2009-03-23

Import patches-unapplied version 2.6.6-1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 01e4464b9fca9e87a10245f05044303cdac9f32e

New changelog entries:
  * New upstream release
    - Save two-color PBMs properly, and don't invert the colors
      (Closes: #517502)

01e4464... by Ari Pollak on 2009-03-06

Import patches-unapplied version 2.6.5-2 to debian/sid

Imported using git-ubuntu import.

Changelog parent: aff4daa6c5b86b1d25a4b58c5d619083cac5b23c

New changelog entries:
  * Bump build-dep on intltool (Closes: #518373)

aff4daa... by Ari Pollak on 2009-02-16

Import patches-unapplied version 2.6.5-1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 42755698ba13521a1c932d965ef9c09b3fd1dc4a

New changelog entries:
  * New upstream release

4275569... by Ari Pollak on 2009-02-15

Import patches-unapplied version 2.6.4-2 to debian/sid

Imported using git-ubuntu import.

Changelog parent: d0ead50cfc90f38277ace2671acec105467f8056

New changelog entries:
  * Upload to unstable
  * New upstream release (Closes: #514530)
  * Revert building gimp-remote, since it's now deprecated.
  * New upstream release
  * Build gimp-remote (Closes: #504260)
  * New upstream release
  * New upstream release
  * Fix watch file
  * Fix typoed gimp-gnomevfs in Replaces (thanks to Michael Biebl for pointing
    it out)
  * New upstream release to experimental so we don't break any transitions
    - Fixes Image Tile error message (Closes: #373184)
    - Fixes crash in Frosty script (Closes: #405200)
    - Uses webkit for help browser (Closes: #275605)
    - Optionally includes pointer in screenshots (Closes: #292471)
  * Merge gimp-python into main gimp package
  * Remove gimp-libcurl and gimp-gnomevfs since we now build with
    GIO support instead; gvfs-backends should provide the same functionality
  * 02_help-crash.patch:
    - Apply patch from upstream to fix crash when opening Help with
      gimp-plugin-registry installed