ubuntu/+source/gimp:ubuntu/gutsy-updates

Last commit made on 2007-12-21
Get this branch:
git clone -b ubuntu/gutsy-updates https://git.launchpad.net/ubuntu/+source/gimp
Members of Ubuntu Server Dev import team can upload to this branch. Log in for directions.

Branch merges

Branch information

Name:
ubuntu/gutsy-updates
Repository:
lp:ubuntu/+source/gimp

Recent commits

197e624... by Steve Kowalik on 2007-12-21

Import patches-unapplied version 2.4.2-0ubuntu0.7.10.1 to ubuntu/gutsy-proposed

Imported using git-ubuntu import.

Changelog parent: 48f8d5d7dd8f9053052e1827ca7e9df594f126c6

New changelog entries:
  * Drop 04_ubunut_bug_148380_upstream_fix.patch, it is of course fixed in
    2.4.2.

48f8d5d... by Steve Kowalik on 2007-12-20

Import patches-unapplied version 2.4.2-0ubuntu0.7.10 to ubuntu/gutsy-proposed

Imported using git-ubuntu import.

Changelog parent: 0577e0cc8ca4c5e71de99c0d1c7b366133056ff7

New changelog entries:
  * Update to Gimp's 2.4.2 release, as opposed to keeping 2.4.0rc3 in Gutsy,
    on the off chance that this fixes some bugs. (LP: #157642)
  * Bump shlibs, just in case.

0577e0c... by Matthias Klose on 2007-10-05

Import patches-unapplied version 2.4.0~rc3-1ubuntu7 to ubuntu/gutsy

Imported using git-ubuntu import.

Changelog parent: 6f569949dfc5681d93d40365ae6e54c04fe84173

New changelog entries:
  * Explicitely remove the doc directories on upgrade for the now symlinked
    doc directories.

6f56994... by Matthias Klose on 2007-10-04

Import patches-unapplied version 2.4.0~rc3-1ubuntu6 to ubuntu/gutsy

Imported using git-ubuntu import.

Changelog parent: aa45f7900112814dedfdcd0c4e72af6925c7d922

New changelog entries:
  * debian/gimp.docs: Remove duplicate doc files. LP: #148985.

aa45f79... by Matthias Klose on 2007-10-04

Import patches-unapplied version 2.4.0~rc3-1ubuntu5 to ubuntu/gutsy

Imported using git-ubuntu import.

Changelog parent: 0222658ebc3190115ca4987314be10b188bc7db3

New changelog entries:
  * Symlink doc directories to avoid duplicate files.

0222658... by Steve Kowalik on 2007-10-03

Import patches-unapplied version 2.4.0~rc3-1ubuntu4 to ubuntu/gutsy

Imported using git-ubuntu import.

Changelog parent: 24268e0b1834bada7dc05df21aeac1141a9522a9

New changelog entries:
  * Apply patch from upstream (SVN r23659) that corrects the image
    disappearing for large images at 150% zoom. (LP: #148380)

24268e0... by Steve Kowalik on 2007-10-02

Import patches-unapplied version 2.4.0~rc3-1ubuntu3 to ubuntu/gutsy

Imported using git-ubuntu import.

Changelog parent: d6a4bbaeb811e0f4ada6db2860395282bf2a2bc9

New changelog entries:
  * It seems the bad usage hadn't completly gone. Correct a variable name
    that was causing the gettext domain to not be put into the .desktop
    file. (LP: #148049)

d6a4bba... by Steve Kowalik on 2007-09-30

Import patches-unapplied version 2.4.0~rc3-1ubuntu2 to ubuntu/gutsy

Imported using git-ubuntu import.

Changelog parent: 4db640733f3d8e8f42d58025683506a9dfe82b27

New changelog entries:
  * Correct bad usage of cut n' waste in debian/rules.

4db6407... by Steve Kowalik on 2007-09-30

Import patches-unapplied version 2.4.0~rc3-1ubuntu1 to ubuntu/gutsy

Imported using git-ubuntu import.

Changelog parent: 85039d63bd6fe539f370b6f9ff7c332b1d4a04d4

New changelog entries:
  * Resynchronized with Debian.
  * Remaining Ubuntu changes:
    - 02_help-message.patch, 03_gimp.desktop.in.in.patch: Distro changes.
    - Weave i18n magic in the rules file.
    - Munge Maintainer field as per spec.
  * Ubuntu changes dropped:
    - 10_dont_show_wizard.patch: Unused, upstream doesn't call it anymore.
    - Use dh_icons.
  * Disabled the print plugin, and removed the Conflicts/Replaces on
    gimp-print.
  * New upstream release
    - Fixes crash after migrating old Extended Input settings (Closes: #439509)
    - Fixes crash on converting color space (Closes: #439511)
    - Script-fu now handles non-UTF8 characters better (Closes: #442277)
  * Conflict & Replaces with gimp-print and update NEWS.Debian to reflect
    the change
  * Fix menu entry to point to XPM icon (Really Closes: #441177)
  * Explicitly build-depend on liblcms1-dev
  * Explicitly remove *.la files in debian/rules
  * Add a note in NEWS.Debian about unnecessary gimp-print
  * Make libgimp2.0 recommend gimp-data for the locale data,
    since it's mostly only messages used in gimp itself.
  * Install XPM for menu icon (Closes: #441177, #237637, #77625)
  * Add back 02_help-message.patch to show a better error message when
    gimp-help-* isn't installed
  * Put icons into gimp-data, and call dh_icons from debian/rules
  * debian/patches/03_zoom-crash.patch:
    - Apply patch from upstream to fix zooming on images with abnormal
      dimensions (Closes: #441409)

85039d6... by Steve Kowalik on 2007-09-07

Import patches-unapplied version 2.4.0~rc2-1ubuntu1 to ubuntu/gutsy

Imported using git-ubuntu import.

Changelog parent: 05d91ce6a5beaeb92051ea3dec29b612f6d0b512

New changelog entries:
  * Resynchronized with Debian.
  * Remaining Ubuntu changes:
    - 02_help-message.patch, 03_gimp.desktop.in.in.patch,
      10_dont_show_wizard.patch: Distro patches.
    - Use dh_icons, and weave i18n magic in the rules file.
    - Munge Maintainer field as per spec.
  * Ubuntu changes dropped:
    - 90_psd_heap_overflow.patch, it has been applied upstream.
  * 03_gimp.desktop.in.in.patch: Exec gimp, not gimp-2.4
  * New upstream version
    - Remove extraneous comma in header file (Closes: #440021)
  * Remove development version notes from control file
  * Tighten up gimp-python dependencies to make it less likely that an
    inconsistent version of gimp-python will be installed
  * Update watch file for 2.4 RC versions
  * debian/patches/04_c++-fix.patch:
    - Add a missing G_END_DECLS which was preventing C++ plugins from building
      (Closes: #439473)
  * debian/patches/05_zoom_improvements.patch:
    - Apply latest zoom improvements from upstream to fix crashes while
      working with large images (Closes: #439489)
  * Add libhal-dev and libdbus-1-dev to build-depends to take advantage
    of input hotplugging and existing-gimp-instance checking
  * debian/patches/03_toolbox-menu.patch:
    - Don't patch .xml.in file, only .xml
  * debian/patches/02_print-crash.patch:
    - Apply patch from upstream to fix Print crash on new installations
      (Closes: #438786)
  * debian/patches/03_toolbox-menu.patch:
    - Work around missing File->Quit and File->Close All items in the toolbox
      (Closes: #438708)
  * Fix debian/watch, README.Debian, and gimp.menu to reflect the new
    major version
  * New upstream version
    - Fixes two mistakes in French translation (Closes: #355961, #428564)
    - Fixes a mistake in Italian translation (Closes: #298454)
    - Fixes a mistake in Chinese Traditional translation (Closes: #309938)
    - Improves TGA file detection (Closes: #231525)
  * New upstream version
    - Fixes integer overflow in PSD plugin (CVE-2007-2949)
  * Make gimp conflict and replace gimp-svg
  * Update versioned build-dep of python-gtk2-dev (Closes: #430363)
  * Make package binNMU-safe (Closes: #432965)