ubuntu/+source/ghostscript:ubuntu/saucy

Last commit made on 2013-09-03
Get this branch:
git clone -b ubuntu/saucy https://git.launchpad.net/ubuntu/+source/ghostscript
Members of Ubuntu Server Dev import team can upload to this branch. Log in for directions.

Branch merges

Branch information

Name:
ubuntu/saucy
Repository:
lp:ubuntu/+source/ghostscript

Recent commits

591e820... by Till Kamppeter on 2013-09-03

Import patches-unapplied version 9.10~dfsg-0ubuntu2 to ubuntu/saucy-proposed

Imported using git-ubuntu import.

Changelog parent: b84a7d5cc6b73594d784803dae9eebbee206b5c2

New changelog entries:
  * debian/patches/020130903-5ae4180-ps-interpreter-dont-interpolate-imagemask-data-for-high-level-devices.patch:
    PS Interpreter: Do not interpolate imagemask data for high level devices.
    This accelerates processing files with embedded bitmap images when the
    output device is a high-level (vector) device. In this case an explicit
    "-dNOINTERPOLATE" on the command line is not needed any more.

b84a7d5... by Till Kamppeter on 2013-09-02

Import patches-unapplied version 9.10~dfsg-0ubuntu1 to ubuntu/saucy-proposed

Imported using git-ubuntu import.

Changelog parent: 21553f9d662fd81006e3f97bb1687823c9564c43

New changelog entries:
  * New upstream release
     - Ghostscript 9.10 final release

21553f9... by Till Kamppeter on 2013-08-28

Import patches-unapplied version 9.10~dfsg~rc1-0ubuntu2 to ubuntu/saucy-proposed

Imported using git-ubuntu import.

Changelog parent: 8474b38bc76c16a767706a2be63e9c27e9a9250f

New changelog entries:
  * debian/rules: Commented out "DEB_BUILD_PARALLEL = yes" line to suppress
    parallelized building. This was leading to a race condition which broke
    the "make" process onn the build servers.

8474b38... by Till Kamppeter on 2013-08-28

Import patches-unapplied version 9.10~dfsg~rc1-0ubuntu1 to ubuntu/saucy-proposed

Imported using git-ubuntu import.

Changelog parent: 0eb8ac8e6ca98c8275a51cab6c7b54eed4208061

New changelog entries:
  * New upstream release
     - Ghostscript 9.10rc1.
     - Upstream: Mainly, changes to our Postscript startup code (to improve
       compatibility with Adobe) have had unexpected and undesirable side
       effects. Most of these have been in fairly widely relied upon, but also
       decidedly non-standard uses (pdf2dsc being a prime example).
     - We are using Ghostscript's libopenjpeg again, using the system's one
       does not (yet) work as there are still patches of the Ghostscript
       developers which did not get accepted upstream yet..
  * debian/control: Removed build dependency on libopenjpeg-dev.
  * debian/rules: Removed check for removed openjpeg/ subdirectory in the
    repackaging check again, also set build options for using Ghostscript's
    built-in libopenjpeg library.

0eb8ac8... by Till Kamppeter on 2013-08-22

Import patches-unapplied version 9.09~dfsg-0ubuntu1 to ubuntu/saucy-proposed

Imported using git-ubuntu import.

Changelog parent: 43bd18f010327e76f0a7860334504614756111f9

New changelog entries:
  * New upstream release
     - Ghostscript 9.09 final release
     - The URW Postscript font set has been updated to the latest version,
       fixing many compatibility problems with the Adobe fonts.
     - Bug fixes.

43bd18f... by Till Kamppeter on 2013-08-16

Import patches-unapplied version 9.09~dfsg~rc1-0ubuntu1 to ubuntu/saucy-proposed

Imported using git-ubuntu import.

Changelog parent: 8d9102fce481959be2d2b535bd641abb4f796a36

New changelog entries:
  * New upstream release
     - Ghostscript 9.09rc1.
     - Upstream: Due to a couple of serious regressions that were discovered
       *very* shortly after the 9.08 release was completed, we decided it was
       best to withdraw 9.08, and produce a 9.09 release with those issues
       resolved.

8d9102f... by Till Kamppeter on 2013-08-15

Import patches-unapplied version 9.08+dfsg-0ubuntu1 to ubuntu/saucy-proposed

Imported using git-ubuntu import.

Changelog parent: b5ad9c638e4d249c56643aaf3a713650baf853a8

New changelog entries:
  * New upstream release
     - Ghostscript 9.08 final release
     - Background printing (BGPrint) is a new feature allowing an accumulated
       page clist to be rendered by one or more rendering threads whilst the
       interpreter (in the "main" thread) continues to accumulate the
       subsequent page's clist. For certain classes of file this can result in
       a useful performance increase. See: Banding Parameters (to be activated
       with the new "-dBGPrint" command line option).
     - GrayDetection allows suitably written devices to detect "color" input in
       near neutral tones (i.e. near monochrome) and to convert "on-the-fly" to
       pure grayscale, whilst retaining the ability to print full color on
       demand. This is primarily aimed at workflows where saving ink (especially
       color inks) is required. See: Device Parameters (to be activated with the
       new "-dGrayDetection" command line option).
     - Plus the usual round of bug fixes, compatibility changes, and incremental
       improvements.
  * debian/rules: Allow also '+' as separator between the upstream version
    number and any extensions (like "dfsg", "git", ...).

b5ad9c6... by Till Kamppeter on 2013-08-09

Import patches-unapplied version 9.08~rc1~dfsg-0ubuntu1 to ubuntu/saucy-proposed

Imported using git-ubuntu import.

Changelog parent: dd4e7f82a344e61591f32c13d95515f77c539695

New changelog entries:
  * New upstream release
     - Ghostscript 9.08rc1.
     - We are using the system's liblcms2 and libopenjpeg now.
  * debian/patches/020130401-852e545-pxl-xl-driver-produced-drawing-commands-without-setting-color-space.patch:
    Removed patch backported from upstream.
  * debian/patches/ojdk-8007925+8007926.patch,
    debian/patches/ojdk-8007927.patch,
    debian/patches/ojdk-8007929.patch,
    debian/patches/ojdk-8009654.patch: Removed patches on build in liblcms2, we
    use the system's liblcms2 now.
  * debian/patches/2001_docdir_fix_for_debian.patch: Manually updated to new
    upstream source code.
  * debian/patches/2003_support_multiarch.patch: Refreshed with quilt.
  * debian/control: Added build dependencies on liblcms2-dev and
    libopenjpeg-dev.
  * debian/rules: Check for removed lcms2/ and openjpeg/ subdirectories in
    the repackaging check again, also set build options for shared liblcms2
    and libopenjpeg libraries.
  * debian/rules: Makefile.in and configure.ac are in the root directory of
    the source now and do not need to get linked from base/. Also there is no
    gstoraster and gstopxl CUPS filter in the package any more and no
    "install-cups" make target any more.
  * debian/control, debian/rules, debian/ghostscript-cups.install,
    debian/ghostscript-cups.ppd-updater: Removed the ghostscript-cups binary
    package. The files are now provided by cups-filters.
  * debian/symbols.common: Updated for new upstream source. Applied patch
    which dpkg-gensymbols generated for debian/libgs9.symbols to this file.

dd4e7f8... by Matthias Klose on 2013-08-04

Import patches-unapplied version 9.07~dfsg2-0ubuntu6 to ubuntu/saucy-proposed

Imported using git-ubuntu import.

Changelog parent: 9d9245d47f904c57313d37a9f618284d3524b6d8

New changelog entries:
  * Update symbols file for Aarch64.

9d9245d... by Matthias Klose on 2013-08-03

Import patches-unapplied version 9.07~dfsg2-0ubuntu5 to ubuntu/saucy-proposed

Imported using git-ubuntu import.

Changelog parent: bce40c36312ddc949a778aea6203b76d688f8055

New changelog entries:
  * Enable parallel builds.
  * debian/copyright_hints: Remove. The copyright check is run even
    for arch only builds. For now, rely on the Debian import and
    handle that better when cdbs supports it.