ubuntu/+source/ghostscript:ubuntu/intrepid-proposed

Last commit made on 2009-01-23
Get this branch:
git clone -b ubuntu/intrepid-proposed https://git.launchpad.net/ubuntu/+source/ghostscript
Members of Ubuntu Server Dev import team can upload to this branch. Log in for directions.

Branch merges

Branch information

Name:
ubuntu/intrepid-proposed
Repository:
lp:ubuntu/+source/ghostscript

Recent commits

0d3e165... by Till Kamppeter on 2008-01-22

Import patches-unapplied version 8.63.dfsg.1-0ubuntu6.2 to ubuntu/intrepid-proposed

Imported using git-ubuntu import.

Changelog parent: 6809f802f2ea9fc54f77d6ea3a2bcf308555534e

New changelog entries:
  * debian/patches/72_gs-setpd-ps-duplex-fix.dpatch: Duplex printing did not
    work in some cases (LP: #308817).

6809f80... by Till Kamppeter on 2008-12-15

Import patches-unapplied version 8.63.dfsg.1-0ubuntu6.1 to ubuntu/intrepid-proposed

Imported using git-ubuntu import.

Changelog parent: fb233ac699617193a3405e33153862e67bc8bd2a

New changelog entries:
  * debian/patches/70_take-into-account-data-in-stream-buffer-before-refill.dpatch:
    Certain files lead to a Ghostscript error due to wrong handling of the
    stream buffer (LP: #306125, upstream bug #690090).
  * debian/patches/65_too-big-temp-files-1.dpatch,
    debian/patches/67_too-big-temp-files-2.dpatch: Ghostscript produced much too
    big temporary files (> 10 GB) when printing photos from GNOME apps in
    1200 dpi (LP: #288570, upstream bug #690133).
  * debian/patches/62_onebitcmyk-pdf.dpatch: Check the whole Decode array to
    detect special cases of identity and inverse decoding in PDF files
    (Upstream bug #690178).
  * debian/patches/50_lips4-floating-point-exception: Fixed floating-point
    exception in "lips4" and other drivers (Upstream bug #690122).

fb233ac... by Till Kamppeter on 2008-10-19

Import patches-unapplied version 8.63.dfsg.1-0ubuntu6 to ubuntu/intrepid

Imported using git-ubuntu import.

Changelog parent: e04e9fe897ca526a14d23e6ca139ace8797e9df7

New changelog entries:
  * debian/patches/42_gs-init-ps-delaybind-fix.dpatch: Make "ps2ascii" working
    again (LP: #281419, upstream bug #690124).
  * debian/patches/45_bjc600-bjc800-pdf-input.dpatch: Fix setting of the
    "DitheringType" option. With PDF input Ghostscript crashes, with
    PostScript input the "DitheringType" option was probably ignored
    (Upstream bug #690032).

e04e9fe... by Till Kamppeter on 2008-10-13

Import patches-unapplied version 8.63.dfsg.1-0ubuntu5 to ubuntu/intrepid

Imported using git-ubuntu import.

Changelog parent: 27adf51ce51072313775db8a10bb3f978e6520f5

New changelog entries:
  * debian/patches/38_pxl-duplex.dpatch: The Duplex option of the "pxlmono"
    and "pxlcolor" drivers did not work (part 1 of the fix for LP: #282738).
  * debian/patches/39_pxl-resolution.dpatch: The resolution must be also set
    as PJL command for the "pxlmono" and "pxlcolor" drivers.

27adf51... by Steve Langasek on 2008-08-21

Import patches-unapplied version 8.63.dfsg.1-0ubuntu4 to ubuntu/intrepid

Imported using git-ubuntu import.

Changelog parent: 2c672da884886bd2446b9fad727cdd2bb4756330

New changelog entries:
  * debian/control, debian/rules: Merge ghostscript-fonts back into
    ghostscript, since this is not needed at present.
  * debian/rules: Drop most of the fonts from ghostscript since gsfonts
    ships newer versions.

2c672da... by Till Kamppeter on 2008-08-11

Import patches-unapplied version 8.63.dfsg.1-0ubuntu3 to ubuntu/intrepid

Imported using git-ubuntu import.

Changelog parent: 345b4ab6cc96bbd4f4a659592c5741630d7b34f5

New changelog entries:
  * debian/rules: Fixed typo (LP: #256975).
  * debian/ghostscript.links: s/8.62/8.63/
  * debian/patches/35_disable_libcairo.dpatch: Added possibility to
    compile Ghostscript without the "cairo" output device. The device
    is still in experimental state and with its dependency on libcairo
    it pulls in a dependency on X.
  * debian/control, debian/rules: Build Ghostscript without the "cairo"
    output device (LP: #256859).

345b4ab... by Till Kamppeter on 2008-08-11

Import patches-unapplied version 8.63.dfsg.1-0ubuntu2 to ubuntu/intrepid

Imported using git-ubuntu import.

Changelog parent: 66e50df46448bb8e5020d2c8316312cef44c5528

New changelog entries:
  * debian/control, debian/rules: Split the fonts off into its own
    "ghostscript-fonts" package. Changes dependencies of "ghostscript"
    package that either "ghostscript-fonts" or "gsfonts" can be used.

66e50df... by Till Kamppeter on 2008-08-05

Import patches-unapplied version 8.63.dfsg.1-0ubuntu1 to ubuntu/intrepid

Imported using git-ubuntu import.

Changelog parent: ecc39001158f3cffb182550f407ab93bf6a2c2a6

New changelog entries:
  * New upstream release
  * Merge from debian unstable, remaining changes:
    - gs-esp and gs-common depend only on ghostscript, not on ghostscript-x,
      as gs-esp had already split off gs-esp-x in Ubuntu
  * debian/patches/12_gs-cjk_vertical_writing_metrics_fix.dpatch,
    debian/patches/30_ps2pdf_man_improvement.dpatch: Adapted to upstream
    changes.
  * debian/control: Added libcairo2-dev to the build dependencies, as
    Ghostscript has a libcairo-based output device now.
  * Acknowledged NMU, thanks madcoder - closes: #453903
  * Bumped to Standards-Version: 3.8.0.
  * Fixed fakeroot build error, thanks Bob Lindell - closes: #484712
  * ghostscript-doc.doc-base: Made file mask *.htm* instead of *.html.

ecc3900... by Till Kamppeter on 2008-06-09

Import patches-unapplied version 8.62.dfsg.1-2.1ubuntu1 to ubuntu/intrepid

Imported using git-ubuntu import.

Changelog parent: 5b0ff1de1218f0cecdef453ac32fb09d2cb9d08b

New changelog entries:
  * Merge from debian unstable, remaining changes:
    - gs-esp and gs-common depend only on ghostscript, not on ghostscript-x,
      as gs-esp had already split off gs-esp-x in Ubuntu
  * debian/libgs8.shlibs: Removed. All libgs8 versions should have the same
    API and ABI. The artificial restriction set by this file required all
    reverse dependencies to be rebuilt for every stable release of Ghostscript.
  * debian/ghostscript.doc-base: Removed. The file conflicts with the
    corresponding file of ghostscript-doc and it also points to documentation
    files which make only part of ghostscript-doc, so the files can be not
    installed when this doc-base file is installed.
  * debian/ghostscript-doc.doc-base: Corrected file mask for all HTML files.
    The Ghostscript documentation is in *.htm files.
  * Non-maintainer upload.
  * Add patches/31_fix-gc-sigbus.dpatch to avoid sigbus/segfaults on sparc and
    hppa (and probably errors on other architectures as well).
    Closes: #453903.
  * ghostscript: Tighten up versioned dependency on libgs8
    - closes: #470253
  * preinsts for each dummy packages now call update-alternatives
    to make sure gs symlinks are removed before the new ghostscript
    package is installed - closes: #449173
  * New upstream release.
  * Removed Resource/Font for a minor licensing problem.
    I'm now contacting the upstream, so they might be back soon.
  * Fixed in the upstream - closes: #418706
    See also http://bugs.ghostscript.com/show_bug.cgi?id=689600
  * Now it can handle DEB_BUILD_OPTS as expected - closes: #446819
  * 10_ijs_krgb_support.dpatch: incorporated into the upstream, removed.
  * 27_cups_filters_with_buffered_input.dpatch: incorporated into
    the upstream, removed.
  * 28_print_encrypted_PDFs_from_adobe_reader_8.dpatch: incorporated into
    the upstream, removed.
  * 31_CVE-2008-0411.dpatch: incorporated into the upstream, removed.
    thanks Nico Golde for NMU.
  * shlibs: loosen the libgs8 shlibs version specification,
    thanks Sune Vuorela for pointing it out - closes: #469218
  * control: ghostscript doesn't provide gs, gs-esp, gs-gpl, gs-afpl
    and gs-aladdin anymore - ghostscript-x does - closes: #448702, #462678
  * control: tighten up versioned Conflicts on dummy packages.
  * rules: removes /usr/share/doc/ghostscript/README.gz explicitly
    - closes: #460692
  * postinst: removes old /etc/alternative symlinks explicitly
    - closes: #447495, #449061
  * Non-maintainer upload by security team.
  * Fix stack based buffer overflow in the zseticcspace() function possibly
    leading to arbitrary code exeuction via a crafted ps file.
    (31_CVE-2008-0411.dpatch; Closes: #468190).
  * Adjusting libgs shlibs file to match the new version number.

5b0ff1d... by Jamie Strandboge on 2008-04-08

Import patches-unapplied version 8.61.dfsg.1-1ubuntu3 to ubuntu/hardy

Imported using git-ubuntu import.

Changelog parent: d944c4d8c1d6669d389e883040d266899f6ec5b3

New changelog entries:
  * SECURITY UPDATE: buffer overflow in color space handling code
  * debian/patches/31_CVE-2008-0411.dpatch: fix zseticcspace() to perform
    range checks
  * References
    CVE-2008-0411