ubuntu/+source/ghostscript:ubuntu/gutsy-updates

Last commit made on 2009-03-23
Get this branch:
git clone -b ubuntu/gutsy-updates https://git.launchpad.net/ubuntu/+source/ghostscript
Members of Ubuntu Server Dev import team can upload to this branch. Log in for directions.

Branch merges

Branch information

Name:
ubuntu/gutsy-updates
Repository:
lp:ubuntu/+source/ghostscript

Recent commits

17c9e76... by Marc Deslauriers on 2009-03-22

Import patches-unapplied version 8.61.dfsg.1~svn8187-0ubuntu3.5 to ubuntu/gutsy-security

Imported using git-ubuntu import.

Changelog parent: f1917fbf38085e1d2b4ca2eff129709c85f4c754

New changelog entries:
  * SECURITY UPDATE: Arbitrary code execution due to integer overflows and
    insufficient upper-bounds checks in the ICC library
    - debian/patches/44_CVE-2009-0583_0584.dpatch: fix multiple integer
      overflows and perform bounds checking in icclib/icc.c.
    - CVE-2009-0583
    - CVE-2009-0584

f1917fb... by Jamie Strandboge on 2008-04-08

Import patches-unapplied version 8.61.dfsg.1~svn8187-0ubuntu3.4 to ubuntu/gutsy-security

Imported using git-ubuntu import.

Changelog parent: 337972dab623d9ae0ba7cc7c5ef8479face7b33f

New changelog entries:
  * SECURITY UPDATE: buffer overflow in color space handling code
  * debian/patches/43_CVE-2008-0411.dpatch: fix zseticcspace() to perform
    range checks
  * References
    CVE-2008-0411

337972d... by Till Kamppeter on 2007-12-12

Import patches-unapplied version 8.61.dfsg.1~svn8187-0ubuntu3.3 to ubuntu/gutsy-proposed

Imported using git-ubuntu import.

Changelog parent: dbfba33358f6b0e4ba548683e08f08069f2468c2

New changelog entries:
  * debian/patches/42_print_encrypted_PDFs_from_adobe_reader_8.dpatch:
    Fixed printing of encrypted PDF files from Adobe Reader 8.1.1. This is
    the real fix now and not only a workaround. (Ghostscript bug #689577,
    Ubuntu bug LP: #172264).

dbfba33... by Kees Cook on 2007-10-22

Import patches-unapplied version 8.61.dfsg.1~svn8187-0ubuntu3.2 to ubuntu/gutsy-security

Imported using git-ubuntu import.

Changelog parent: 569a26943c471d19f2cd49c39a424d4d2bb64e5c

New changelog entries:
  [ Kees Cook ]
  * SECURITY UPDATE: possible code execution via crafted JPEG2000 images.
  * Add debian/patches/40_embedded_jasper_fix.dpatch: upstream backports.
  * References
    https://launchpad.net/bugs/153765
    CVE-2007-2721
  [ Martin Pitt ]
  * debian/rules: Clean /usr/share/doc/*.html files from package
    'ghostscript', too (incomplete fix in previous versions), since they are
    already shipped in ghostscript-doc and thus have a file conflict.
    (LP: #153218)

569a269... by Martin Pitt on 2007-10-09

Import patches-unapplied version 8.61.dfsg.1~svn8187-0ubuntu3 to ubuntu/gutsy

Imported using git-ubuntu import.

Changelog parent: 21ac71d0ce1f49209e884b4e6595b777660b09df

New changelog entries:
  [ Till Kamppeter ]
  * debian/rules: Install missing *.upp files (usptream bug, LP: #150985).
  [ Martin Pitt ]
  * debian/rules: Clean files from package ghostscript which are moved to
    ghostscript-doc on i386 (where arch-all packages are built). On all
    non-i386 platforms the files remained in the main package, which causes
    file conflicts and unnecessary package growth. This is a quick hack for
    Gutsy. In Hardy, this horribly broken build system should be fixed
    properly.

21ac71d... by Till Kamppeter on 2007-09-18

Import patches-unapplied version 8.61.dfsg.1~svn8187-0ubuntu2 to ubuntu/gutsy

Imported using git-ubuntu import.

Changelog parent: 3233da29bad821fb5445abb9f7fd2699fe8472b8

New changelog entries:
  * debian/patches/06_libpaper_support.dpatch: Added missing
    "#include <paper.h>", this made Ghostscript not working at all
    on IA64 (Fixes LP: #130842, thanks to Ralph Giles from ghostscript.com
    for the fix and to Matthias Klose for the IA64 test machine).
  * debian/ghostscript.links: Bumped version number in link for CJK fonts
    (Fixes LP: #139911).

3233da2... by Till Kamppeter on 2007-08-13

Import patches-unapplied version 8.61.dfsg.1~svn8187-0ubuntu1 to ubuntu/gutsy

Imported using git-ubuntu import.

Changelog parent: eb78e5da6fc4b5054b127aa7c27832b8b33b6ef5

New changelog entries:
  * New upstream release
    o SVN snapshot rev 8187
    o CJK patches from Koji Otani to fix several issues with CJK text
      (should fix http://bugs.ghostscript.com/show_bug.cgi?id=689304).
      These patches were also applied to ESP Ghostscript and having them
      in Gutsy's GPL GS will avoide regressions against Feisty's ESP GS.
    o Minor bug fixes from upstream.

eb78e5d... by Matthias Klose on 2007-08-10

Import patches-unapplied version 8.60.dfsg.6-0ubuntu2 to ubuntu/gutsy

Imported using git-ubuntu import.

Changelog parent: 65669392883c21a54072483fa97d76065af9219a

New changelog entries:
  * debian/patches/30_assorted_script_fixes.dpatch: Back out the update
    to pdf2eps, causing build failures on the buildds.
  * debian/control: Build-depend on freeglut3-dev | libglut-dev.

6566939... by Till Kamppeter on 2007-08-02

Import patches-unapplied version 8.60.dfsg.6-0ubuntu1 to ubuntu/gutsy

Imported using git-ubuntu import.

Changelog parent: d8dce5e5c3fe754c2144d3ed503892acb98c5913

New changelog entries:
  * Final release of Ghostscript 8.60
    o First official release of GPL Ghostscript with merged functionality
      of ESP Ghostscript.
    o Closes: LP: #128801
  * debian/patches/50_gv_kghostview_compatibility.dpatch: Removed workaround,
    real fix done upstream

d8dce5e... by Till Kamppeter on 2007-07-16

Import patches-unapplied version 8.60.dfsg.5-0ubuntu1 to ubuntu/gutsy

Imported using git-ubuntu import.

Changelog parent: e619e71aa4acc45edb9b6a01c1cef318b2cac17d

New changelog entries:
  * New upstream release
    o SVN snapshot rev 8127
    o Carried over some bug fixes from ESP Ghostscript (see
      http://bugs.ghostscript.com/show_bug.cgi?id=689315)
    o Minor bug fixes from upstream.
  * debian/patches/30_assorted_script_fixes.dpatch: Updated.