ubuntu/+source/ghostscript:applied/ubuntu/gutsy-updates

Last commit made on 2009-03-23
Get this branch:
git clone -b applied/ubuntu/gutsy-updates https://git.launchpad.net/ubuntu/+source/ghostscript
Members of Ubuntu Server Dev import team can upload to this branch. Log in for directions.

Branch merges

Branch information

Name:
applied/ubuntu/gutsy-updates
Repository:
lp:ubuntu/+source/ghostscript

Recent commits

88f2a3b... by Marc Deslauriers on 2009-03-22

Import patches-applied version 8.61.dfsg.1~svn8187-0ubuntu3.5 to applied/ubuntu/gutsy-security

Imported using git-ubuntu import.

Changelog parent: 0d8a52cc9d623c1045058bf036dc5b2cad8ad035
Unapplied parent: 17c9e765867e579239bedfbaa16bbf9e67ba5896

New changelog entries:
  * SECURITY UPDATE: Arbitrary code execution due to integer overflows and
    insufficient upper-bounds checks in the ICC library
    - debian/patches/44_CVE-2009-0583_0584.dpatch: fix multiple integer
      overflows and perform bounds checking in icclib/icc.c.
    - CVE-2009-0583
    - CVE-2009-0584

17c9e76... by Marc Deslauriers on 2009-03-22

Import patches-unapplied version 8.61.dfsg.1~svn8187-0ubuntu3.5 to ubuntu/gutsy-security

Imported using git-ubuntu import.

Changelog parent: f1917fbf38085e1d2b4ca2eff129709c85f4c754

New changelog entries:
  * SECURITY UPDATE: Arbitrary code execution due to integer overflows and
    insufficient upper-bounds checks in the ICC library
    - debian/patches/44_CVE-2009-0583_0584.dpatch: fix multiple integer
      overflows and perform bounds checking in icclib/icc.c.
    - CVE-2009-0583
    - CVE-2009-0584

0d8a52c... by Jamie Strandboge on 2008-04-08

Import patches-applied version 8.61.dfsg.1~svn8187-0ubuntu3.4 to applied/ubuntu/gutsy-security

Imported using git-ubuntu import.

Changelog parent: 3e4b7a400f52661740ddee3754a33242fe657479
Unapplied parent: f1917fbf38085e1d2b4ca2eff129709c85f4c754

New changelog entries:
  * SECURITY UPDATE: buffer overflow in color space handling code
  * debian/patches/43_CVE-2008-0411.dpatch: fix zseticcspace() to perform
    range checks
  * References
    CVE-2008-0411

f1917fb... by Jamie Strandboge on 2008-04-08

Import patches-unapplied version 8.61.dfsg.1~svn8187-0ubuntu3.4 to ubuntu/gutsy-security

Imported using git-ubuntu import.

Changelog parent: 337972dab623d9ae0ba7cc7c5ef8479face7b33f

New changelog entries:
  * SECURITY UPDATE: buffer overflow in color space handling code
  * debian/patches/43_CVE-2008-0411.dpatch: fix zseticcspace() to perform
    range checks
  * References
    CVE-2008-0411

3e4b7a4... by Till Kamppeter on 2007-12-12

Import patches-applied version 8.61.dfsg.1~svn8187-0ubuntu3.3 to applied/ubuntu/gutsy-proposed

Imported using git-ubuntu import.

Changelog parent: 995ef85170116629fa6ddf422bece08d89aff4cd
Unapplied parent: 337972dab623d9ae0ba7cc7c5ef8479face7b33f

New changelog entries:
  * debian/patches/42_print_encrypted_PDFs_from_adobe_reader_8.dpatch:
    Fixed printing of encrypted PDF files from Adobe Reader 8.1.1. This is
    the real fix now and not only a workaround. (Ghostscript bug #689577,
    Ubuntu bug LP: #172264).

337972d... by Till Kamppeter on 2007-12-12

Import patches-unapplied version 8.61.dfsg.1~svn8187-0ubuntu3.3 to ubuntu/gutsy-proposed

Imported using git-ubuntu import.

Changelog parent: dbfba33358f6b0e4ba548683e08f08069f2468c2

New changelog entries:
  * debian/patches/42_print_encrypted_PDFs_from_adobe_reader_8.dpatch:
    Fixed printing of encrypted PDF files from Adobe Reader 8.1.1. This is
    the real fix now and not only a workaround. (Ghostscript bug #689577,
    Ubuntu bug LP: #172264).

995ef85... by Kees Cook on 2007-10-22

Import patches-applied version 8.61.dfsg.1~svn8187-0ubuntu3.2 to applied/ubuntu/gutsy-security

Imported using git-ubuntu import.

Changelog parent: 25fe11642102fdd0f165a2be9ec67ad2a8959276
Unapplied parent: dbfba33358f6b0e4ba548683e08f08069f2468c2

New changelog entries:
  [ Kees Cook ]
  * SECURITY UPDATE: possible code execution via crafted JPEG2000 images.
  * Add debian/patches/40_embedded_jasper_fix.dpatch: upstream backports.
  * References
    https://launchpad.net/bugs/153765
    CVE-2007-2721
  [ Martin Pitt ]
  * debian/rules: Clean /usr/share/doc/*.html files from package
    'ghostscript', too (incomplete fix in previous versions), since they are
    already shipped in ghostscript-doc and thus have a file conflict.
    (LP: #153218)

dbfba33... by Kees Cook on 2007-10-22

Import patches-unapplied version 8.61.dfsg.1~svn8187-0ubuntu3.2 to ubuntu/gutsy-security

Imported using git-ubuntu import.

Changelog parent: 569a26943c471d19f2cd49c39a424d4d2bb64e5c

New changelog entries:
  [ Kees Cook ]
  * SECURITY UPDATE: possible code execution via crafted JPEG2000 images.
  * Add debian/patches/40_embedded_jasper_fix.dpatch: upstream backports.
  * References
    https://launchpad.net/bugs/153765
    CVE-2007-2721
  [ Martin Pitt ]
  * debian/rules: Clean /usr/share/doc/*.html files from package
    'ghostscript', too (incomplete fix in previous versions), since they are
    already shipped in ghostscript-doc and thus have a file conflict.
    (LP: #153218)

25fe116... by Martin Pitt on 2007-10-09

Import patches-applied version 8.61.dfsg.1~svn8187-0ubuntu3 to applied/ubuntu/gutsy

Imported using git-ubuntu import.

Changelog parent: e3e2d1922388df6b834356a0b0347c841052f59d
Unapplied parent: 569a26943c471d19f2cd49c39a424d4d2bb64e5c

New changelog entries:
  [ Till Kamppeter ]
  * debian/rules: Install missing *.upp files (usptream bug, LP: #150985).
  [ Martin Pitt ]
  * debian/rules: Clean files from package ghostscript which are moved to
    ghostscript-doc on i386 (where arch-all packages are built). On all
    non-i386 platforms the files remained in the main package, which causes
    file conflicts and unnecessary package growth. This is a quick hack for
    Gutsy. In Hardy, this horribly broken build system should be fixed
    properly.

569a269... by Martin Pitt on 2007-10-09

Import patches-unapplied version 8.61.dfsg.1~svn8187-0ubuntu3 to ubuntu/gutsy

Imported using git-ubuntu import.

Changelog parent: 21ac71d0ce1f49209e884b4e6595b777660b09df

New changelog entries:
  [ Till Kamppeter ]
  * debian/rules: Install missing *.upp files (usptream bug, LP: #150985).
  [ Martin Pitt ]
  * debian/rules: Clean files from package ghostscript which are moved to
    ghostscript-doc on i386 (where arch-all packages are built). On all
    non-i386 platforms the files remained in the main package, which causes
    file conflicts and unnecessary package growth. This is a quick hack for
    Gutsy. In Hardy, this horribly broken build system should be fixed
    properly.