ubuntu/+source/ghostscript:applied/debian/lenny

Last commit made on 2010-09-04
Get this branch:
git clone -b applied/debian/lenny https://git.launchpad.net/ubuntu/+source/ghostscript
Members of Ubuntu Server Dev import team can upload to this branch. Log in for directions.

Branch merges

Branch information

Name:
applied/debian/lenny
Repository:
lp:ubuntu/+source/ghostscript

Recent commits

36e978d... by Giuseppe Iuculano on 2010-08-18

Import patches-applied version 8.62.dfsg.1-3.2lenny5 to applied/debian/lenny

Imported using git-ubuntu import.

Changelog parent: 3f6b72e15d745a40d576079e4eeaa474c54c6bf1
Unapplied parent: 3b0ee7d2759be3d9e0117cc99b0839138cab7dfe

New changelog entries:
  * Non-maintainer upload by the Security Team.
  * Fixed CVE-2009-4897: Buffer overflow in gs/psi/iscan.c allows remote
    attackers to execute arbitrary code or cause a denial of service via a
    crafted PDF document containing a long name.
  * Fixed CVE-2010-1628: execute arbitrary code via a PostScript file
    containing unlimited recursive procedure invocations, which trigger
    memory corruption in the stack of the interpreter (Closes: #584516)
  * Rebuild again, there's an old 8.62.dfsg.1-3.2lenny3 build on
    chopin, which prevents builds from trickling in
  * Trigger rebuild, the old upload wasn't processed by buildds
  * CVE-2007-6725 CVE-2008-3522 CVE-2008-6679 CVE-2009-0196
    CVE-2010-0792 CVE-2009-4270 CVE-2010-1869

3b0ee7d... by Giuseppe Iuculano on 2010-08-18

Import patches-unapplied version 8.62.dfsg.1-3.2lenny5 to debian/lenny

Imported using git-ubuntu import.

Changelog parent: bc4d79458d389d5e6b648b34945e8e83f5cf222d

New changelog entries:
  * Non-maintainer upload by the Security Team.
  * Fixed CVE-2009-4897: Buffer overflow in gs/psi/iscan.c allows remote
    attackers to execute arbitrary code or cause a denial of service via a
    crafted PDF document containing a long name.
  * Fixed CVE-2010-1628: execute arbitrary code via a PostScript file
    containing unlimited recursive procedure invocations, which trigger
    memory corruption in the stack of the interpreter (Closes: #584516)
  * Rebuild again, there's an old 8.62.dfsg.1-3.2lenny3 build on
    chopin, which prevents builds from trickling in
  * Trigger rebuild, the old upload wasn't processed by buildds
  * CVE-2007-6725 CVE-2008-3522 CVE-2008-6679 CVE-2009-0196
    CVE-2010-0792 CVE-2009-4270 CVE-2010-1869

3f6b72e... by Steffen Joeris <email address hidden> on 2009-03-14

Import patches-applied version 8.62.dfsg.1-3.2lenny1 to applied/debian/lenny

Imported using git-ubuntu import.

Changelog parent: 8b29280f00abf8ec3792301ad3e787adaf7c9c35
Unapplied parent: bc4d79458d389d5e6b648b34945e8e83f5cf222d

New changelog entries:
  * Non-maintainer upload by the security team
  * Include patch from RedHat to fix several integer overflows and add
    upper-bound checks on certain variables in the embedded icc library
    Fixes: CVE-2009-0583 CVE-2009-0584

bc4d794... by Steffen Joeris <email address hidden> on 2009-03-14

Import patches-unapplied version 8.62.dfsg.1-3.2lenny1 to debian/lenny

Imported using git-ubuntu import.

Changelog parent: 2e51fdc417cf63821cc658086be8e805f01ec4db

New changelog entries:
  * Non-maintainer upload by the security team
  * Include patch from RedHat to fix several integer overflows and add
    upper-bound checks on certain variables in the embedded icc library
    Fixes: CVE-2009-0583 CVE-2009-0584

8b29280... by Thomas Viehmann <email address hidden> on 2009-01-05

Import patches-applied version 8.62.dfsg.1-3.2lenny0 to applied/debian/lenny

Imported using git-ubuntu import.

Changelog parent: 572ec3dd4db806b52012e9175eaf570add50f490
Unapplied parent: 2e51fdc417cf63821cc658086be8e805f01ec4db

New changelog entries:
  * Non-maintainer upload to testing, mainly to get fix
    from 8.62.dfsg.1-3.2:
    - Make ghostscript depend on gs-common to prevent removal.
      Drop gs-common -> ghostscript-x dependency to not force the
      X version on all users. Hopefully Closes: #503712.
  * libgs-dev: version Depends: libgs8. Closes: #510691.

2e51fdc... by Thomas Viehmann <email address hidden> on 2009-01-05

Import patches-unapplied version 8.62.dfsg.1-3.2lenny0 to debian/lenny

Imported using git-ubuntu import.

Changelog parent: 9dacaa7f69fbda703700f69112fb23aecd160f0f

New changelog entries:
  * Non-maintainer upload to testing, mainly to get fix
    from 8.62.dfsg.1-3.2:
    - Make ghostscript depend on gs-common to prevent removal.
      Drop gs-common -> ghostscript-x dependency to not force the
      X version on all users. Hopefully Closes: #503712.
  * libgs-dev: version Depends: libgs8. Closes: #510691.

572ec3d... by Thomas Viehmann <email address hidden> on 2008-12-28

Import patches-applied version 8.62.dfsg.1-3.2 to applied/debian/sid

Imported using git-ubuntu import.

Changelog parent: e374f9d77f066f363ecb7bdafbeaf33253e1d2a0
Unapplied parent: 9dacaa7f69fbda703700f69112fb23aecd160f0f

New changelog entries:
  * Non-maintainer upload.
  * Make ghostscript depend on gs-common to prevent removal.
    Drop gs-common -> ghostscript-x dependency to not force the
    X version on all users. Hopefully Closes: #503712.

9dacaa7... by Thomas Viehmann <email address hidden> on 2008-12-28

Import patches-unapplied version 8.62.dfsg.1-3.2 to debian/sid

Imported using git-ubuntu import.

Changelog parent: f8f0e4c1ed9e840deef3bc5d8b5cee9ace6b0d9d

New changelog entries:
  * Non-maintainer upload.
  * Make ghostscript depend on gs-common to prevent removal.
    Drop gs-common -> ghostscript-x dependency to not force the
    X version on all users. Hopefully Closes: #503712.

e374f9d... by Thomas Viehmann <email address hidden> on 2008-08-31

Import patches-applied version 8.62.dfsg.1-3.1 to applied/debian/lenny

Imported using git-ubuntu import.

Unapplied parent: f8f0e4c1ed9e840deef3bc5d8b5cee9ace6b0d9d

f8f0e4c... by Thomas Viehmann <email address hidden> on 2008-08-31

Import patches-unapplied version 8.62.dfsg.1-3.1 to debian/lenny

Imported using git-ubuntu import.