ubuntu/+source/gconf:debian/wheezy

Last commit made on 2012-08-07
Get this branch:
git clone -b debian/wheezy https://git.launchpad.net/ubuntu/+source/gconf
Members of Ubuntu Server Dev import team can upload to this branch. Log in for directions.

Branch merges

Branch information

Name:
debian/wheezy
Repository:
lp:ubuntu/+source/gconf

Recent commits

e2fdd4c... by Michael Biebl on 2012-08-07

Import patches-unapplied version 3.2.5-1+build1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: cbf0df2cd3f3a21507ac5f40590f1f284e2a7aa4

New changelog entries:
  * No source changes; rebuild with xz compression.

cbf0df2... by Michael Biebl on 2012-04-27

Import patches-unapplied version 3.2.5-1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: dcb161a17b862598563679bf28738f2a9e500636

New changelog entries:
  * New upstream release.
  * Bump Build-Depends on cdbs and debhelper for multiarch support.
  * Bump Build-Depends on libglib2.0-dev to (>= 2.31.0).
  * Drop explicit Build-Depends on gir1.2-glib-2.0.
  * Refresh patches.
  * Bump Standards-Version to 3.9.3.

dcb161a... by Josselin Mouette <email address hidden> on 2012-03-17

Import patches-unapplied version 3.2.3-4 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 21b521610285809425c94020e1b3c2e0efcc9159

New changelog entries:
  * Let libgconf2-4 and libgconf-2-4 break gconf2 << 3.2.3-2 to avoid
    triggering gconf2 while in an inconsistent state. Thanks a lot to
    Steve Langasek for the analysis. Closes: #663167.

21b5216... by Jordi Mallach on 2012-02-26

Import patches-unapplied version 3.2.3-3 to debian/sid

Imported using git-ubuntu import.

Changelog parent: fe4cde43155eabf5f47c5dd56704be74dbc140c1

New changelog entries:
  * Let gconf2-common Breaks: libgconf2-4 (<< 3.2.3-2), to avoid partial
    upgrades (closes: #661380).

fe4cde4... by Josselin Mouette <email address hidden> on 2012-02-23

Import patches-unapplied version 3.2.3-2 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 888cca32994ab723dec8423d6fd52afdd98fb7f5

New changelog entries:
  [ Michael Biebl ]
  * debian/libgconf2-dev.install:
    - Remove libtool .la files.
  * debian/control.in:
    - Remove obsolete Conflicts and Replaces.
    - Change section of gir1.2-gconf-2.0 to introspection.
  * Rely on cdbs to call dh_girepository. Bump Build-Depends accordingly.
  * Switch to dh_python2.
  [ Laurent Bigonville ]
  * Add debian/patches/05_readd_gconf_engine_key_is_writable.patch: Add
    missing function in D-Bus variant that causes ABI breakage (Closes: #649112)
  [ Jordi Mallach ]
  * Add a NEWS entry explaining the necessity of a session restart after
    a GConf 2.32 → GConf 3.2 upgrade, due to the ORBit → D-Bus
    transition (closes: #648673).
  [ Josselin Mouette ]
  * Convert to Multi-Arch. Closes: #652861.
    + gconf2, gconf2-common, gconf-defaults-service are M-A: foreign.
    + Move the daemon to a multiarch path.
    + Tighten dependencies.
    + Remove the sanity-check binary, nothing uses it anymore.
      Closes: #649297, #645580.
    + Move the daemon and the activation file to gconf-service, a new
      MA: foreign package.
    + Add appropriate Breaks/Replaces for the activation file.
    + Rename libgconf2-4 to libgconf-2-4, make it MA: same.
    + Make the shlibs add both libgconf-2-4 and gconf-service.
    + Make libgconf2-4 a dummy MA: same package depending on both too.
    + gconf-gsettings-backend is MA: same.
    + Move dbus dependency to gconf-service, make it dbus-x11.
  * Move the API documentation to libgconf2-doc.
  * Get rid of the symlink for documentation.
  * Remove unused gnome-version.mk.
  * gconf-schemas, update-gconf-defaults: don’t purge the environment
    entirely. Closes: #636083.

888cca3... by Josselin Mouette <email address hidden> on 2011-11-12

Import patches-unapplied version 3.2.3-1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 1ad67be96e718cc588ecd43249c906f4f7c1b793

New changelog entries:
  [ Jeremy Bicha ]
  * New upstream release
  * debian/control.in:
    - Use GTK 3
    - Drop orbit dependency
    - Updated Vcs-Browser link
  * debian/copyright: Fixed lintian warning
  * debian/rules:
    - Explicity disable orbit
  * debian/watch: Switch to .xz tarballs
  * 02_fix_wrong_return_value.patch: Updated
  [ Josselin Mouette ]
  * Split the GSettings backend into a gconf-gsettings-backend package
    that provides gsettings-backend. Closes: #633442.
  * New upstream release.

1ad67be... by Michael Biebl on 2011-06-16

Import patches-unapplied version 2.32.4-1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 61bb398320d50e2e74463bcf572c949a53c253c8

New changelog entries:
  * New upstream release.

61bb398... by Michael Biebl on 2011-06-03

Import patches-unapplied version 2.32.3-2 to debian/sid

Imported using git-ubuntu import.

Changelog parent: ae351122e07a0650ff078130dde6dee0e862d0c1

New changelog entries:
  * debian/watch: Switch to .bz2 tarballs.
  * Bump debhelper compatibility level to 8.
    - Bump Build-Depends on debhelper.
    - Strip leading debian/tmp/ from .install files.
  * Bump Standards-Version to 3.9.2. No further changes.
  * Update package description. Fix spelling error "allows to" found by
    lintian.
  * Drop Build-Depends on dpkg-dev (>= 1.13.19). Even lenny has a more recent
    version.
  * Upload to unstable, drop check-dist include.

ae35112... by Sebastien Bacher on 2011-05-18

Import patches-unapplied version 2.32.3-1 to debian/experimental

Imported using git-ubuntu import.

Changelog parent: c8e8444b5eb80b3bd545f9a3943a749611c36128

New changelog entries:
  [ Josselin Mouette ]
  * Make the -dev package depend on the gir package.
  [ Sebastien Bacher ]
  * New upstream version
  * debian/control.in: updated Standards-Version
  * debian/patches/01_defaults_path.patch: new version update

c8e8444... by Emilio Pozuelo Monfort <email address hidden> on 2010-12-12

Import patches-unapplied version 2.32.1-2 to debian/experimental

Imported using git-ubuntu import.

Changelog parent: 58eeee7d5b5cec9f3549b8ca98d5281c19bc9f42

New changelog entries:
  * debian/po-up/*:
    + Removed, the patch has been merged upstream so there's nothing
      to translate.
  * debian/rules:
    + Remove patch-translations.mk.
  * Update to the new gir policy:
    - Rename gir1.0-gconf-2.0 to gir1.2-gconf-2.0.
    - Bump the gobject-introspection build dependency.
    - Build depend on gir1.2 packages.