ubuntu/+source/freeipa:ubuntu/wily

Last commit made on 2015-09-25
Get this branch:
git clone -b ubuntu/wily https://git.launchpad.net/ubuntu/+source/freeipa
Members of Ubuntu Server Dev import team can upload to this branch. Log in for directions.

Branch merges

Branch information

Name:
ubuntu/wily
Repository:
lp:ubuntu/+source/freeipa

Recent commits

5aed73d... by Timo Aaltonen on 2015-09-25

Import patches-unapplied version 4.1.4-1 to debian/experimental

Imported using git-ubuntu import.

Changelog parent: 803256acd094a86eab351f58dfae6579a0f1e30e

New changelog entries:
  * New upstream release. (LP: #1492226)
    - Refresh patches
    - platform-support.diff: Added NAMED_VAR_DIR.
    - fix-bind-conf.diff: Dropped, obsolete with above.
    - disable-dnssec-support.patch: Disable DNSSEC-support as we're
      missing the dependencies for now.
  * control: Add python-usb to build-depends and to python-freeipa
    depends.
  * control: Bump SSSD dependencies.
  * control: Add libsofthsm2-dev to build-depends and softhsm2 to server
    depends.
  * freeipa-{server,client}.install: Add new files.
  * control: Bump Depends on slapi-nis for CVE fixes.
  * control: Bump 389-ds-base, pki-ca depends.
  * control: Drop dogtag-pki-server-theme from server depends, it's not
    needed.
  * control: Server needs newer python-ldap, bump build-dep too.
  * control: Bump certmonger depends.
  * control: Bump python-nss depends.
  * freeipa-client: Add /etc/ipa/nssdb, rework /etc/pki/nssdb handling.
  * platform: Add DebianNamedService.
  * platform, disable-dnssec-support.patch: Fix named.conf template.
  * server.postinst: Run ipa-ldap-updater and ipa-upgradeconfig on
    postinst.
  * Revert DNSSEC changes to schema and ACI, makes upgrade tools fail.
  * server.postrm: Clean logs on purge and disable apache modules on
    remove/purge.

803256a... by Timo Aaltonen on 2015-09-24

Import patches-unapplied version 4.0.5-6 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 277fadef64d1a59286cab5dff4a434008d702032

New changelog entries:
  * control Add gnupg-agent to python-freeipa depends, and change gnupg
    to gnupg2. (LP: #1492184)
  * Rebuild against current krb5, there was an abi break which broke at
    least the setup phase.

277fade... by Timo Aaltonen on 2015-04-09

Import patches-unapplied version 4.0.5-5 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 27f7178364f31aa7cfc8de4708b4776e18018ba6

New changelog entries:
  * control: Drop selinux-policy-dev from build-depends, not needed
    anymore.
  * client.dirs,postrm: Drop removing /etc/pki/nssdb from postrm and let
    dpkg handle it. (Closes: #781114)

27f7178... by Timo Aaltonen on 2015-04-02

Import patches-unapplied version 4.0.5-4 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 9c071faf45ff9daa0c8d9717a0aaac626cb50821

New changelog entries:
  * control: Fix freeipa-tests depends.
  * control: Add systemd-sysv to server depends. (Closes: #780386)
  * freeipa-client.postrm: Purge /etc/pki if empty. (Closes: #781114)
  * add-a-clear-openssl-exception.diff: Add a clear OpenSSL exception.
    (Closes: #772136)
  * control: Add systemd to build-depends.
  * dont-check-for-systemd-pc.diff: Dropped, not needed anymore.

9c071fa... by Timo Aaltonen on 2015-03-04

Import patches-unapplied version 4.0.5-3 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 271d1a2642f3eddfb1a089435050f50e63e8c364

New changelog entries:
  * rules: Set JAVA_STACK_SIZE to hopefully avoid FTBFS on exotic archs.
  * freeipa-client.postrm: Remove nssdb files on purge. (Closes:
    #775387)
  * freeipa-client.postinst: Fix bashism with echo. (Closes: #772242)

271d1a2... by Benjamin Drung <email address hidden> on 2014-11-24

Import patches-unapplied version 4.0.5-2 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 81d49d929dd5aa6b35ca6b9c975e921b90ec75fa

New changelog entries:
  * Team upload.
  * Let python-freeipa depend on python-pyasn1, because pyasn1 is imported
    by ipalib/pkcs10.py and ipalib/plugins/cert.py.
  * debian/copyright: Drop unused PD license section
  * debian/copyright: Fix paths of Javascript files

81d49d9... by Timo Aaltonen on 2014-11-11

Import patches-unapplied version 4.0.5-1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: a039af11b6cf372e6243e8371902d0c69b1a7aff

New changelog entries:
  * New upstream release
    - Fix CVE-2014-7828. (Closes: #768294)
  * control: Update my email address.
  * fix-bind-conf.diff, add-debian-platform.diff: Fix bind config
    template to use Debian specific paths, and replace named.conf not
    named.conf.local. (Closes: #768122)
  * rules, -server.postinst: Create /var/cache/bind/data owned by bind
    user.
  * rules: Fix /var/lib/ipa/backup permissions.
  * Add non-standard-dir-perm to server lintian overrides.
  * copyright: Fix a typo.
  * control: Bump dependency on bind9-dyndb-ldap to 6.0-4~.
  * control: Move dependency on python-qrcode and python-yubico from
    server to python-freeipa and drop python-selinux which belongs to
    pki-server.
  * control: Relax libxmlrpc-core-c3-dev buil-dep and 389-ds-base dep
    for easier backporting.
  * control: Add python-dateutils to server, and python-dbus and python-
    memcache to python-freeipa dependencies. (Closes: #768187)
  * platform: Handle /etc/default/nfs-common and /etc/default/autofs,
    drop NSS_DB_DIR since it's inherited already. (Closes: #769037)
  * control: Bump policy to 3.9.6, no changes.

a039af1... by Timo Aaltonen on 2014-10-31

Import patches-unapplied version 4.0.4-2 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 28e3670cfb3b94f48d1fa999e418e0b0b4dd2e1f

New changelog entries:
  * control: Add python-qrcode, python-selinux, python-yubico
    to freeipa-server dependencies. (Closes: #767427)
  * freeipa-server.postinst: Enable mod_authz_user and mod_deflate too,
    but since they should be part of the default apache2 install, don't
    disable them on uninstall like the other modules. (Closes: #767425)
  * control: Bump server dependency on -mod-nss to 1.0.10-2 which
    doesn't enable the module by default.

28e3670... by Timo Aaltonen on 2014-10-24

Import patches-unapplied version 4.0.4-1 to debian/sid

Imported using git-ubuntu import.