ubuntu/+source/expat:applied/ubuntu/yakkety

Last commit made on 2016-06-22
Get this branch:
git clone -b applied/ubuntu/yakkety https://git.launchpad.net/ubuntu/+source/expat
Members of Ubuntu Server Dev import team can upload to this branch. Log in for directions.

Branch merges

Branch information

Name:
applied/ubuntu/yakkety
Repository:
lp:ubuntu/+source/expat

Recent commits

4915c31... by Laszlo Boszormenyi on 2016-06-21

Import patches-applied version 2.2.0-1 to applied/debian/sid

Imported using git-ubuntu import.

Changelog parent: 4dbdcdfd411b5826147f631b71d36fc7f4bc9abb
Unapplied parent: 029afe618445468e3efa68070b7e1da659eb79fc

New changelog entries:
  * New upstream release, update symbols accordingly.
  * Use upstream manpage for xmlwf.
  * Drop all patches as this release contains those.

029afe6... by Laszlo Boszormenyi on 2016-06-21

Import patches-unapplied version 2.2.0-1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 7f746d9570ab0f8a9d06a9cf15412c6725c30b3c

New changelog entries:
  * New upstream release, update symbols accordingly.
  * Use upstream manpage for xmlwf.
  * Drop all patches as this release contains those.

4dbdcdf... by Laszlo Boszormenyi on 2016-06-05

Import patches-applied version 2.1.1-3 to applied/debian/sid

Imported using git-ubuntu import.

Changelog parent: ea9e05d50e471b2d4320dc485b1cb2d094ad8000
Unapplied parent: 470337f7af79908ecb3a724e9c1fd005afbd41e8

New changelog entries:
  * Use upstream fix for the following security vulnerabilities:
    - CVE-2012-6702, unanticipated internal calls to srand
    - CVE-2016-5300, use of too little entropy

7f746d9... by Laszlo Boszormenyi on 2016-06-05

Import patches-unapplied version 2.1.1-3 to debian/sid

Imported using git-ubuntu import.

Changelog parent: bc37360f43ab2b8c918e9b0a2e499383eb2856dc

New changelog entries:
  * Use upstream fix for the following security vulnerabilities:
    - CVE-2012-6702, unanticipated internal calls to srand
    - CVE-2016-5300, use of too little entropy

470337f... by Laszlo Boszormenyi on 2016-06-05

[PATCH] Resolve call to srand, use more entropy (patch version 1.0)

Gbp-Pq: cve-2012-6702-plus-cve-2016-5300-v1.patch.

2960b33... by Laszlo Boszormenyi on 2016-06-05

[PATCH] Address CVE-2016-0718 (/patch/ version 2.2.1)

Gbp-Pq: CVE-2016-0718-v2-2-1.patch.

591e6da... by Laszlo Boszormenyi on 2016-06-05

[PATCH] Avoid relying on undefined behavior in CVE-2015-1283 fix. It

Gbp-Pq: CVE-2015-1283-refix.patch.

ea9e05d... by Laszlo Boszormenyi on 2016-05-16

Import patches-applied version 2.1.1-2 to applied/debian/sid

Imported using git-ubuntu import.

Changelog parent: 573f67da14d8ace3713b3e698309b8d7df4c1791
Unapplied parent: f1a66d8165a257c599dd9c8cf553e320f6726775

New changelog entries:
  * Avoid relying on undefined behavior in CVE-2015-1283 fix.
  * Apply upstream patch to fix the root cause of CVE-2016-0718 and
    CVE-2016-0719 vulnerabilities.
  * Update Standards-Version to 3.9.8 .

bc37360... by Laszlo Boszormenyi on 2016-05-16

Import patches-unapplied version 2.1.1-2 to debian/sid

Imported using git-ubuntu import.

Changelog parent: a6f9fb70bebf32201d0cde3b5b6118d36e79bc07

New changelog entries:
  * Avoid relying on undefined behavior in CVE-2015-1283 fix.
  * Apply upstream patch to fix the root cause of CVE-2016-0718 and
    CVE-2016-0719 vulnerabilities.
  * Update Standards-Version to 3.9.8 .

f1a66d8... by Laszlo Boszormenyi on 2016-05-16

[PATCH] Address CVE-2016-0718 (/patch/ version 2.2.1)

Gbp-Pq: CVE-2016-0718-v2-2-1.patch.