ubuntu/+source/empathy:ubuntu/disco-devel

Last commit made on 2017-10-11
Get this branch:
git clone -b ubuntu/disco-devel https://git.launchpad.net/ubuntu/+source/empathy
Members of Ubuntu Server Dev import team can upload to this branch. Log in for directions.

Branch merges

Branch information

Name:
ubuntu/disco-devel
Repository:
lp:ubuntu/+source/empathy

Recent commits

7563b8f... by Jeremy Bicha on 2017-10-11

Import patches-unapplied version 3.25.90+really3.12.14-0ubuntu1 to ubuntu/artful-proposed

Imported using git-ubuntu import.

Changelog parent: 42bd40df1c67ae5d0d12a01dcd94d8c19ad5c1a8

New changelog entries:
  * Revert to 3.12.14 per upstream recommendation (LP: #1722583)
  * Restore indicator support and patches (LP: #1712535)
    - debian/control
    - debian/empathy.install
    - 10_use_notify_osd_icons.patch
    - 41_unity_launcher_progress.patch
    - 43_quicklists.patch

42bd40d... by Jeremy Bicha on 2017-08-17

Import patches-unapplied version 3.25.90-0ubuntu1 to ubuntu/artful-proposed

Imported using git-ubuntu import.

Changelog parent: 9ad49567615258623b8e5e1b68d7dd8d7e943b70

New changelog entries:
  * New upstream release
  * debian/control:
    - Build-depend on libwebkit2gtk-4.0-dev instead of libwebkitgtk-3.0-dev
      (Closes: #866637) (LP: #1588150)
    - Bump Build-Depends on libglib2.0-dev to 2.48.0
    - Drop obsolete Build-Depends on libgnutls28-dev
  * Refresh patches
  * Drop patch applied in new release:
    - clutter-gst-3.0.patch
  * Update debian/watch
  * debian/empathy.install: Install appstream metadata in new location

9ad4956... by Ken VanDine on 2017-04-27

Import patches-unapplied version 3.12.13-0ubuntu1 to ubuntu/artful-proposed

Imported using git-ubuntu import.

Changelog parent: 1d42395acb2c9b99b7c7902d711dc8b6f1c2dd2c

New changelog entries:
  * New upstream release
  * Dropped unity related patches
    -debian/patches/23_idomessagedialog_for_voip_and_ft.patch
    -debian/patches/41_unity_launcher_progress.patch
    -debian/patches/43_quicklists.patch
  * Dropped UOA patch
    -debian/patches/ubuntu_launch_uoa_panel.patch
  * Dropped notify-osd icons patch
    -debian/patches/10_use_notify_osd_icons.patch
  * debian/control
    - Removed account-plugin-*, and other UOA related packages. Include GOA
      plugin in the empathy package as there's no benefit to splitting it out
      without UOA
  * debian/compat
    - bumped to 9

1d42395... by Jeremy Bicha on 2016-09-29

Import patches-unapplied version 3.12.12-3ubuntu1 to ubuntu/yakkety-proposed

Imported using git-ubuntu import.

Changelog parent: 6700ec869884f80ab61f8b060e7ff6a4f79772f2

New changelog entries:
  * Merge with Debian. Remaining changes:
    - debian/patches/00_linker-fixes.patch
    - debian/patches/10_use_notify_osd_icons.patch
    - debian/patches/23_idomessagedialog_for_voip_and_ft.patch
    - debian/patches/34_start_raised_execpt_in_session.patch
    - debian/patches/38_default_to_facebook_for_im.patch
    - debian/patches/39_default_to_freenode_for_irc.patch
    - debian/patches/41_unity_launcher_progress.patch
    - debian/patches/42_shell_running.patch
    - debian/patches/43_quicklists.patch:
    - debian/patches/ubuntu_launch_uoa_panel.patch:
      + Patches kept, see patch headers for descriptions.
    - debian/*: Turn on UOA and split out account plugins into
      account-plugins-* and mcp-account-manager-goa/uoa packages.
    - debian/indicators/empathy: Install indicator integration point.
    - debian/shlibs.local: Bump version to 3.12.12
    - debian/control: Don't mention Windows Live Messenger
  * Dropped changes:
    - debian/control:
      + Replace/Conflict/Provide empathy-call: Not needed after Ubuntu 14.04 LTS
  * debian/control:
    - Set X-Ubuntu-Use-Langpack: yes to continue using language packs
      for Ubuntu-specific strings after this package moved to universe
  * debian/rules: Enable all hardening flags

6700ec8... by Laurent Bigonville on 2016-09-18

Import patches-unapplied version 3.12.12-3 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 4cf31e4a7baaea11c48e238b8d4f679373cf3417

New changelog entries:
  [ Jonny Lamb ]
  * Remove myself from Uploaders.
  [ Laurent Bigonville ]
  * debian/control: Drop libgnome-keyring-dev build-dependency, empathy is
    using libsecret for years... (Thanks to Michael Biebl for spotting this)
  * debian/control: Depend against "default-dbus-session-bus |
    dbus-session-bus" instead of "dbus-x11" (Closes: #835877)

4cf31e4... by Laurent Bigonville on 2016-06-05

Import patches-unapplied version 3.12.12-2 to debian/sid

Imported using git-ubuntu import.

Changelog parent: ef5c995f974eb25b5095e056fb65882345da75d1

New changelog entries:
  * debian/control: Drop gnome-icon-theme from the dependencies, do not force
    an icon theme and rely on the one installed by the metapackages

ef5c995... by Laurent Bigonville on 2016-05-19

Import patches-unapplied version 3.12.12-1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: bb1d9fcccf2d1cb24cbbbcfa467f5486dcbab7a0

New changelog entries:
  * New upstream release
    - Drop Don-t-call-XInitThreads-in-Wayland.patch and
      Don-t-crash-in-window_get_workspace-under-Wayland.patch: merged upstream
  * debian/control: Bump Standards-Version to 3.9.8 (no further changes)
  * debian/control: Use https for the Vcs-* URL's to please lintian

bb1d9fc... by Andreas Henriksson on 2016-05-10

Import patches-unapplied version 3.12.11-3 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 7221a9744f50946d8253c3cb1851b70cee0cdd99

New changelog entries:
  * Team upload.
  * Add debian/patches/clutter-gst-3.0.patch
    - from upstream bugzilla porting to clutter-gst-3.0
    - bug: https://bugzilla.gnome.org/show_bug.cgi?id=751185
    - patch origin: https://bugzilla.gnome.org/attachment.cgi?id=316559
    (Closes: #808512)
  * Switch build-dependency to clutter-gst-3.0

7221a97... by Sjoerd Simons on 2016-03-28

Import patches-unapplied version 3.12.11-2 to debian/sid

Imported using git-ubuntu import.

Changelog parent: baff228d8cc537586d7c95fef9374d6a04c30c5d

New changelog entries:
  [ Laurent Bigonville ]
  * Remove empathy-dbg package and rely on automatic dbgsym package
  [ Sjoerd Simons ]
  * d/p/Don-t-crash-in-window_get_workspace-under-Wayland.patch:
    + Added. Fix crash under wayland
  * d/p/Don-t-call-XInitThreads-in-Wayland.patch:
    + Don't bother initting X threas when running under wayland

baff228... by Laurent Bigonville on 2015-10-14

Import patches-unapplied version 3.12.11-1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: afe331cdc8f412d96e10c2783d21565f57abc037

New changelog entries:
  * New upstream release
    - Fix segfault at start (Closes: #800348)