ubuntu/+source/debconf:ubuntu/lucid-devel

Last commit made on 2010-04-09
Get this branch:
git clone -b ubuntu/lucid-devel https://git.launchpad.net/ubuntu/+source/debconf
Members of Ubuntu Server Dev import team can upload to this branch. Log in for directions.

Branch merges

Branch information

Name:
ubuntu/lucid-devel
Repository:
lp:ubuntu/+source/debconf

Recent commits

3320e9a... by Colin Watson on 2010-04-09

Import patches-unapplied version 1.5.28ubuntu4 to ubuntu/lucid

Imported using git-ubuntu import.

Changelog parent: 630e3d79620b7b66619487240a7c093a34ac18be

New changelog entries:
  * Build for python3.1 rather than python3.0.

630e3d7... by Colin Watson on 2010-04-08

Import patches-unapplied version 1.5.28ubuntu3 to ubuntu/lucid

Imported using git-ubuntu import.

Changelog parent: 6b7f3a3f1c72cb10cbc26d6391487876d2910a1b

New changelog entries:
  * Stop building for python2.5 (LP: #558453).

6b7f3a3... by Michael Vogt on 2010-02-05

Import patches-unapplied version 1.5.28ubuntu2 to ubuntu/lucid

Imported using git-ubuntu import.

Changelog parent: 0af38ebe652bc9caf4efb714b782a04cc669136b

New changelog entries:
  * Gnome.pm: Do not show "Cancel" or "Close" buttons
    so that the maintainer scripts do not break
    (LP: #517813 #517810 #517720)

0af38eb... by Colin Watson on 2009-11-10

Import patches-unapplied version 1.5.28ubuntu1 to ubuntu/lucid

Imported using git-ubuntu import.

Changelog parent: cd8936ba881d288f4c50168d6c765f1aba9048d3

New changelog entries:
  * Resynchronise with Debian. Remaining changes:
    - Gnome.pm: Do not show "Cancel" or "Close" buttons during release
      upgrades. Debian Bug: #501767.
    - Build for python2.6, and not for python2.4.
    - Convert debconf.py for python3.0 and install.

cd8936b... by Joey Hess <email address hidden> on 2009-10-20

Import patches-unapplied version 1.5.28 to debian/sid

Imported using git-ubuntu import.

Changelog parent: fb50ea07118d1268453d3a3947135c4a827a6071

New changelog entries:
  [ Colin Watson ]
  * Put debconf-i18n in Section: localization, to match overrides.
  * Remove unused subcommand parameter from
    Debconf::FrontEnd::Passthrough::progress_data().
  * Override Lintian warning about debconf's postrm not calling db_purge;
    debconf itself is a special case here.
  * Declare "Media change" string as needing translation. (apt gives us
    translated messages for substitution into the extended description here,
    but not for the short description.)
  * Remove unused 'use I18N::Langinfo' from Debconf::Element::Gnome
    (LP: #387112).
  * Upgrade to debhelper v7. In the process, convert to python-central with
    DH_PYCENTRAL=nomove (since we need our modules to be usable even when
    debconf is unconfigured; at the moment, the effect of this use of
    python-central is only to add a Python-Versions control field).
  [ Christian Perrier ]
  * Add translation of "-a" in "man dpkg-reconfigure".
    Patch by Simon Paillard.
  * Suggest reporting bugs related to French translations in the French
    l10n mailing list. Patch by Simon Paillard.
  * French debconf translation update
  [ Joey Hess ]
  * document --terse in relevant man pages and show --no-reload in
    dpkg-reconfigure usage. Closes: #548994
  * German man page addendum fixed. Closes: #546789
  * Dropped the KDE frontend. libqt-perl is uninstallable, and
    work on the new qt4 perl bindings and a new KDE frontend based on
    them is not ready. If the KDE frontend is specified, debconf will
    now attempt to fall back to the Gnome frontend, or failing that,
    to dialog. Closes: #522580
  * Enable set -e in debconf-utils postinst.
  [ Programs translation updates ]
  * Portuguese (Miguel Figueiredo). Closes: #551379
  [ Debconf translation updates ]
  * Asturian (Marcos Alvarez Costales).
  * Bulgarian (Damyan Ivanov).
  * Finnish (Tapio Lehtonen).
  * Czech (Miroslav Kure).
  * Esperanto (Felipe Castro).
  * Simplified Chinese (Carlos Z.F. Liu).
  * Slovak (Ivan Mas├ír).
  * German (Holger Wansing).
  * Bengali (Md. Rezwan Shahid).
  * Basque (Piarres Beobide).
  * Japanese (Kenshi Muto).
  * Russian (Yuri Kozlov).

fb50ea0... by Colin Watson on 2009-07-03

Import patches-unapplied version 1.5.27 to debian/squeeze

Imported using git-ubuntu import.

Changelog parent: 5881d0d99b33f3d26e0c64f7cb59936fda1b4db7

New changelog entries:
  * Fix Plural-Forms header in Tagalog translation.
  * debconf-apt-progress: If we didn't start the debconf frontend ourselves,
    then it's unlikely that the passthrough child will be able to start
    debconf normally, so tell it to use a pipe database in that case and
    rely on passthrough to save answers (LP: #337306).
  * debconf-apt-progress: DEBIAN_HAS_FRONTEND is always set here at some
    point, even if only on the second run after starting debconf, so we need
    to invert our handling of the check for whether we started the debconf
    frontend ourselves (LP: #347648).
  * Minor GET optimisation: fetch the question value only once rather than
    twice.
  * debconf-apt-progress: If we get cancelled very early on before managing
    to start the process we're controlling, make sure that we don't carry on
    and start it anyway, and that we still return 30.
  * debconf-apt-progress: Handle cancellation right at the end. We don't
    have a process to kill at this point, but we should at least return the
    correct exit code.
  [ Manpages translations ]
  * Completed german man page translation. Closes: #518396
  * Completed French man page translation. Closes: #520787
  [ Debconf translations ]
  * Added Asturian. Closes: #518977
  * Added Bengali
  [ Programs translations ]
  * Added Asturian. Closes: #518977
  * Added Bengali

5881d0d... by Colin Watson on 2009-03-03

Import patches-unapplied version 1.5.26 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 1708228bb86f68bc55c2ee64487c9e6aca8d41ee

New changelog entries:
  * Use 'key not in dict' rather than 'not dict.has_key(key)' in debconf.py;
    dict.has_key is deprecated in Python 2.6.
  * debconf-apt-progress: Don't send STOP if we didn't start the debconf
    frontend ourselves; in that case the application calling us should
    arrange to stop itself.
  * debconf.py: Use subprocess rather than popen2 if it's available. popen2
    is deprecated in Python 2.6.

1708228... by Colin Watson on 2009-02-19

Import patches-unapplied version 1.5.25 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 0e0a1927fd916ff33b9e0c0bb23ef2c1c9a71f44

New changelog entries:
  [ Joey Hess ]
  * debconf-devel(7): Fix state machine example to handle case where user
    backs out of first question.
  [ Colin Watson ]
  * Support overriding frontend's package name determination (used to set
    the owner) using the DEBCONF_PACKAGE environment variable. Useful for
    applications driving debconf other than by way of package installation.
  * Refer to po-debconf(7) rather than its README (thanks, James R. Van
    Zandt). Closes: #505392
  * Refer to debconf-show(1) from dpkg-reconfigure(8) for those who just
    want to see the current configuration. Closes: #506070
  * Only use -C fields when explicitly disabling internationalisation within
    debconf (or when DEBCONF_C_VALUES=true), not merely when in the C
    locale. Based on a patch by Frans Pop, for which thanks! Closes: #476873
  * Force fallback to the default template if we encounter 'en' in the
    locale list and no language-specific template for English was
    found,since English text is usually found in a plain field rather than
    something like Choices-en.UTF-8. This allows you to override other
    locale variables for a different language with LANGUAGE=en. Thanks again
    to Frans Pop. Closes: #496631
  [ Manpages translations ]
  * Completed german man page translation.
  [ Debconf translations ]
  * Corrections in german translation with apologies for
    forgetting this bug report. Closes: #462302

0e0a192... by Colin Watson on 2008-10-12

Import patches-unapplied version 1.5.24 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 551a945d0a115bb8588ba2f2c04ea632fd0e0420

New changelog entries:
  [ Joey Hess ]
  * debconf(7): Clarify reason for libterm-readline-gnu-perl being recommended
    for users of readline frontend. Closes: #497357
  [ Manpages translations ]
  * Updated german man page translation. Closes: #492370
  * German proofread by Helge Kreutzmann. Copyright fixed to include
    Florian Rehnisch
  * Corrected French manpages translation wrt "interactive".
    Closes: #496555
  [ Debconf translations ]
  * Hindi updated.
  * Greek updated. Closes: #498580
  [ Programs translations ]
  * Hindi updated.
  * Greek updated. Closes: #498577
  [ Joey Hess ]
  * debconf.7: Remove whitespace in manrefs. Closes: #498446
  [ Colin Watson ]
  * Fall back to untranslated fields if asking explicitly for any
    nonexistent translated field, not just Choices-C. For example, asking
    for Choices-en.UTF-8 should fall back to Choices if Choices-en.UTF-8
    doesn't exist. LP: #271652
  * Remove some dead code in Debconf::Template::AUTOLOAD.
  * Add an AUTHOR section to debconf-escape(1) to make the German po4a
    translations work better.
  * Add missing =back to debconf-apt-progress(1)'s OPTIONS section.
  * Use =head1 in German POD addendum, not =HEAD1. Together with switching
    output to UTF-8 (below), this fixes various problems with German manual
    page output. Closes: #492368
  * Recode all manual pages to UTF-8 and re-enable Russian manual page
    generation, now that pod2man has a --utf8 option. Requires perl (>=
    5.10.0-16) as bug #500210 broke the Russian pages. Closes: #485756
  [ Manpages Translations ]
  * Russian updated. Closes: #482288
  * French updated.
  * German added. Closes: #486869
  [ Debconf translations ]
  * Macedonian. Closes: #485993
  * Romanian. Closes: #488530
  * Korean. Closes: #491515
  [ Programs translations ]
  * Catalan. Closes: #486714
  * Romanian. Closes: #488530
  * Korean. Closes: #491515
  [ Joey Hess ]
  * Typo. Closes: #486870
  * Disable Russian man pages until the encoding issue affecting them can be
    fixed.

551a945... by Joey Hess <email address hidden> on 2008-05-14

Import patches-unapplied version 1.5.22 to debian/lenny

Imported using git-ubuntu import.