ubuntu/+source/bind9:ubuntu/edgy-updates

Last commit made on 2008-01-11
Get this branch:
git clone -b ubuntu/edgy-updates https://git.launchpad.net/ubuntu/+source/bind9
Members of Ubuntu Server Dev import team can upload to this branch. Log in for directions.

Branch merges

Branch information

Name:
ubuntu/edgy-updates
Repository:
lp:ubuntu/+source/bind9

Recent commits

ce2faba... by Soren Hansen on 2008-01-11

Import patches-unapplied version 1:9.3.2-2ubuntu3.3 to ubuntu/edgy-proposed

Imported using git-ubuntu import.

Changelog parent: cac5cdb2dc8f75106a4f1b0a26ee545537c84007

New changelog entries:
  * l.root-servers.net. got a new IP. (LP #160176)

cac5cdb... by Kees Cook on 2007-07-24

Import patches-unapplied version 1:9.3.2-2ubuntu3.2 to ubuntu/edgy-security

Imported using git-ubuntu import.

Changelog parent: b06721f35cf5c7d34efa37f0f5fa4a8c9283087c

New changelog entries:
  * SECURITY UPDATE: query responses could be forged remotely.
  * bin/named/client.c, lib/dispatch.c, lib/include/dispatch.h:
    upstream fixes back ported.
  * References
    CVE-2007-2926

b06721f... by Kees Cook on 2007-01-25

Import patches-unapplied version 1:9.3.2-2ubuntu3.1 to ubuntu/edgy-security

Imported using git-ubuntu import.

Changelog parent: 88a601502e2f81b386a3882ac1257a51a48fcb7a

New changelog entries:
  * SECURITY UPDATE: remote denial of service.
  * lib/dns/include/dns/validator.h, lib/dns/{validator,resolver}.c,
    lib/dns/api: fixes taken from upstream changes between bind 9.3.3 and
    9.3.4, applied inline.
  * References
    CVE-2007-0493 CVE-2007-0494

88a6015... by Kees Cook on 2006-09-28

Import patches-unapplied version 1:9.3.2-2ubuntu3 to ubuntu/edgy

Imported using git-ubuntu import.

Changelog parent: 025ef1a0a62f95a73eaeb9e3983fa98185fd38f0

New changelog entries:
  * SECURITY UPDATE: name servers accessible from the Internet could be
    used as an amplifier in DDoS attacks against other networks.
  * debian/named.conf.options: allow recursion only on localnets. This
    matches the default configuration of listening on all interfaces, and
    gives a reasonable balance between allowing local recursion, and
    protecting the server from being used in a DDoS attack.
  * References
    CVE-2006-0987
    http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=248899

025ef1a... by Martin Pitt on 2006-09-07

Import patches-unapplied version 1:9.3.2-2ubuntu2 to ubuntu/edgy

Imported using git-ubuntu import.

Changelog parent: 796403a9a7f5d778f4b0b7cabed56fc15859b94d

New changelog entries:
  * SECURITY UPDATE:
  * bin/named/query.c, lib/dns/resolver.c: Apply upstream patch from 9.3.2-P1
    to fix the following flaws:
    - A remote user (DNS server) can send specially crafted RRset responses in
      return to a recursive SIG query to cause the requesting named service to
      crash [CVE-2006-4095].
    - A remote user can also send specially crafted queries to trigger an
      INSIST failure and cause the requesting service(s) to crash
      [CVE-2006-4096].

796403a... by Matthias Klose on 2006-02-16

Import patches-unapplied version 1:9.3.2-2ubuntu1 to ubuntu/dapper

Imported using git-ubuntu import.

Changelog parent: 59492a43d1d09a75d28ea043305e8d47b7ffb899

New changelog entries:
  * Drop build dependency on g++-3.4 (#292958 was filed for g++-3.3,
    fixed in g++-3.4 and up).

59492a4... by LaMont Jones on 2006-01-16

Import patches-unapplied version 1:9.3.2-2 to ubuntu/dapper

Imported using git-ubuntu import.

Changelog parent: cf1c81a93002d7c985bd90f718cbc26bac10ce6d

New changelog entries:
  * correct force-reload. Closes: #333841
  * Fix init.d's usage message. Closes: #331090
  * resolvconf tweaks. Closes: #252232, #275412

cf1c81a... by LaMont Jones on 2006-01-05

Import patches-unapplied version 1:9.3.2-1 to ubuntu/dapper

Imported using git-ubuntu import.

Changelog parent: db70125f9a50498643d330fee2dd7b1cbb10567c

New changelog entries:
  * New upstream
  * use lsb-base for start/stop messages in init.d.
  * switch to debhelper 4
  * Getting good reports from experimental, uploading to sid.
    Release team, please consider this package for sarge. Thanks.
  * correct pidfile name in init.d/lwresd. Closes: #298100
  * Build with gcc-3.4 on powerpc, to work around #292958.
  * New upstream version.
  * new upstream version
  * New upstream version

db70125... by LaMont Jones on 2004-09-23

Import patches-unapplied version 1:9.2.4-1 to ubuntu/warty

Imported using git-ubuntu import.