ubuntu/+source/base-files:debian/buster

Last commit made on 2019-09-07
Get this branch:
git clone -b debian/buster https://git.launchpad.net/ubuntu/+source/base-files
Members of Ubuntu Server Dev import team can upload to this branch. Log in for directions.

Branch merges

Branch information

Name:
debian/buster
Repository:
lp:ubuntu/+source/base-files

Recent commits

0239dd1... by Santiago Vila <email address hidden> on 2019-08-30

Import patches-unapplied version 10.3+deb10u1 to debian/buster

Imported using git-ubuntu import.

Changelog parent: a36ea61accd393ae931a0b532d4b112db470f88b

New changelog entries:
  * Change /etc/debian_version to 10.1, for Debian 10.1 point release.

a36ea61... by Santiago Vila <email address hidden> on 2019-05-13

Import patches-unapplied version 10.3 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 5f6fba1f870e70429819066f1b9afedcf25149be

New changelog entries:
  * Add Breaks: debian-security-support (<< 2019.04.25). Closes: #928172.
    This is the first version of debian-security-support which does not break
    when /etc/debian_version contains a string in the form "10.x".

5f6fba1... by Santiago Vila <email address hidden> on 2019-04-19

Import patches-unapplied version 10.2 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 9fe105e771a3b67f9805c42178e4d5f23f878460

New changelog entries:
  * Release candidate for buster as stable:
  - Use "10" as version in /etc/issue and /etc/issue.net.
    (never expected to change after buster is released)
  - Use 10.0 as version in /etc/debian_version.
    (expected to change at every point release)
  - Change PRETTY_NAME in /usr/lib/os-release, adding 10 as version number
    and "(buster)" as codename. Add also VERSION_ID and VERSION.
    (never expected to change)
  - Add VERSION_CODENAME to os-release. Closes: #829245. This is optional
    according to the specs but some people find it useful. Please note that
    for now this is only expected to be present on stable releases.
  - Update README (buster -> bullseye).

9fe105e... by Santiago Vila <email address hidden> on 2018-01-13

Import patches-unapplied version 10.1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 889379624765b670aaf76558512988ce64b17a6e

New changelog entries:
  * Add CC0-1.0 to common-licenses. Closes: #859649, #882628.
    Source: https://creativecommons.org/publicdomain/zero/1.0/legalcode.txt.
  * Simplify debian/rules a little bit by dropping install target
    and using override_dh_auto_install instead. Closes: #886901.
    Package should now build from source again in every supported way.
    Thanks to Daniel Schepler for the report and to Niels Thykier for
    clarifying the true nature of this bug.
  * Do not create /etc/staff-group-for-usr-local on new installs anymore.
    Do not create it on upgrades either, as we don't support upgrades
    skipping stable releases, and even less skipping several releases.
  * Standards-Version: 4.1.3.

8893796... by Santiago Vila <email address hidden> on 2017-06-25

Import patches-unapplied version 10 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 65b099a28c346576498596b72949b6a64488faea

New changelog entries:
  * Change issue, issue.net, debian_version and os-release to read
    "buster/sid", and drop VERSION and VERSION_ID from os-release.
  * Fix typo in changelog for version 9.

65b099a... by Santiago Vila <email address hidden> on 2017-04-04

Import patches-unapplied version 9.9 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 816cdfae6382f4423fdc7934878cd0e7bdb16e2b

New changelog entries:
  * Add MPL-1.1 and MPL-2.0 to common-licenses. Closes: #849835.
    License texts taken from https://www.mozilla.org/en-US/MPL/.
  * Add a default /etc/update-motd.d/10-uname script to
    recover the traditional motd behaviour. Closes: #859124.

816cdfa... by Santiago Vila <email address hidden> on 2017-01-15

Import patches-unapplied version 9.8 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 1d6d4ade3dc45af6550613d9c94ca07bf8e93993

New changelog entries:
  * Release candidate for stretch as stable:
  - Use "9" as version in /etc/issue and /etc/issue.net.
    (never expected to change after stretch is released)
  - Use 9.0 as version in /etc/debian_version.
    (expected to change at every point release)
  - Change PRETTY_NAME in /usr/lib/os-release, adding 9 as version number
    and "(stretch)" as codename. Add also VERSION_ID and VERSION.
    (never expected to change)
  - Update README (stretch -> buster).
  * Standards-Version: 3.9.8 (no special changes for this).

1d6d4ad... by Santiago Vila <email address hidden> on 2016-11-27

Import patches-unapplied version 9.7 to debian/sid

Imported using git-ubuntu import.

Changelog parent: eb2b2eb8ab95458692ed7409b28edc328c2a0980

New changelog entries:
  * Do not care about /etc/nsswitch.conf anymore, as the file has been
    moved to libc-bin. Closes: #827095.
  [ Guillem Jover ]
  * Do not use gzip compression anymore to build .deb and use the default.

eb2b2eb... by Santiago Vila <email address hidden> on 2016-03-04

Import patches-unapplied version 9.6 to debian/sid

Imported using git-ubuntu import.

Changelog parent: d63b00773e15368db8ee1ed7de31d7624c12b401

New changelog entries:
  * Add lintian override for /etc/os-release.
  * Add lintian overrides for /usr/share/common-licenses.
  * Standards-Version: 3.9.7 (no special changes for this).
  * Switch to dh. Hopefully this should make the package easier
    to fork. Closes: #693423.
  * Change default /etc/profile to not warn about possibly undefined
    variables PS1 and BASH. Closes: #776154.

d63b007... by Santiago Vila <email address hidden> on 2015-10-28

Import patches-unapplied version 9.5 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 04f6172335cd320c3e25a3eca312a75b2006697a

New changelog entries:
  * os-release: Drop trailing slash in SUPPORT_URL variable, as the URL
    is not supposed to have it. Closes: #781809, #800791.