ubuntu/+source/avogadro:ubuntu/quantal

Last commit made on 2012-08-10
Get this branch:
git clone -b ubuntu/quantal https://git.launchpad.net/ubuntu/+source/avogadro
Members of Ubuntu Server Dev import team can upload to this branch. Log in for directions.

Branch merges

Branch information

Name:
ubuntu/quantal
Repository:
lp:ubuntu/+source/avogadro

Recent commits

aed1b7d... by Sebastien Bacher on 2012-08-10

Import patches-unapplied version 1.0.3-5ubuntu2 to ubuntu/quantal

Imported using git-ubuntu import.

Changelog parent: 3fca2ff075aff6f262d0a1b2986312821d1525d7

New changelog entries:
  * No change rebuild with the new glew

3fca2ff... by St├ęphane Graber on 2012-07-04

Import patches-unapplied version 1.0.3-5ubuntu1 to ubuntu/quantal

Imported using git-ubuntu import.

Changelog parent: d3fbaa604bc64fff87a90b0279943a27c59be003

New changelog entries:
  * Apply patch from Debian bug #679819:
    Drop semi-obsolete use of version specify python packages to restore
    installability (python-qt4 stopped providing one of the required packages).

d3fbaa6... by Daniel Leidert on 2012-06-06

Import patches-unapplied version 1.0.3-5 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 7b44804420faed87318350931a67ca801cb9782e

New changelog entries:
  * debian/control (Uploaders): Removed Jordan Mantha. Thanks for your work.
    (Build-Depends): Use libglew-dev.
    (Depends): Let libavogadro-dev depend on libglew-dev.

7b44804... by Daniel Leidert on 2012-06-04

Import patches-unapplied version 1.0.3-4 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 3d3bb0acc85f24bb1c1bab727c03b83757623073

New changelog entries:
  [ Michael Banck ]
  * Acknowledge NMU.
  * debian/patches/hurd_ftbfs.patch: New patch, fixing build on hurd-i386,
    thanks to Pino Toscano.
  [ Daniel Leidert ]
  * debian/control (Standards-Version): Bumped to 3.9.3.
    (Build-Depends): Added versioned dependency on python-numpy.
  * debian/rules (override_dh_python2): Added call to dh_numpy to fix lintian
    error.
  * debian/upstream: Added.

3d3bb0a... by "Steve M. Robbins" <email address hidden> on 2012-01-28

Import patches-unapplied version 1.0.3-3.1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: e27c73585e6e664463daa187273fd2cf1cfbef25

New changelog entries:
  * Non-Maintainer Upload.

  * patches/boost148.patch: New. Work around moc limitation. Closes:
    #653625.

e27c735... by Daniel Leidert on 2011-12-05

Import patches-unapplied version 1.0.3-3 to debian/sid

Imported using git-ubuntu import.

Changelog parent: bd6c2d467beb7fa362425468820039bd56b6e54e

New changelog entries:
  * debian/control (Build-Depends): Added libgl2ps-dev.
  * debian/patches/link_to_libgl2ps.patch: Added.
    - Link with -lgl2ps instead of compiling and linking the internal copy.
  * debian/patches/series: Adjusted.
  [ Michael Banck ]
  * debian/copyright: Explicitly state the 3-clause BSD license for the cmake
    module files.
  * debian/rules, debian/control: Convert to dh_python2, thanks to Barry
    Warsaw (Closes: #616742)
  * debian/patches/nwchem_input_ccsd.patch: New patch, fixes NWChem input
    extension input file generation for the CCSD method.
  [ Daniel Leidert ]
  * debian/avogadro.install: Install missing avopkg tool.
  * debian/compat: Increased dh compatibility level.
  * debian/control: Set X-Python-Version to 'current'. Use wrap-and-sort
    for *Depends* and Uploaders.
    (Build-Depends): Removed cdbs and patchutils. Increased required debhelper
    version.
    (Standards-Version): Bumped to 3.9.2.
    (Vcs-Browser): Point to real location.
    (Description): Fixed a typo reported by lintian.
    (Conflicts): Changed conflicts-with-version warning into Breaks.
  * debian/copyright: Minor update.
  * debian/pycompat: Dropped obsolete file.
  * debian/rules: Rewritten for debhelper 7.
  * debian/patches/nwchem_input_ccsd.patch: Added patch documentation.
  * debian/patches/series: Added.

bd6c2d4... by Michael Banck on 2011-04-25

Import patches-unapplied version 1.0.3-1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: f4dade2720698f043aeff43165be682d5560ea89

New changelog entries:
  * New upstream release.
  * debian/patches/install_translations.patch: Removed, applied upstream.
  * debian/source/format: New file, switching to 3.0/quilt.

f4dade2... by Michael Banck on 2011-04-23

Import patches-unapplied version 1.0.2-1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 10b0df28ba60486f787c0200f97180c8d94e1e6c

New changelog entries:
  * New upstream release.
    + Fixes crash on Undo after erasing of any atom with attached Hs
      (Closes: #602388).
  * debian/avogadro.install: Explicitely install /usr/bin/avogadro, avoiding
    avopkg.
  * debian/libavogadro-dev.install: Move avogadro.prf from /usr/features to
    /usr/share/qt4/mkspecs.
  * debian/patches/install_translations.patch: New file, fix installation of
    translations, taken from upstream.
  * debian/control (Build-Depends): Removed sip4.
  * debian/control (Standards-Version): Bumped to 3.9.1.

10b0df2... by Michael Banck on 2010-05-19

Import patches-unapplied version 1.0.1-3 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 1da9984a4a63d28530db3d0ffdb0d9c03ec8335c

New changelog entries:
  [ Daniel Leidert ]
  * debian/avogadro.install: Install manual pages from upstream.
  * debian/avogadro.manpages,
    debian/avogadro.1: Dropped in favour of upstream manual pages.
  * debian/libavogadro-dev.install: Install .prf file for QMake projects.
  [ Michael Banck ]
  * debian/rules (DEB_DH_GENCONTROL_ARGS_python-avogadro): Replace
    python$(PYVER)-sip4 by python$(PYVER)-sip (Closes: #581972).
  * debian/rules (binary-install/python-avogadro): Added dh_sip.
  * debian/control (python-avogadro/Depends): Added ${sip:Depends}.
  * debian/control (Build-Depends): Replaced python-sip4-dev by
    python-sip-dev.

1da9984... by Michael Banck on 2010-05-07

Import patches-unapplied version 1.0.1-2 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 4c5e1f8ca118b39ee579fb4df72b286b0affa58b

New changelog entries:
  * debian/rules (DEB_CMAKE_EXTRA_FLAGS): Define PYTHON_EXECUTABLE,
    PYTHON_LIBRARY and PYTHON_INCLUDE_DIR in order to make sure the correct
    version of python is used in case several are co-installed, thanks to
    Jakub Wilk (Closes: #577439).
  * New upstream release.
    + Fixes crash when importing PDB files via network (Closes: #570230).
  * debian/patches/sip_4.10_support.patch: Removed, applied upstream.
  * debian/control (Build-Depends): Bump required libqt4-dev version to
    4.5.0, as per CMakeLists.txt.