ubuntu/+source/avogadro:ubuntu/natty-devel

Last commit made on 2011-04-15
Get this branch:
git clone -b ubuntu/natty-devel https://git.launchpad.net/ubuntu/+source/avogadro
Members of Ubuntu Server Dev import team can upload to this branch. Log in for directions.

Branch merges

Branch information

Name:
ubuntu/natty-devel
Repository:
lp:ubuntu/+source/avogadro

Recent commits

fa79a77... by KunalGoel on 2011-04-07

Import patches-unapplied version 1.0.1-3.2ubuntu2 to ubuntu/natty

Imported using git-ubuntu import.

Changelog parent: 2d9a0559bf2dd3effa1a788e608ae0df4f220a43

New changelog entries:
  * Revert back the changes as build fails for arm
  * build disabled for arm as build dependency on
    libOpenGL and libQtOpenGL

2d9a055... by KunalGoel on 2011-03-29

Import patches-unapplied version 1.0.1-3.2ubuntu1 to ubuntu/natty

Imported using git-ubuntu import.

Changelog parent: 72a7f56bf7e337d47cc23ca8cc4437302bbe7f4c

New changelog entries:
  * Only build-dep on libqt4-opengl-dev and libglew1.5-dev on [i386 amd64
   powerpc] to fix armel FTBFS due to the GL/GLES transition (LP: #707794)

72a7f56... by Jonathan Riddell on 2011-03-28

Import patches-unapplied version 1.0.1-3.2build1 to ubuntu/natty

Imported using git-ubuntu import.

Changelog parent: d7025e5557143a0edc0c80df7d61cfe2b7b87860

New changelog entries:
  * Rebuild for moved libX11

d7025e5... by Scott Kitterman on 2011-03-09

Import patches-unapplied version 1.0.1-3.2 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 2208b2ad080bad479916e66c74aa7272910a1243

New changelog entries:
  * Non-maintainer upload.
  * Fix FTBFS with new SIP API (8.0) (Closes: #616183)
    - Patch from Gentoo Bug 345423 via Ubuntu

2208b2a... by Scott Kitterman on 2011-02-17

Import patches-unapplied version 1.0.1-3.1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 10b0df28ba60486f787c0200f97180c8d94e1e6c

New changelog entries:
  * Non-maintainer upload.
  * Drop obsolete build-depends on sip4 (Closes: #611091)

10b0df2... by Michael Banck on 2010-05-19

Import patches-unapplied version 1.0.1-3 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 1da9984a4a63d28530db3d0ffdb0d9c03ec8335c

New changelog entries:
  [ Daniel Leidert ]
  * debian/avogadro.install: Install manual pages from upstream.
  * debian/avogadro.manpages,
    debian/avogadro.1: Dropped in favour of upstream manual pages.
  * debian/libavogadro-dev.install: Install .prf file for QMake projects.
  [ Michael Banck ]
  * debian/rules (DEB_DH_GENCONTROL_ARGS_python-avogadro): Replace
    python$(PYVER)-sip4 by python$(PYVER)-sip (Closes: #581972).
  * debian/rules (binary-install/python-avogadro): Added dh_sip.
  * debian/control (python-avogadro/Depends): Added ${sip:Depends}.
  * debian/control (Build-Depends): Replaced python-sip4-dev by
    python-sip-dev.

1da9984... by Michael Banck on 2010-05-07

Import patches-unapplied version 1.0.1-2 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 4c5e1f8ca118b39ee579fb4df72b286b0affa58b

New changelog entries:
  * debian/rules (DEB_CMAKE_EXTRA_FLAGS): Define PYTHON_EXECUTABLE,
    PYTHON_LIBRARY and PYTHON_INCLUDE_DIR in order to make sure the correct
    version of python is used in case several are co-installed, thanks to
    Jakub Wilk (Closes: #577439).
  * New upstream release.
    + Fixes crash when importing PDB files via network (Closes: #570230).
  * debian/patches/sip_4.10_support.patch: Removed, applied upstream.
  * debian/control (Build-Depends): Bump required libqt4-dev version to
    4.5.0, as per CMakeLists.txt.

4c5e1f8... by Michael Banck on 2010-02-20

Import patches-unapplied version 1.0.0-3 to debian/sid

Imported using git-ubuntu import.

Changelog parent: bcfa17699c695fdd5c55da51f4b8c187f80270bb

New changelog entries:
  [ Jordan Mantha ]
  * debian/python-avogadro.install: use wildcard to catch both site-packages
    and dist-packages python directories.
  [ Michael Banck ]
  * debian/patches/sip_4.10_support.patch: New patch, recognize new SIP
    version, taken from upstream (closes: #569438).

bcfa176... by Michael Banck on 2009-11-13

Import patches-unapplied version 1.0.0-2 to debian/sid

Imported using git-ubuntu import.

Changelog parent: ab42411ee7caa3accedd008f190a90710b0e78cc

New changelog entries:
  [ Michael Banck ]
  * debian/libavogadro0.install: Wildcard the API directory.
  * debian/libavogadro-dev.install: Likewise.
  * debian/libavogadro0.install: Renamed to ...
  * debian/libavogadro1.install: ... this.
  * debian/control (libavogadro0): Renamed package to libavogadro1. Update
    all references.
  * debian/rules: Likewise.
  * debian/control (libavogadro1): Replace and Conflict with libavogadro0.
  * debian/control (avogadro-data): New package.
  * debian/control (avogadro): Recommend avogadro-data.
  * debian/control (libavogadro1): Likewise.
  * debian/libavogadro1.install: No longer ship /usr/share/libavogadro.
  * debian/avogadro.install: Only ship i18n directory from
    /usr/share/avogadro.
  * debian/avogadro-data.install: New file.
  * debian/python-avogadro.install: Install wireframe.py explicitely
    ommitting example.py (closes: #555627).
  * debian/libavogadro-dev.install: Ship AvogadroBuildSettings.cmake,
    AvogadroLibraryDeps.cmake and AvogadroUse.cmake as well.
  * debian/control (avogadro-date): Replace and Conflict with prior versions
    of the avogadro and libavogadro0 packages.
  * debian/python-avogadro.dirs: New file.
  [ Daniel Leidert ]
  * debian/python-avogadro.files: Dropped.
  * debian/python-avogadro.install: Install scripts from debian/tmp.
  * debian/rules (binary-install/python-avogadro): Adjusted for changes above.

ab42411... by Michael Banck on 2009-10-23

Import patches-unapplied version 1.0.0-1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 6a07db65173980589165ad591cd41c412b5eb750

New changelog entries:
  * New upstream release.
  * debian/patches/sip_4.9_support.patch: Removed, applied upstream.
  * debian/patches/fix_empty_second_window.patch: Likewise.
  * debian/patches/fix_molpro_input_generator.patch: Likewise.
  * debian/libavogadro0.install: Adjust for additional API directory.
  * debian/libavogadro-dev.install: Likewise.