ubuntu/+source/avogadro:debian/jessie

Last commit made on 2014-01-23
Get this branch:
git clone -b debian/jessie https://git.launchpad.net/ubuntu/+source/avogadro
Members of Ubuntu Server Dev import team can upload to this branch. Log in for directions.

Branch merges

Branch information

Name:
debian/jessie
Repository:
lp:ubuntu/+source/avogadro

Recent commits

2424270... by Anton Gladky on 2013-11-03

Import patches-unapplied version 1.0.3-10.1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: c5e146cc4d6098f187d30e842527887750e7383e

New changelog entries:
  * Non-maintainer upload.
  * Replace eigen2 by eigen3. (Closes: #728610)

c5e146c... by Debichem Team <email address hidden> on 2013-06-02

Import patches-unapplied version 1.0.3-10 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 3782491498f6d2c137a5ad59cf40a3cd789a5862

New changelog entries:
  [ Daniel Leidert ]
  * debian/rules (override_dh_auto_configure): Drop setting of
    -DPYTHON_INCLUDE_DIRS. This didn't work on other architectures than amd64.
  * debian/patches/series: Don't use the use_python_include_dirs.patch patch.

3782491... by Debichem Team <email address hidden> on 2013-06-02

Import patches-unapplied version 1.0.3-9 to debian/sid

Imported using git-ubuntu import.

Changelog parent: a11677b3b6ce85f081615b96a0e73c93448837fb

New changelog entries:
  [ Daniel Leidert ]
  * debian/rules (override_dh_auto_configure): Try to fix the recently
    introduced FTBFSes (really closes: #710703).
  * debian/patches/use_python_include_dirs.patch: Reverted to 1.0.3-7.
  [ Daniel Leidert ]
  * debian/control (Vcs-Browser, Vcs-Svn): Fixed vcs-field-not-canonical.
  * debian/rules: Try to fix an FTBFS if several Python versions are installed
    (closes: Bug#710703) and don't FTBFS if there is no multi-arch Python.
  * debian/patches/use_python_include_dirs.patch: Updated.
    - Removed patch to cmake/modules/PythonDeps.cmake.

a11677b... by Debichem Team <email address hidden> on 2013-05-29

Import patches-unapplied version 1.0.3-7 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 11764f82a9d30bf35f0d7d69c53c4810d87b647e

New changelog entries:
  [ Daniel Leidert ]
  * Ack NMU.
  * debian/rules: Prepare for Python multiarch.
    (override_dh_auto_configure): Adjusted likewise.
  * debian/patches/use_python_include_dirs.patch: Enabled (closes: #708639).
  * debian/patches/series: Adjusted.

11764f8... by Matthias Klose on 2013-05-17

Import patches-unapplied version 1.0.3-6.1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 70777ed43830c7835a3f5741f3d7385fa86e4032

New changelog entries:
  * Non maintainer upload.
  * Fix to build with the libpython multiarch location.

70777ed... by Debichem Team <email address hidden> on 2013-05-12

Import patches-unapplied version 1.0.3-6 to debian/sid

Imported using git-ubuntu import.

Changelog parent: d3fbaa604bc64fff87a90b0279943a27c59be003

New changelog entries:
  [ Daniel Leidert ]
  * debian/control: Dropped DM-Upload-Allowed field.
    (Uploaders): Removed myself.
    (Standards-Version): Bumped to 3.9.4.
    (Depends): Added non-versioned dependencies to python-numpy, python-qt4
    and python-sip (see #679819).
  * debian/copyright: Added a hint about the text found in some files in the
    testfile directory (closes: #643921).
  * debian/rules: Removed code to generate versioned dependencies to
    python-numpy, python-qt4 and python-sip. Enable hardening.
  * debian/watch: Minor update to catch bzip2 compressed tarballs and ignore
    experimental releases.
  * debian/patches/use_python_include_dirs.diff: Added based on the patch by
    Ubuntu.
  [ Michael Banck ]
  * debian/upstream: Added reference.

d3fbaa6... by Daniel Leidert on 2012-06-06

Import patches-unapplied version 1.0.3-5 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 7b44804420faed87318350931a67ca801cb9782e

New changelog entries:
  * debian/control (Uploaders): Removed Jordan Mantha. Thanks for your work.
    (Build-Depends): Use libglew-dev.
    (Depends): Let libavogadro-dev depend on libglew-dev.

7b44804... by Daniel Leidert on 2012-06-04

Import patches-unapplied version 1.0.3-4 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 3d3bb0acc85f24bb1c1bab727c03b83757623073

New changelog entries:
  [ Michael Banck ]
  * Acknowledge NMU.
  * debian/patches/hurd_ftbfs.patch: New patch, fixing build on hurd-i386,
    thanks to Pino Toscano.
  [ Daniel Leidert ]
  * debian/control (Standards-Version): Bumped to 3.9.3.
    (Build-Depends): Added versioned dependency on python-numpy.
  * debian/rules (override_dh_python2): Added call to dh_numpy to fix lintian
    error.
  * debian/upstream: Added.

3d3bb0a... by "Steve M. Robbins" <email address hidden> on 2012-01-28

Import patches-unapplied version 1.0.3-3.1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: e27c73585e6e664463daa187273fd2cf1cfbef25

New changelog entries:
  * Non-Maintainer Upload.

  * patches/boost148.patch: New. Work around moc limitation. Closes:
    #653625.

e27c735... by Daniel Leidert on 2011-12-05

Import patches-unapplied version 1.0.3-3 to debian/sid

Imported using git-ubuntu import.

Changelog parent: bd6c2d467beb7fa362425468820039bd56b6e54e

New changelog entries:
  * debian/control (Build-Depends): Added libgl2ps-dev.
  * debian/patches/link_to_libgl2ps.patch: Added.
    - Link with -lgl2ps instead of compiling and linking the internal copy.
  * debian/patches/series: Adjusted.
  [ Michael Banck ]
  * debian/copyright: Explicitly state the 3-clause BSD license for the cmake
    module files.
  * debian/rules, debian/control: Convert to dh_python2, thanks to Barry
    Warsaw (Closes: #616742)
  * debian/patches/nwchem_input_ccsd.patch: New patch, fixes NWChem input
    extension input file generation for the CCSD method.
  [ Daniel Leidert ]
  * debian/avogadro.install: Install missing avopkg tool.
  * debian/compat: Increased dh compatibility level.
  * debian/control: Set X-Python-Version to 'current'. Use wrap-and-sort
    for *Depends* and Uploaders.
    (Build-Depends): Removed cdbs and patchutils. Increased required debhelper
    version.
    (Standards-Version): Bumped to 3.9.2.
    (Vcs-Browser): Point to real location.
    (Description): Fixed a typo reported by lintian.
    (Conflicts): Changed conflicts-with-version warning into Breaks.
  * debian/copyright: Minor update.
  * debian/pycompat: Dropped obsolete file.
  * debian/rules: Rewritten for debhelper 7.
  * debian/patches/nwchem_input_ccsd.patch: Added patch documentation.
  * debian/patches/series: Added.