ubuntu/+source/armel-cross-toolchain-base:ubuntu/natty

Last commit made on 2011-04-14
Get this branch:
git clone -b ubuntu/natty https://git.launchpad.net/ubuntu/+source/armel-cross-toolchain-base
Members of Ubuntu Server Dev import team can upload to this branch. Log in for directions.

Branch merges

Branch information

Name:
ubuntu/natty
Repository:
lp:ubuntu/+source/armel-cross-toolchain-base

Recent commits

82a661f... by Marcin Juszkiewicz on 2011-04-13

Import patches-unapplied version 1.62 to ubuntu/natty

Imported using git-ubuntu import.

Changelog parent: 9e37ca007359a6a7e19c1c613a04f1733b5aa754

New changelog entries:
  * Fixed build to work with co-installable (multiarched) linux-libc-dev
    headers. LP: #750585.
  * Added copyright, changelog files into eglibc and linux cross packages
    LP: #755329
  * Changed dependencies from -1 -> -1~ to make lintian more happy.
  * Debian changes:
    - switched to gcc 4.6 under Debian
    - moved definition of GCC versions to distro parts
    - gcc-4.6: disable libquadmath for stages - sent for review/merge
    - fixed minimal version of binutils to Debian one
    - moved to 2.6.38 kernel
    - refreshed linux and eglibc patches
    - updated copy of linux-2.6 packaging to 2.6.38-3

9e37ca0... by Steve Langasek on 2011-04-12

Import patches-unapplied version 1.61build1 to ubuntu/natty

Imported using git-ubuntu import.

Changelog parent: 7d2faca19740fcb8a5df49457b712a72f504e614

New changelog entries:
  * No-change rebuild against current gcc-4.5-source.

7d2faca... by Marcin Juszkiewicz on 2011-04-04

Import patches-unapplied version 1.61 to ubuntu/natty

Imported using git-ubuntu import.

Changelog parent: 059dd847f1412a825597b235192b181506a6d85f

New changelog entries:
  * "Say good bye to update-alternatives" release
  * switch to symlinks for default cross gcc version - LP: #676454
    - this will require newer gcc-defaults-armel-cross release
    - bumped gcc-4.5-source dependency to 4.5.2-8~
  * added 'init' task into debian/rules to make testing does patches apply
    easier
  * added section for libc6-dev-armel-cross because dpkg-cross 2.6.0+ keeps
    section instead of overwriting
  * dropped all patches which were merged into binutils and gcc-4.5
  * refreshed eglibc patches to apply - LP: #749180
  * added patch to eglibc to revert 2.13-0ubuntu10 change:
    "* Provide compatibility symlinks for .o files in /usr/lib. LP: #744908."
    this is needed for native builds but not for current cross
  * multiarch related changes
    - require dpkg-cross 2.6.3 to handle multiarch packages - LP: #736154 and
    LP: #739151
    - require dpkg 0.16.0 for working dpkg-shlibdeps
  * gcc-4.5 patches:
    - disabled build of plugin-dev
  * merged Steve Langasek changes (1.59)
    - Fix up build to work with current eglibc debian/rules.
  * changes related to pkgsym ddebs:
    - clean step removes a bit more - *.ddeb & debian/files
    - rules: use wildcard instead of listing files to mangle
    - create -dbgsym package and strip libraries - LP: #711523
    - files from gcc/debian/gcc-4.5-*-base dir are used as we do not have
      gcc-4.5-*-base package anymore
  * Merged Debian/Ubuntu/Linaro backport PPA rules
    - downgraded build-dependencies to Debian level (where possible)
    - separate patches for eglibc/Debian and eglibc/Ubuntu
    - fixed handling of eglibc and gcc documentation in Debian
    - backported some patches from eglibc/Ubuntu to eglibc/Debian
      - stages support
      - PATCHED_SOURCES support
    - backported some patches from linux/Ubuntu to linux/Debian
      - stages support
    - use separate 'series' files for patches/linux and patches/eglibc
    - dropped eglibc/lucid-force-gcc-4.4.patch as it is integrated in eglibc backport
    - switched to quilt for patching eglibc (.pc dir is removed after patching)
    - PPA build can be enabled by touching debian/ppa file
  * moved code which installs gcc into common function
  * dropped binutils patch which was needed for 2.21 (bumped to 2.21.0.20110216)
  * dropped code to regenerate debian/control - it was buggy and never finished
  * added new rule to generate debian/control file (handles Debian and Ubuntu for
    now)

059dd84... by Steve Langasek on 2011-02-27

Import patches-unapplied version 1.59 to ubuntu/natty

Imported using git-ubuntu import.

Changelog parent: 1688f6b7a60304e9886b2314043f2a1596cc3899

New changelog entries:
  * Fix up build to work with current eglibc debian/rules.

1688f6b... by Steve Langasek on 2011-02-26

Import patches-unapplied version 1.58+build1 to ubuntu/natty

Imported using git-ubuntu import.

Changelog parent: 4f99358574003dd588488de3f43b565fc59d1671

New changelog entries:
  * No-change rebuild against current gcc-4.5.

4f99358... by Marcin Juszkiewicz on 2011-01-31

Import patches-unapplied version 1.58 to ubuntu/natty

Imported using git-ubuntu import.

Changelog parent: 417e0fb5c1c06afabfd8ce001955e1f94cd7369a

New changelog entries:
  * update to use 2.6.38 kernel

417e0fb... by Marcin Juszkiewicz on 2011-01-26

Import patches-unapplied version 1.57 to ubuntu/natty

Imported using git-ubuntu import.

Changelog parent: 07ecda6acfc69545039e950b09c01654487e0f96

New changelog entries:
  * use PKG_IGNORE_CURRENTLY_BUILDING instead of NO_PKG_MANGLE to allow
    to generate .ddebs
  * control: remove alternatives dependencies - they are PPA backports only
  * control: re-added Vcs-* entries
  * merged changes from PPA backport:
    - depend on dpkg-cross >= 2.5.8 to get rid of double Provides: lines
      (lucid problem)
    - binutils: (re-)apply patch from Ubuntu to fix FTFBS (needed only for
      PPA, fails to apply in natty but we can ignore that)
    - rules: use gcc 4.4 to build eglibc (lucid lacks gcc-4.5)
    - rules: handle PPA versions of this package in DEB_VER_ACT variable
    - rules: bumped hardcoded component versions to recent one
  * Rebuild with gcc 4.5.2

07ecda6... by Marcin Juszkiewicz on 2010-12-14

Import patches-unapplied version 1.55 to ubuntu/natty

Imported using git-ubuntu import.

Changelog parent: 3292990ab87a9c71d801b386014de51ed76135cb

New changelog entries:
  * Updated build dependencies:
    - binutils 2.21 as gold-cross.patch got merged - LP: #686530
    - gcc-4.5 4.5.1-12 as armv7a optimizations patch got merged - LP: #684625

3292990... by Marcin Juszkiewicz on 2010-12-07

Import patches-unapplied version 1.54 to ubuntu/natty

Imported using git-ubuntu import.

Changelog parent: 4c25dc5cbb911b7b5321218d6c97dca3fad0b06f

New changelog entries:
   * merged support to build for PPA backport
     - PPA=true means build is for PPA
       - other version of patch for eglibc will be used
       - versioned binutils/eglibc/gcc-4.5 releases will be used
       - set exact versions of binutils/eglibc/gcc
       - linux-source is not covered by PPA variable because it has different
         name for each release
   * binutils: enable gold to match native build - LP: #686530
   * gcc: use armv7a optimizations - LP: #684625
   * gcc-4.5: do not use gold for stage1/2 builds
   * updated build dependencies:
     - g++-4.4 is required for binutils to build gold
     - binutils/eglibc/gcc-4.5 deps can be provided by PPA backports
     - lowered build dependencies to lucid level to make backports easier

4c25dc5... by Marcin Juszkiewicz on 2010-11-25

Import patches-unapplied version 1.53 to ubuntu/natty

Imported using git-ubuntu import.

Changelog parent: 42b99dbaecdcb2c3177f762255ad59ff8c9ab49c

New changelog entries:
  [ Michael Hope ]
  * fixed build for non-standard PF.
  [ Marcin Juszkiewicz ]
  * added binutils-arm-linux-gnueabi to build-conficts as we need binutils
    which know what sysroot is during build.
  * added fakeroot dependency
  * dropped g++-multilib dependency - closes LP: #637454
  * updated to natty versions
    - dropped binutils patch as it got merged in natty (bumped binutils
      dependency)
  * use gcc-4.4 to compile binutils and eglibc (update to gcc-4.5 is on
    todolist)
  * do not copy gcc patches anymore as this is symlink to debian/patches