ubuntu/+source/aptitude:ubuntu/natty-devel

Last commit made on 2010-11-18
Get this branch:
git clone -b ubuntu/natty-devel https://git.launchpad.net/ubuntu/+source/aptitude
Members of Ubuntu Server Dev import team can upload to this branch. Log in for directions.

Branch merges

Branch information

Name:
ubuntu/natty-devel
Repository:
lp:ubuntu/+source/aptitude

Recent commits

fbf22aa... by Michael Vogt on 2010-11-18

Import patches-unapplied version 0.6.3-3.2ubuntu1 to ubuntu/natty

Imported using git-ubuntu import.

Changelog parent: 5d6bc0b550b30cb1f97ddff2ee1d4038753ef2be

New changelog entries:
  * Merge from debian unstable. Remaining changes:
    - debian/05aptitude: never autoremove kernels
    - drop aptitude-doc to Suggests
    - 01_intltool_update.dpatch: run intltool-update against the source
      directory, so that irrelevant cosmetic .po file changes don't end up
      tangled in other patches.
    - 03_branding.dpatch: ubuntu branding
    - 04_changelog.dpatch: take changelogs from changelogs.ubuntu.com
    - 09_ubuntu_fortify_source.dpatch: Suppress a number of warnings (turned
      into errors by -Werror) triggered by Ubuntu's default of
      -D_FORTIFY_SOURCE=2.
    - 11_ubuntu_uses_sudo.dpatch: fix status line of 'Become root' menu entry
      to not refer to su.
    - 12_point_manpage_to_doc_package.dpatch: point Finnish manpage to the
      correct place for further info
  - debian/rules: build with --disable-werror
    - 14_html2text_preferred.dpatch: switch back to html2text in favor of
      elinks, since html2text is in main and elinks isn't.
  * dropped:
    - 13_screensize.dpatch: applied upstream
    - 15_ftbfs_new_apt.dpatch: applied upstream

5d6bc0b... by Tim Retout on 2010-10-12

Import patches-unapplied version 0.6.3-3.2 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 3e7627200a1f86cd8d3f32530ebb3db62b375f24

New changelog entries:
  * Non-maintainer upload.
  * 0007-preferences-dir.patch: Patch to support /etc/apt/preferences.d/
    directory. (Closes: #557580)
  * debian/rules: Fix clean rule. Patch by St├ęphane Glondu.
    (Closes: #594505)

3e76272... by Julien Cristau on 2010-08-26

Import patches-unapplied version 0.6.3-3.1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: f56e2fa4929831d3e984c2ba3903d86db4138cbc

New changelog entries:
  * Non-maintainer upload to fix FTBFS (closes: 594199).
  * Add patch by Michael Vogt to use sigc::mem_fun0 instead of sigc::mem_fun,
    fixing an error with apt 0.8.
  * Comment out our operator<< for pkgCache::DepIterator, libapt-pkg has one
    now and this caused conflicts. Build-Depend on new libapt-pkg-dev
    accordingly.
  * Don't build with -Werror to avoid more FTBFS.

f56e2fa... by Daniel Burrows on 2010-07-10

Import patches-unapplied version 0.6.3-3 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 03210f4881d2f397d47e08ece3a7299b18fc5b06

New changelog entries:
  * Apply patch from Nobuhiro Iwamatsu to fix compilation on sh, which
    has the same problem as s390. (Closes: #586861)
  * Apply patch from Michael Vogt to update Vcs links in debian/control.
  * Cherry-pick an Ubuntu patch that was merged upstream to fix the
    progress code on large terminals. (Closes: #586470)

03210f4... by Daniel Burrows on 2010-06-20

Import patches-unapplied version 0.6.3-2 to debian/sid

Imported using git-ubuntu import.

Changelog parent: f6107336e22067baef17f1941c4e48315bd0650f

New changelog entries:
  * Cherry-pick an upstream patch that fixes the Makefiles so that files
    named using $(wildcard) get installed. (Closes: #586508, #586511)

f610733... by Daniel Burrows on 2010-06-19

Import patches-unapplied version 0.6.3-1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 3840e712c66d9f5f90a26597eebc225cc11b86b3

New changelog entries:
  * New upstream release.
    - aptitude no longer requires log4cxx; dropped that build dependency.
      I hope this will solve some of the random crashes, particularly
      on exit, that have been reported, but since they're unreproducible
      it's hard to know.
    - aptitude should build correctly against either the current ept
      release or the upcoming release (in experimental).
      (Closes: #581009)
  * Applied upstream patches to make the tests build when GTK+ is
    disabled.
  * Weakened the build dependency on libboost-dev, since this upstream
    release no longer requires 1.42.
  * aptitude now requries gtest and google-mock for its test suite;
    added build dependencies.
  * Add the compile flag -fno-gcse on s390; current g++ miscompiles some
    of aptitude's parse code without this. (Closes: #580085)

3840e71... by Daniel Burrows on 2010-04-23

Import patches-unapplied version 0.6.2.1-2 to debian/sid

Imported using git-ubuntu import.

Changelog parent: d11281994a74cfd4d6eeee11bafdbfc5a87baf37

New changelog entries:
  * Tighten the dependency on libboost-dev to reflect the fact that
    aptitude needs at least 1.42.
    This caused actual build failures, so I'm surprised I didn't get bugs
    about it. I don't know if this will be a permanent state of affairs;
    a configure test could take care of the one thing that's a serious
    problem (a published API reversed the order of its arguments (!)).
  * New upstream release.
    - Fixes some backwards compatibility breakages in 0.6.2-2.
  * Weaken the Conflict against ia32-apt-get to (<< 22), on advice from
    Goswin von Bredrelow. Apparently some people still use this package,
    and the "feature" that broke aptitude is not present in recent
    versions.
  * Backport upstream patch to fix crashes in the resolver. (Closes: #578344)
  * Moved to source version 3.0 (quilt).
  * New upstream release.
    - Includes the patch for #567242 to not crash when the user sets
      a rejection by package name and version at the command-line,
      previously backported.
    - Includes the patch for #566205 to make sure that download progress
      bars are deleted when the download is finished.
    - Don't crash in "aptitude changelog" when the package given on
      the command-line doesn't have a valid version (Closes: #567318).
      Thanks to Dmitry Semyonov for the patch.

d112819... by Daniel Burrows on 2010-03-12

Import patches-unapplied version 0.6.1.5-3 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 9e4bf7c09555ce1b4751aa8caad0509fd8918090

New changelog entries:
  * Backport changes from head to increase how long the resolver is
    permitted to run. Fixes problems with some large upgrades where
    the resolver would time out and fail to find a solution. The new
    limit is much larger than any reasonable upgrade should require (it
    was increased by a factor of 100, from a value that was just barely
    too small).

9e4bf7c... by Daniel Burrows on 2010-01-30

Import patches-unapplied version 0.6.1.5-2 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 50b3fe62214208834a9542ec1e214506fab5f24f

New changelog entries:
  * Ignore failures in the Boost unit test everywhere; it's just too flaky
    (Closes: #566780).
  * Backport patch from head to make sure the changelog progress bar is
    safely destroyed after it downloads (Closes: #566205).
  * Backport patch from head to fix crashes when changing the settings of
    the command-line resolver (Closes: #567242).

50b3fe6... by Daniel Burrows on 2010-01-21

Import patches-unapplied version 0.6.1.5-1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 05565bc53678bbaa995e8122af54069b3385ebdb

New changelog entries:
  * New upstream release.
    - Make the resolver significantly less conservative, so major
      upgrades get computed better. (Closes: #565867)
    - Explicitly explain the implications of how the Linux command-line
      works in the aptitude manpage entry for "search" to reduce
      the confusion it causes. (Closes: #566003)