ubuntu/+source/aptitude:ubuntu/intrepid-devel

Last commit made on 2008-09-02
Get this branch:
git clone -b ubuntu/intrepid-devel https://git.launchpad.net/ubuntu/+source/aptitude
Members of Ubuntu Server Dev import team can upload to this branch. Log in for directions.

Branch merges

Branch information

Name:
ubuntu/intrepid-devel
Repository:
lp:ubuntu/+source/aptitude

Recent commits

36b471b... by Colin Watson on 2008-09-02

Import patches-unapplied version 0.4.11.3-1ubuntu3 to ubuntu/intrepid

Imported using git-ubuntu import.

Changelog parent: a8f2bf1d5c23b8731a4443847981db8bfc3cc834

New changelog entries:
  * 09_ubuntu_fortify_source.dpatch: Suppress a number of warnings (turned
    into errors by -Werror) triggered by Ubuntu's default of
    -D_FORTIFY_SOURCE=2.

a8f2bf1... by Colin Watson on 2008-09-01

Import patches-unapplied version 0.4.11.3-1ubuntu2 to ubuntu/intrepid

Imported using git-ubuntu import.

Changelog parent: 4c82fa180e8d6e4792c5841782d94d4db4cc6de0

New changelog entries:
  * Drop aptitude-doc to Suggests (LP: #252044).

4c82fa1... by Michael Vogt on 2008-06-05

Import patches-unapplied version 0.4.11.3-1ubuntu1 to ubuntu/intrepid

Imported using git-ubuntu import.

Changelog parent: 99206f75fd0a81b578452396c7b3a89328576941

New changelog entries:
  * Merge from debian unstable, remaining changes:
    - 03_branding.dpatch: ubuntu branding
    - 04_changelog.dpatch: take changelogs from changelogs.ubuntu.com
    - 07_hide_recommends_warning.dpatch: do not show a warning about
      missing recommends
    - 08_ubuntu_default_source.dpatch: do not clean lists directory
      on transient network failures
    - 11_gxx43.dpatch:build tests without -Werror
  * New upstream release.

    - "aptitude unhold" should work now. (Closes: #477165)

    - Fixed almost complete breakage of "aptitude changelog". (Closes: #481458)

    - Fixed retrieving the changelogs of bin-nmued packages from the curses
      interface. (Closes: #333468)

    - Always be at least as quiet as the user requested that we be.
      (Closes: #476749)

    - Remove a stray hyphen in the output of --help. (Closes: #476835)

    - Fix the manpage to talk about Recommends-Important instead of
      Install-Recommends. (Closes: #480533)

    - Translation updates:
      * Brazilian Portuguese (Closes: #481007)
      * Danish (Closes: #476732)
      * French
      * Galician (Closes: #476837)
      * German (Closes: #476344)
      * Japanese
      * Norwegian Bokmal (Closes: #480063)
      * Polish (Closes: #480062)
      * Simplified Chinese (Closes: #475740)
      * Vietnamese (Closes: #477295)

99206f7... by Michael Vogt on 2008-05-27

Import patches-unapplied version 0.4.11.2-1ubuntu1 to ubuntu/intrepid

Imported using git-ubuntu import.

Changelog parent: ede9f541a9e0161e8542d2e9468c7dba305616c8

New changelog entries:
  * Merge from debian unstable, remaining changes:
    - 03_branding.dpatch: ubuntu branding
    - 04_changelog.dpatch: take changelogs from changelogs.ubuntu.com
    - 07_hide_recommends_warning.dpatch: do not show a warning about
      missing recommends
    - 08_ubuntu_default_source.dpatch: do not clean lists directory
      on transient network failures
    - 11_gxx43.dpatch:build tests without -Werror
  * Updated:
    - 03_branding.dpatch
  * Disabled 07_hide_recommends warning because we do install
    recommends now by default too
  * New upstream release.

    - Fix XML errors in the manpage source. (Closes: #473722)

    - Don't crash if a package's Section field is empty. (Closes: #474115)

    - Rewrite the status information to avoid the need for choosing
      between the singular and plural forms of verbs. (Closes: #486186)

    - Added "why" and "why-not" to the output of "--help". (Closes: #454088)

    - Use a different technique to migrate "Recommends-Important" to
      "Install-Recommends" that doesn't overwrite the old option; instead
      the option "Aptitude::Ignore-Recommends-Important" is set to "true"
      when the setting is migrated; if this option is set, then
      Recommends-Important is ignored.

      This should be better for people who share configuration files
      between machines. (Closes: #473872)

    - Translation updates:
      * Galician (Closes: #474672)
      * Vietnamese (Closes: #473719)
  * New upstream release.
    - Don't crash if debtags has been purged (Closes: #472695).
    - Save interactive changes to string options. (Closes: #471315)
    - Don't print an error on startup if debtags is missing.
      (Closes: #472678)
    - Translation updates:
      + Simplified Chinese (Closes: #458162, #473363)
      + Vietnamese (Closes: #473229)
  * Upload to unstable.
    - Built against the new cwidget (Closes: #472369).
  * Removed the dependency on diff. As pointed out by lintian, diff is an
    Essential package and so depending on it is not just unnecessary, it's
    outright wrong.
  * Explicitly enable ept support.
  * Backport typo fixes to NEWS.
  * Backport fixes to test/test_tags.cc so it compiles with ept support.
  * Upload to experimental so as not to interfere with the installer.

  * New upstream release.

    - Handle conflicts/provides/replaces in the dependency resolver
      (Closes: #466374).

    - Implement a "build-dep" command to install build dependencies of one
      or more source packages. (Closes: #243317)

    - Implement support for multi-level sections, thanks to Paul Donahue
      for the patches.

    - Use libept to get debtags information. (Closes: #397652, #406201)

    - Fixed a case where aptitude would claim that packages could
      fulfill a versioned dependency through a Provides. (Closes: #464131)

    - Fix task handling in the case that different versions of a package
      have different task fields. (Closes: #459348)

    - Fix building with g++-4.3, assuming the build-deps support g++-4.3.
      (Closes: #452204, #452540)

    - Forcibly make the manual compile by allowing through a largely
      untranslated input. (Closes: #470054)

    - Migrate the setting for enabling installation of Recommends from
      Aptitude::Recommends-Important to Apt::Install-Recommends.
      (Closes: #458189, #448561)

    - Ensure that the resolver state is always synchronized with the
      state of the package cache, to eliminate some cases where it
      would break or produce wrong answers. (Closes: #421395, #432411)

    - Eliminate some crashes that occurred when removing packages at the
      command-line while version numbers were displayed (-V).
      (Closes: #459336, #461669)

    - If the package lists can't be read in "aptitude update", download
      new ones instead of crashing. (Closes: #468751)

    - Document some of the files that aptitude uses in a FILES section
      in the manpage (Closes: #470839)

    - Fix the use of quote in the French translation (Closes: #460808).

  * Build-Depend on libept-dev for ept support.

  * Add a reportbug script that includes the user's $TERM in the bug.

  * Fix a typo in the aptitude description. (Closes: #452710)

  * Add VCS fields to the control file.

  * Build-Depend on the newest version of cwidget so we link against
    libcwidget1 instead of libcwidget0.
  * New upstream release.
    - Add an option --allow-untrusted to override trust warning.
      (Closes: #452201, #452541)

    - Recommended packages are now hidden if quiet mode is enabled.
      (Closes: #452202)

    - Fixed a segfault that would happen after updating the package lists
      or doing an install run.
        (Closes: #454695, #454700, #455349, #453362, #455865)

    - If StepLimit is 0, abort dependency resolution cleanly instead of
      going into an infinite loop. (Closes: #451311)

    - When visual mode is entered from the command-line (e.g., via
      --visual-preview), return a failing exit code if the last
      install run the user performs fails.

    - Return a failing exit code from "aptitude update" if any
      download fails. (Closes: #233129)

    - Checkboxes and radio buttons in the preferences tree will
      now toggle on both Space and Enter. (Closes: #451765)

    - Command-line searches will now only print each result once.
      (Closes: #450798)

ede9f54... by Michael Vogt on 2008-04-03

Import patches-unapplied version 0.4.9-2ubuntu5 to ubuntu/hardy

Imported using git-ubuntu import.

Changelog parent: 30e4805040507b44e30d03eed0980587091646fc

New changelog entries:
  * 12_fix_crash_from_hg.dpatch:
    - cherry pick fix from hg to fix crash in the package view
  * 13_build_with_current_cwdiget_from_hg.dpatch:
    - make it build with latest cwidget

30e4805... by Matthias Klose on 2008-01-31

Import patches-unapplied version 0.4.9-2ubuntu4 to ubuntu/hardy

Imported using git-ubuntu import.

Changelog parent: e0eaad5e7b527c07b1191241953b2e336c23fb1d

New changelog entries:
  * Build with -Wno-deprecated to build with g++-4.3 as well.

e0eaad5... by Michael Vogt on 2007-12-13

Import patches-unapplied version 0.4.9-2ubuntu3 to ubuntu/hardy

Imported using git-ubuntu import.

Changelog parent: e40458197733eb3422cbf3e303f6982a30330590

New changelog entries:
  * rebuild against latest apt

e404581... by Michael Vogt on 2007-11-27

Import patches-unapplied version 0.4.9-2ubuntu2 to ubuntu/hardy

Imported using git-ubuntu import.

Changelog parent: 1c3f820c6f199f499558d9245c4875975a2d56fb

New changelog entries:
  * 03_branding.dpatch:
    - adjusted for current version
  * 04_changelog:

1c3f820... by Michael Vogt on 2007-11-23

Import patches-unapplied version 0.4.9-2ubuntu1 to ubuntu/hardy

Imported using git-ubuntu import.

Changelog parent: 059f5f04652d17317a116cd8204a5852c8e7bbce

New changelog entries:
  * Merge from debian unstable, remaining changes:
    - 01_allow_unauthenticated.dpatch: add --allow-unauthenticated
    - 03_branding.dpatch: ubuntu branding
    - 04_changelog.dpatch: take changelogs from changelogs.ubuntu.com
    - 07_hide_recommends_warning.dpatch: do not show a warning about
      missing recommends
    - 08_ubuntu_default_source.dpatch: do not clean lists directory
      on transient network failures
    - 11_gxx43.dpatch:build tests without -Werror
  (thanks to Ryan Kavanagh for the initial merge)
  * Add a -dbg package. (Closes: #448884)

  * Generate aptitude-doc-ja. (Closes: #390859)

  * Talk about software package management, not apt, in the Description.
  * New upstream release.
    - Add a matcher for obsolete/local packages (Closes: #397547).

    - Don't swap around the name, description, and long description
      of configuration options. (Closes: #449138)

    - Don't remove *.gmo in distclean, hopefully fixing problems
      with translations in the Debian packages.
      (Closes: #451584, #441696)
  * New upstream release.

    - Fix display corruption of the broken packages indicator.
      (Closes: #448753)

  * This release needs cwidget (0.5.5 or greater due to errors in previous
    versions' include files); add an appropriate build-dep.

059f5f0... by Michael Vogt on 2007-11-13

Import patches-unapplied version 0.4.7-1ubuntu1 to ubuntu/hardy

Imported using git-ubuntu import.

Changelog parent: e70910df8f2469cf415513c327f0f2e361736aa4

New changelog entries:
  * Merge from debian unstable, remaining changes:
    - 01_allow_unauthenticated.dpatch: add --allow-unauthenticated
    - 03_branding.dpatch: ubuntu branding
    - 04_changelog.dpatch: take changelogs from changelogs.ubuntu.com
    - 07_hide_recommends_warning.dpatch: do not show a warning about
      missing recommends
    - 08_ubuntu_default_source.dpatch: do not clean lists directory
      on transient network failures
    - 11_gxx43.dpatch:build tests without -Werror
  * dropped 10_dpkg_breaks.dpatch, taken upstream
  * New upstream release.
    - Replaced the options "dialogs" with a list-based display that
      handles long string options more sanely. As part of this, did work
      on string prompts; when the text being edited gets too long, the
      prompt will now expand vertically and wrap around.
      (Closes: #197976, #331200, #424708)

    - The online help is now a top-level view, so some of the problems
      with it should go away. (Closes: #434349)

    - Support for the "Breaks" field and for trigger states is now
      included. Thanks to Michael Vogt and Ian Jackson for the patches
      and for prodding me to apply them. (Closes: #438543)

    - Display styles for downgraded packages are now available:
      "PkgDowngraded" and "PkgDowngradedHighlighted". (Closes: #434442)

  * Acknowledge NMU (Closes: #441696).

  * Add support for noopt builds (Closes: #433646).

  * Build against the new apt (Closes: #447960).
  * Non-maintainer upload.
  * Removed “*.gmo” removal from the “distclean” target in po/Makefile.in.in
    to fix package content change on double-build (Closes: #441696).
  * Moved the menu entry from the “Apps/System” section to the
    “Applications/System/Administration” one.
  * No longer ignore “make distclean” errors, per lintian.