ubuntu/+source/aptitude:applied/ubuntu/breezy

Last commit made on 2005-12-21
Get this branch:
git clone -b applied/ubuntu/breezy https://git.launchpad.net/ubuntu/+source/aptitude
Members of Ubuntu Server Dev import team can upload to this branch. Log in for directions.

Branch merges

Branch information

Name:
applied/ubuntu/breezy
Repository:
lp:ubuntu/+source/aptitude

Recent commits

d493758... by Michael Vogt on 2005-09-20

Import patches-applied version 0.2.15.9-3ubuntu6 to applied/ubuntu/breezy

Imported using git-ubuntu import.

Changelog parent: abb12733c5ab18d76523757f98f2611700f1972f
Unapplied parent: b325c6ee13de3492fa6a9d14c2fc89f582e79ebe

New changelog entries:
  * src/cmdline/cmdline_changelog.cc:
    - make aptitude changelog work with ubuntu (ubuntu #15867)
  * src/generic/aptcache.cc, src/cmdline/cmdline_do_action.cc:
    - dist-upgrade ignores sticky-selections (other than "Install")
      now. this fixes a problem with held-back packages on dist-upgrade
      (ubuntu #15871)
  * src/generic/acqprogress.cc:
    - fail (and not loop forever) if nothing can be read from stdin
      on MediaChange (ubuntu: #13713)
  * A package is authenticated if one authenticated source (VerFile)
    for the version is available.
    libapt (pkgAcqArchive::QueueNext()) will not queue a non-authenticated
    source in this case. Aptitude checks if all sources for the version are
    authenticated, this breaks installs in certain cases where the network
    is not available but a authenticated package is available on the cd
    (ubuntu #13496)
  * rebuild against the latest apt soname change
  * added a one-line patch to support progress-reporting
    from aptitude too
  * rebuild because of the libsigc++-1.2 soname change
  * Resynchronise with Debian.
  * Build against the UNANNOUNCED apt 0.6 upload.
    (Closes: #316072)
  * Change Build-Depends to force buildds to build against the new apt.
  * updated m4/gettext.m4 from the latest gettext package to
    fix a FTBFS on amd64/ia64 with g++-4.0
  * rebuild for g++-4.0, fixed small g++-4.0 compile problems
  * Rebuild for new C++ ABI
  * Resynchronise with Debian.
  * merged conflicts in:
    - debian/control
    - src/ui.cc
  * removed the bits that where taken upstream
    (but renamed etc)
  * Merge from upstream to svn HEAD (r2931):
    - Don't use http:// URLs to retrieve the docbook DTDs when
      they're on the same filesystem! Should fix autobuilder
      problems.
    - Translation updates, including:
      + Czech (Closes: #302107)
      + Dutch (Closes: #301809)
      + Greek (Closes: #302851)
      + Portuguese (Closes: #301830)
      + Tagalog (Closes: #302085)
  * Add docbook-xml to Build-Depends.
  * New upstream release
    - Translation updates:
      + Dutch (Closes: #288815)
      + French (Closes: #274953), including a merge of the new user's manual
      + German (Closes: #283546, #293127)
      + Hebrew (Closes: #275266)
      + Lithuanian (Closes: #280049)
      + Polish (Closes: #265481)
      + Portuguese, Brazilian (Closes: #275220)
      + Romanian (Closes: #281531)
      + Slovak (Closes: #279559)
  * Bumped Standards-Version to 3.6.1.0.
  * Fix FTBFS with gcc-3.4 (closes: #263267).

b325c6e... by Michael Vogt on 2005-09-20

Import patches-unapplied version 0.2.15.9-3ubuntu6 to ubuntu/breezy

Imported using git-ubuntu import.

Changelog parent: b4ab4fd82751c44981e02d9916726dbb49f9ad43

New changelog entries:
  * src/cmdline/cmdline_changelog.cc:
    - make aptitude changelog work with ubuntu (ubuntu #15867)
  * src/generic/aptcache.cc, src/cmdline/cmdline_do_action.cc:
    - dist-upgrade ignores sticky-selections (other than "Install")
      now. this fixes a problem with held-back packages on dist-upgrade
      (ubuntu #15871)
  * src/generic/acqprogress.cc:
    - fail (and not loop forever) if nothing can be read from stdin
      on MediaChange (ubuntu: #13713)
  * A package is authenticated if one authenticated source (VerFile)
    for the version is available.
    libapt (pkgAcqArchive::QueueNext()) will not queue a non-authenticated
    source in this case. Aptitude checks if all sources for the version are
    authenticated, this breaks installs in certain cases where the network
    is not available but a authenticated package is available on the cd
    (ubuntu #13496)
  * rebuild against the latest apt soname change
  * added a one-line patch to support progress-reporting
    from aptitude too
  * rebuild because of the libsigc++-1.2 soname change
  * Resynchronise with Debian.
  * Build against the UNANNOUNCED apt 0.6 upload.
    (Closes: #316072)
  * Change Build-Depends to force buildds to build against the new apt.
  * updated m4/gettext.m4 from the latest gettext package to
    fix a FTBFS on amd64/ia64 with g++-4.0
  * rebuild for g++-4.0, fixed small g++-4.0 compile problems
  * Rebuild for new C++ ABI
  * Resynchronise with Debian.
  * merged conflicts in:
    - debian/control
    - src/ui.cc
  * removed the bits that where taken upstream
    (but renamed etc)
  * Merge from upstream to svn HEAD (r2931):
    - Don't use http:// URLs to retrieve the docbook DTDs when
      they're on the same filesystem! Should fix autobuilder
      problems.
    - Translation updates, including:
      + Czech (Closes: #302107)
      + Dutch (Closes: #301809)
      + Greek (Closes: #302851)
      + Portuguese (Closes: #301830)
      + Tagalog (Closes: #302085)
  * Add docbook-xml to Build-Depends.
  * New upstream release
    - Translation updates:
      + Dutch (Closes: #288815)
      + French (Closes: #274953), including a merge of the new user's manual
      + German (Closes: #283546, #293127)
      + Hebrew (Closes: #275266)
      + Lithuanian (Closes: #280049)
      + Polish (Closes: #265481)
      + Portuguese, Brazilian (Closes: #275220)
      + Romanian (Closes: #281531)
      + Slovak (Closes: #279559)
  * Bumped Standards-Version to 3.6.1.0.
  * Fix FTBFS with gcc-3.4 (closes: #263267).

abb1273... by Michael Vogt on 2005-03-18

Import patches-applied version 0.2.15.8-1ubuntu12 to applied/ubuntu/hoary

Imported using git-ubuntu import.

Changelog parent: e26b32685a3413bac19fe634273b756647572d10
Unapplied parent: b4ab4fd82751c44981e02d9916726dbb49f9ad43

New changelog entries:
  * show the:
    "The following packages are RECOMMENDED but will NOT be installed:"
    warning only when verbose is >0 (not by default)

  * get the changelogs from "changelogs.ubuntu.com" (#6540)
  * prompt for correct keys in frensh (#6240)
  * fixed the "don't auto-remove kernels" pattern in aptitude (#6539)
  * added "--allow-unauthenticated" (aptitude::AllowUnauthenticated) (#6493)
  * a fix in the "apt_check_auth()" code
  * rebuild against apt-0.6.30
  * build against apt-0.6.30
  * don't automatically remove packages that have "linux-image" in
    it's name (aptitude::Delete-Unused-Pattern="!linux-image")

  * bugfix for the the "warn on not authenticated packages"
  * warn about not authenticated packages
  * rebuild against the latest apt-0.6
  * don't write files to users home-dir (closes: #3975)
  * changelog re-enanbled (points to people.ubuntulinux.org/~mvo/ now)
  * Revive the lost su->sudo changes of version 0.2.14.1-2ubuntu2 and adapted
    them to work with the current version (Warty bug #1589).
  * Resynchronise with Debian.
  * New upstream release
    - RMs: this release includes a patch to work around UTF-8 problems
      in an ugly way. The debian-installer team has requested it for sarge.
    - Only show packages that really are suggested in "Suggested Packages".
      (Closes: #270667)
    - Apply an old patch from the BTS, mostly (the 'l' problem was
      handled by using 'L' as the keybinding). (Closes: #179533)
    - Translation updates:
      + French (Closes: #272824)
      + Italian (Closes: #265243)
      + Japanese (Closes: #272454)
  * New upstream release.
    - Documentation fixes (Closes: #269102, #269100)
    - Translation updates:
      + Brazilian (Closes: #271411)
      + Catalan (Closes: #270917)
      + Finnish (Closes: #263313)
      + French (Closes: #270713)
      + Greek (Closes: #265006)
      + Italian (Closes: #268263)
      + Japanese (Closes: #264867)
      + Norwegian (Closes: #269976)
      + Russian (Closes: #266294)
      + Spanish (Closes: #269311)
  * New upstream release. Give up on getting into testing the usual way.
    - Un-reverse the display of the size change of individual versions.

    - Install localized manpages in 'make install'.

    - Translation updates:
      + Czech (Closes: #262524)
      + Danish (Closes: #262129)
      + Dutch (Closes: #262000)
      + Finnish (Closes: #263313)
      + German (Closes: #262534)
      + Italian (Closes: #261819)
      + Portuguese (Closes: #261502)
  * This is probably useless due to the gcc-3.4 transition, but
    try to give the package a snowball's chance of getting into
    testing.
  * New upstream release, closing the following Debian bugs:
    - aptitude can now log to multiple destinations (specified
      as a configuration group); Closes: #259714.
    - A format code to display priorities (as set in apt_preferences)
      of package versions is now available: %i. May close #240423.
    - An option (Allow-Null-Upgrade) is available to disable one of
      the sanity-checks performed before an install run. Closes: #260590.
    - Internal pagers scroll by the correct amount. Closes: #260713.
    - The display limit can be reset by entering an empty string.
      Closes: #260244.
    - Don't use nonportable pthreads symbols. Closes: #260259.
    - Translation updates:
      + Brazilian (Closes: #260953)
      + Catalan (Closes: #261095)
      + Czech (Closes: #259966)
      + Dutch (Closes: #260632)
      + Italian (Closes: #261017)
      + Greek (Closes: #261029)
      + Portuguese (Closes: #261425)
  * New upstream release, closing the following Debian bugs:
    - aptitude now treats Suggests-Important as a synonym for
      Keep-Suggests, which should smooth out the transition a
      bit for people who had it turned on. (Closes: #259387)
    - The 'download' action at the command-line now accepts a
      version or archive specification. (Closes: #160145)
    - A menu command and a keyboard command are now available
      to find the next broken package. (Closes: #162474)
  * New upstream release, closing the following Debian bugs:
    - Fix the behavior of menubar hiding (Closes: #258688).
    - Suppress harmless self-conflicts when describing problems
      with a package (Closes: #258533).
    - The default keys bound to Yes and No are translatable.
      (Closes: #258409)
    - Split the manpage into a separate file. (Closes: #259089)
    - Suppress some mostly useless messages unless the user asks
      us to be verbose. (Closes: #258913)
    - Translation updates:
      + Brazilian (Closes: #258667), Greek (Closes: #258805),
        Spanish (Closes: #258243)
  * Split the (large) HTML documentation into separate packages.
  * New upstream release, closing the following Debian bugs:
    - No longer stores unchanged options in the user configuration file.
      (Closes: #175409)
    - s/forbid-upgrade/forbid-version/g (Closes: #257901)
    - Translation updates: Finnish (Closes: #257902); Italian (Closes: #257710)
  * New upstream release.
    - Incorporates the fix from -2.
    - Includes the screenshots that were missing in the previous release.
  * Avoid dereferencing apt_cache_file in a codepath that is sometimes
    invoked while it is NULL. (Closes: #257420)
  * New upstream release, closing the following Debian bugs:
    - Hopefully this version compiles on ia64. (Closes: #243932)

    - aptitude no longer displays a warning about removing Essential
      packages if the removal is cancelled. (Closes: #254422)
    - All traces of Suggests-Important were removed from the program.
      The program now has enough features that there is no longer any
      good reason to use this option; its main use was to find
      suggested-but-not-installed packages, and there are better
      ways of doing that now.
      (Closes: #245410)
    - The non-hierarchical tree mode is broken and shows no signs of
      being fixed; until it is fixed, aptitude will not use it.
      This means the categorical browser actually works again.
      (Closes: #120978, #144079, #144083, #151437, #242397)

    - ORed dependencies are shown correctly in 'aptitude show'.
      (Closes: #254740)
    - A --visual-preview command-line option is now available.
      (Closes: #253335)
    - Translated task descriptions will be displayed. (Closes: #203725)

    - Removed trailing periods from all menu descriptions.
      (Closes: #244676)

    - Applied a manpage patch from Sebastian Kapfer; unfortunately,
      the old manpage has been superseded by a (pretty much identical)
      new manpage generated from DocBook :-/. (Closes: #242304)
    - Fixed the display of ORed dependencies when describing reasons
      for a package's state. (Closes: #242663)

    - Improved the calculation of reasons for a package's state in the
      presence of virtual packages. (Closes: #244817)

    - Fixed -R and -r. (Closes: #243289)
    - Translations:

      - Basque updates (Closes: #244858)

      - Brazilian updates (Closes: #242332)
      - Catalan updates (Closes: #248764)
      - Czech updates (Closes: #243728, #256326)
      - Danish updates (Closes: #244539)
      - Dutch updates (Closes: #249405)
      - German updates (Closes: #233917, #255396)
      - Italian updates (Closes: #244679)
      - Japanese updates (Closes: #250023)
      - Lithuanian updates (Closes: #242815)
      - Norwegian Bokmal translation added (Closes: #250500, #252507)
      - Polish updates (Closes: #248365)
      - Portugese updates (Closes: #242309, #242372, #244850, #245699)
      - Russian added (Closes: #250498)
      - Traditional Chinese translation added (Closes: #244359)
  * Added build-depends on xsltproc, docbook-xsl, and html2text for
    the shiny new DocBook documentation.

  * Quote some more menu strings to make lintian happy.

b4ab4fd... by Michael Vogt on 2005-03-18

Import patches-unapplied version 0.2.15.8-1ubuntu12 to ubuntu/hoary

Imported using git-ubuntu import.

Changelog parent: 6f3f2f357c98bc5d86f754b3b250f76c4c9ed6ae

New changelog entries:
  * show the:
    "The following packages are RECOMMENDED but will NOT be installed:"
    warning only when verbose is >0 (not by default)

  * get the changelogs from "changelogs.ubuntu.com" (#6540)
  * prompt for correct keys in frensh (#6240)
  * fixed the "don't auto-remove kernels" pattern in aptitude (#6539)
  * added "--allow-unauthenticated" (aptitude::AllowUnauthenticated) (#6493)
  * a fix in the "apt_check_auth()" code
  * rebuild against apt-0.6.30
  * build against apt-0.6.30
  * don't automatically remove packages that have "linux-image" in
    it's name (aptitude::Delete-Unused-Pattern="!linux-image")

  * bugfix for the the "warn on not authenticated packages"
  * warn about not authenticated packages
  * rebuild against the latest apt-0.6
  * don't write files to users home-dir (closes: #3975)
  * changelog re-enanbled (points to people.ubuntulinux.org/~mvo/ now)
  * Revive the lost su->sudo changes of version 0.2.14.1-2ubuntu2 and adapted
    them to work with the current version (Warty bug #1589).
  * Resynchronise with Debian.
  * New upstream release
    - RMs: this release includes a patch to work around UTF-8 problems
      in an ugly way. The debian-installer team has requested it for sarge.
    - Only show packages that really are suggested in "Suggested Packages".
      (Closes: #270667)
    - Apply an old patch from the BTS, mostly (the 'l' problem was
      handled by using 'L' as the keybinding). (Closes: #179533)
    - Translation updates:
      + French (Closes: #272824)
      + Italian (Closes: #265243)
      + Japanese (Closes: #272454)
  * New upstream release.
    - Documentation fixes (Closes: #269102, #269100)
    - Translation updates:
      + Brazilian (Closes: #271411)
      + Catalan (Closes: #270917)
      + Finnish (Closes: #263313)
      + French (Closes: #270713)
      + Greek (Closes: #265006)
      + Italian (Closes: #268263)
      + Japanese (Closes: #264867)
      + Norwegian (Closes: #269976)
      + Russian (Closes: #266294)
      + Spanish (Closes: #269311)
  * New upstream release. Give up on getting into testing the usual way.
    - Un-reverse the display of the size change of individual versions.

    - Install localized manpages in 'make install'.

    - Translation updates:
      + Czech (Closes: #262524)
      + Danish (Closes: #262129)
      + Dutch (Closes: #262000)
      + Finnish (Closes: #263313)
      + German (Closes: #262534)
      + Italian (Closes: #261819)
      + Portuguese (Closes: #261502)
  * This is probably useless due to the gcc-3.4 transition, but
    try to give the package a snowball's chance of getting into
    testing.
  * New upstream release, closing the following Debian bugs:
    - aptitude can now log to multiple destinations (specified
      as a configuration group); Closes: #259714.
    - A format code to display priorities (as set in apt_preferences)
      of package versions is now available: %i. May close #240423.
    - An option (Allow-Null-Upgrade) is available to disable one of
      the sanity-checks performed before an install run. Closes: #260590.
    - Internal pagers scroll by the correct amount. Closes: #260713.
    - The display limit can be reset by entering an empty string.
      Closes: #260244.
    - Don't use nonportable pthreads symbols. Closes: #260259.
    - Translation updates:
      + Brazilian (Closes: #260953)
      + Catalan (Closes: #261095)
      + Czech (Closes: #259966)
      + Dutch (Closes: #260632)
      + Italian (Closes: #261017)
      + Greek (Closes: #261029)
      + Portuguese (Closes: #261425)
  * New upstream release, closing the following Debian bugs:
    - aptitude now treats Suggests-Important as a synonym for
      Keep-Suggests, which should smooth out the transition a
      bit for people who had it turned on. (Closes: #259387)
    - The 'download' action at the command-line now accepts a
      version or archive specification. (Closes: #160145)
    - A menu command and a keyboard command are now available
      to find the next broken package. (Closes: #162474)
  * New upstream release, closing the following Debian bugs:
    - Fix the behavior of menubar hiding (Closes: #258688).
    - Suppress harmless self-conflicts when describing problems
      with a package (Closes: #258533).
    - The default keys bound to Yes and No are translatable.
      (Closes: #258409)
    - Split the manpage into a separate file. (Closes: #259089)
    - Suppress some mostly useless messages unless the user asks
      us to be verbose. (Closes: #258913)
    - Translation updates:
      + Brazilian (Closes: #258667), Greek (Closes: #258805),
        Spanish (Closes: #258243)
  * Split the (large) HTML documentation into separate packages.
  * New upstream release, closing the following Debian bugs:
    - No longer stores unchanged options in the user configuration file.
      (Closes: #175409)
    - s/forbid-upgrade/forbid-version/g (Closes: #257901)
    - Translation updates: Finnish (Closes: #257902); Italian (Closes: #257710)
  * New upstream release.
    - Incorporates the fix from -2.
    - Includes the screenshots that were missing in the previous release.
  * Avoid dereferencing apt_cache_file in a codepath that is sometimes
    invoked while it is NULL. (Closes: #257420)
  * New upstream release, closing the following Debian bugs:
    - Hopefully this version compiles on ia64. (Closes: #243932)

    - aptitude no longer displays a warning about removing Essential
      packages if the removal is cancelled. (Closes: #254422)
    - All traces of Suggests-Important were removed from the program.
      The program now has enough features that there is no longer any
      good reason to use this option; its main use was to find
      suggested-but-not-installed packages, and there are better
      ways of doing that now.
      (Closes: #245410)
    - The non-hierarchical tree mode is broken and shows no signs of
      being fixed; until it is fixed, aptitude will not use it.
      This means the categorical browser actually works again.
      (Closes: #120978, #144079, #144083, #151437, #242397)

    - ORed dependencies are shown correctly in 'aptitude show'.
      (Closes: #254740)
    - A --visual-preview command-line option is now available.
      (Closes: #253335)
    - Translated task descriptions will be displayed. (Closes: #203725)

    - Removed trailing periods from all menu descriptions.
      (Closes: #244676)

    - Applied a manpage patch from Sebastian Kapfer; unfortunately,
      the old manpage has been superseded by a (pretty much identical)
      new manpage generated from DocBook :-/. (Closes: #242304)
    - Fixed the display of ORed dependencies when describing reasons
      for a package's state. (Closes: #242663)

    - Improved the calculation of reasons for a package's state in the
      presence of virtual packages. (Closes: #244817)

    - Fixed -R and -r. (Closes: #243289)
    - Translations:

      - Basque updates (Closes: #244858)

      - Brazilian updates (Closes: #242332)
      - Catalan updates (Closes: #248764)
      - Czech updates (Closes: #243728, #256326)
      - Danish updates (Closes: #244539)
      - Dutch updates (Closes: #249405)
      - German updates (Closes: #233917, #255396)
      - Italian updates (Closes: #244679)
      - Japanese updates (Closes: #250023)
      - Lithuanian updates (Closes: #242815)
      - Norwegian Bokmal translation added (Closes: #250500, #252507)
      - Polish updates (Closes: #248365)
      - Portugese updates (Closes: #242309, #242372, #244850, #245699)
      - Russian added (Closes: #250498)
      - Traditional Chinese translation added (Closes: #244359)
  * Added build-depends on xsltproc, docbook-xsl, and html2text for
    the shiny new DocBook documentation.

  * Quote some more menu strings to make lintian happy.

e26b326... by Martin Pitt on 2004-10-06

Import patches-applied version 0.2.14.1-2ubuntu3 to applied/ubuntu/warty

Imported using git-ubuntu import.

Unapplied parent: 6f3f2f357c98bc5d86f754b3b250f76c4c9ed6ae

6f3f2f3... by Martin Pitt on 2004-10-06

Import patches-unapplied version 0.2.14.1-2ubuntu3 to ubuntu/warty

Imported using git-ubuntu import.