ubuntu/+source/apache2:applied/ubuntu/utopic

Last commit made on 2014-07-25
Get this branch:
git clone -b applied/ubuntu/utopic https://git.launchpad.net/ubuntu/+source/apache2
Members of Ubuntu Server Dev import team can upload to this branch. Log in for directions.

Branch merges

Branch information

Name:
applied/ubuntu/utopic
Repository:
lp:ubuntu/+source/apache2

Recent commits

5bbfc0c... by Robie Basak on 2014-07-24

Import patches-applied version 2.4.10-1ubuntu1 to applied/ubuntu/utopic-proposed

Imported using git-ubuntu import.

Changelog parent: 1e010873c0ac08eea2fa956e286438bad47d54f9
Unapplied parent: 5a33395ff07782c1b4cc7cea3a81bff0c1eebb14

New changelog entries:
  * Merge from Debian unstable. Remaining changes:
    - debian/{control, apache2.install, apache2-utils.ufw.profile,
      apache2.dirs}: Add ufw profiles.
    - debian/apache2.py, debian/apache2-bin.install: Add apport hook.
    - d/control, d/config-dir/mods-available/ssl.conf, d/ask-for-passphrase,
      d/apache2.install: Plymouth aware passphrase dialog program
      ask-for-passphrase.
    - Add dep8 tests.
    - debian/rules: Fix cross-building by passing DEB_{HOST,BUILD}_GNU_TYPE to
      configure.
    - debian/patches/086_svn_cross_compiles: Backport several cross fixes from
      upstream
    - d/index.html: replace Debian with Ubuntu on default page.
    - d/p/split-logfile.patch: fix completely broken split-logfile command.

5a33395... by Robie Basak on 2014-07-24

fix completely broken split-logfile command

Gbp-Pq: split-logfile.patch.

490cbd2... by Robie Basak on 2014-07-24

Pull upstream fixes for autotools for cross-compiling

Gbp-Pq: 086_svn_cross_compiles.

892f3b9... by Robie Basak on 2014-07-24

add suexec-custom to the build system

Gbp-Pq: build_suexec-custom.patch.

5f410e1... by Robie Basak on 2014-07-24

Adapt apxs to Debian specific changes

Gbp-Pq: customize_apxs.patch.

f0b259f... by Robie Basak on 2014-07-24

Fix race condition with chdir

Gbp-Pq: suexec-CVE-2007-1742.patch.

475f212... by Robie Basak on 2014-07-24

Remove LD_LIBRARY_PATH from envvars-std

Gbp-Pq: no_LD_LIBRARY_PATH.patch.

2607e5b... by Robie Basak on 2014-07-24

Fix up FHS file locations for apache2 droppings.

Gbp-Pq: fhs_compliance.patch.

5b08bf0... by Robie Basak on 2014-07-24

Import patches-unapplied version 2.4.10-1ubuntu1 to ubuntu/utopic-proposed

Imported using git-ubuntu import.

Changelog parent: cb4b1f159d987435b5ce0707fb56052f7dfa0cec

New changelog entries:
  * Merge from Debian unstable. Remaining changes:
    - debian/{control, apache2.install, apache2-utils.ufw.profile,
      apache2.dirs}: Add ufw profiles.
    - debian/apache2.py, debian/apache2-bin.install: Add apport hook.
    - d/control, d/config-dir/mods-available/ssl.conf, d/ask-for-passphrase,
      d/apache2.install: Plymouth aware passphrase dialog program
      ask-for-passphrase.
    - Add dep8 tests.
    - debian/rules: Fix cross-building by passing DEB_{HOST,BUILD}_GNU_TYPE to
      configure.
    - debian/patches/086_svn_cross_compiles: Backport several cross fixes from
      upstream
    - d/index.html: replace Debian with Ubuntu on default page.
    - d/p/split-logfile.patch: fix completely broken split-logfile command.

1e01087... by Stefan Fritsch on 2014-07-22

Import patches-applied version 2.4.10-1 to applied/debian/sid

Imported using git-ubuntu import.

Changelog parent: 8c996be1f757bebd68c3ffda85237f82b7d52205
Unapplied parent: 11e7b07d21b25c60a52002c121d5233d71d264f3

New changelog entries:
  [ Arno Töll ]
  * New upstream version
    + Refresh debian/patches/fhs_compliance.patch
    + Security Fixes:
      - CVE-2014-0117 mod_proxy: Fix DoS that could cause a crash
      - CVE-2014-0226 Fix a race condition resulting in a heap overflow in
        scoreboard handling
      - CVE-2014-0118 mod_deflate: The DEFLATE input filter now limits the
        length and compression ratio of inflated request to mitigate a
        possible DoS
      - CVE-2014-0231 mod_cgid: Fix a denial of service against CGI scripts
    + Fixes SNI with certificate defined in global scope. (Closes: #751361)
  * Warn users if they try to disable modules that we consider essential for
    operation of the Apache web server (Closes: #709461)
  * Drop libcap from our build-dependencies. That was needed for itk which we
    gave source out to it's own package again.
  * Provide apache2.2-common package to avoid upgrading problems for people
    using --purge (apt) or --purge-unused (aptitude) even though that's
    clearly discouraged. This caused disappearing of conffiles because we move
    them from apache2.2-common to apache2 during the upgrade. Ugh. This was
    not a bug in our packaging, but an unfortunately people blame us
    nonetheless even though it's not all our fault. This alternative helps
    those people, but at the same time means that incompatible modules aren't
    force-removed by dpkg during the upgrade. Hopefully we catch all of them
    with the Breaks relation coming along (Closes: #716880, #752922, #711925)