ubuntu/+source/apache2:applied/ubuntu/disco

Last commit made on 2019-02-05
Get this branch:
git clone -b applied/ubuntu/disco https://git.launchpad.net/ubuntu/+source/apache2
Members of Ubuntu Server Dev import team can upload to this branch. Log in for directions.

Branch merges

Branch information

Name:
applied/ubuntu/disco
Repository:
lp:ubuntu/+source/apache2

Recent commits

d593a21... by Andreas Hasenack on 2019-02-03

Import patches-applied version 2.4.38-2ubuntu1 to applied/ubuntu/disco-proposed

Imported using git-ubuntu import.

Changelog parent: 51a0ddced04f55fe833211d6e9b0b1318b712b76
Unapplied parent: e0b88072a7ac12aa5746ca8cd69ba73c873b9708

New changelog entries:
  * Merge with Debian unstable. Remaining changes:
    - debian/{control, apache2.install, apache2-utils.ufw.profile,
      apache2.dirs}: Add ufw profiles.
    - debian/apache2.py, debian/apache2-bin.install: Add apport hook.
   - debian/patches/086_svn_cross_compiles: Backport several cross
     fixes from upstream
     [Removed configure chunk, not needed since configure.in is being
      patched.]
    - d/index.html, d/icons/ubuntu-logo.png, d/apache2.postrm: replace
      Debian with Ubuntu on default page.
      + d/source/include-binaries: add Ubuntu icon file
    - d/t/control, d/t/check-http2: add basic test for http2 support
  * Dropped:
    - d/control, d/rules, d/config-dir/mods-available/md.load: don't build
      libapache2-mod-md, as that makes apache2-bin pull in libcurl4 which
      cannot be coinstalled with libcurl3. That situation breaks the
      installation of libapache2-mod-shib2. See
      https://bugs.launchpad.net/ubuntu/+source/apache2/+bug/1770242/comments/1
      for details.
      [This has been resolved in Disco, where libxmltooling8 is built with
      openssl 1.1]
    - SECURITY UPDATE: denial of service in HTTP/2 via large SETTINGS frames
      + debian/patches/CVE-2018-11763.patch: rework connection IO event
        handling in modules/http2/h2_session.c, modules/http2/h2_session.h,
        modules/http2/h2_version.h.
        - CVE-2018-11763
        [Fixed in 2.4.35]

e0b8807... by Andreas Hasenack on 2019-02-03

Pull upstream fixes for autotools for cross-compiling

Gbp-Pq: 086_svn_cross_compiles.

94f8f12... by Andreas Hasenack on 2019-02-03

spelling errors

Gbp-Pq: spelling-errors.patch.

7986943... by Andreas Hasenack on 2019-02-03

Make builds reproducible

Gbp-Pq: reproducible_builds.diff.

51c325c... by Andreas Hasenack on 2019-02-03

add suexec-custom to the build system

Gbp-Pq: build_suexec-custom.patch.

66ec549... by Andreas Hasenack on 2019-02-03

Adapt apxs to Debian specific changes

Gbp-Pq: customize_apxs.patch.

2fc05d3... by Andreas Hasenack on 2019-02-03

Fix race condition with chdir

Gbp-Pq: suexec-CVE-2007-1742.patch.

71cd3e0... by Andreas Hasenack on 2019-02-03

Remove LD_LIBRARY_PATH from envvars-std

Gbp-Pq: no_LD_LIBRARY_PATH.patch.

f129b8d... by Andreas Hasenack on 2019-02-03

Fix up FHS file locations for apache2 droppings.

Gbp-Pq: fhs_compliance.patch.

065c91f... by Andreas Hasenack on 2019-02-03

Import patches-unapplied version 2.4.38-2ubuntu1 to ubuntu/disco-proposed

Imported using git-ubuntu import.

Changelog parent: 847b2dd6c945b42d4b49bbc8fbb24a7dd4fc4897

New changelog entries:
  * Merge with Debian unstable. Remaining changes:
    - debian/{control, apache2.install, apache2-utils.ufw.profile,
      apache2.dirs}: Add ufw profiles.
    - debian/apache2.py, debian/apache2-bin.install: Add apport hook.
   - debian/patches/086_svn_cross_compiles: Backport several cross
     fixes from upstream
     [Removed configure chunk, not needed since configure.in is being
      patched.]
    - d/index.html, d/icons/ubuntu-logo.png, d/apache2.postrm: replace
      Debian with Ubuntu on default page.
      + d/source/include-binaries: add Ubuntu icon file
    - d/t/control, d/t/check-http2: add basic test for http2 support
  * Dropped:
    - d/control, d/rules, d/config-dir/mods-available/md.load: don't build
      libapache2-mod-md, as that makes apache2-bin pull in libcurl4 which
      cannot be coinstalled with libcurl3. That situation breaks the
      installation of libapache2-mod-shib2. See
      https://bugs.launchpad.net/ubuntu/+source/apache2/+bug/1770242/comments/1
      for details.
      [This has been resolved in Disco, where libxmltooling8 is built with
      openssl 1.1]
    - SECURITY UPDATE: denial of service in HTTP/2 via large SETTINGS frames
      + debian/patches/CVE-2018-11763.patch: rework connection IO event
        handling in modules/http2/h2_session.c, modules/http2/h2_session.h,
        modules/http2/h2_version.h.
        - CVE-2018-11763
        [Fixed in 2.4.35]