ubuntu/+source/amarok:applied/debian/sid

Last commit made on 2019-08-16
Get this branch:
git clone -b applied/debian/sid https://git.launchpad.net/ubuntu/+source/amarok
Members of Ubuntu Server Dev import team can upload to this branch. Log in for directions.

Branch merges

Branch information

Name:
applied/debian/sid
Repository:
lp:ubuntu/+source/amarok

Recent commits

c61960a... by Tehnick on 2019-08-15

Import patches-applied version 2.9.0-2 to applied/debian/sid

Imported using git-ubuntu import.

Changelog parent: 79d3cfa00e821911a3df3368b845d78b55c8c94e
Unapplied parent: 4438b718eb2be4d90c923aa48bcd6c53d2d9583e

New changelog entries:
  [ Boris Pek ]
  * Team upload.
  * Add patch use-secrure-URLs.
  * d/rules: enable all hardening flags
  * Bump debhelper version to 12~ (was 11~); update debian/compat.
  [ Louis-Philippe VĂ©ronneau ]
  * d/control: Update the VCS fields from Alioth to Salsa

4438b71... by Tehnick on 2019-08-15

Use more secure URL

Gbp-Pq: use-secrure-URLs.diff.

bc0b7e4... by Tehnick on 2019-08-15

Disable the mp3tunes service

Gbp-Pq: no-mp3tunes.diff.

7a5ee42... by Tehnick on 2019-08-15

valgrind_uninitialized_value

No DEP3 Subject or Description header found

Gbp-Pq: valgrind_uninitialized_value.

4853d6d... by Tehnick on 2019-08-15

Do not check for clamz at build-time

Gbp-Pq: debian_clamz_is_runtime_dependency.diff.

70b4e13... by Tehnick on 2019-08-15

Fix mysql_config call for Debian MySQL

Gbp-Pq: debian_find_mysql_fix.diff.

e1f4568... by Tehnick on 2019-08-15

[PATCH] Make Amarok use locally installed errsys.msg

Gbp-Pq: debian_mysqle_amarok_local_errmsg_feature.diff.

808cf52... by Tehnick on 2019-08-15

Import patches-unapplied version 2.9.0-2 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 8caf1bbf78f9ec4deed46a0e72ff7b9d1bdf63a1

New changelog entries:
  [ Boris Pek ]
  * Team upload.
  * Add patch use-secrure-URLs.
  * d/rules: enable all hardening flags
  * Bump debhelper version to 12~ (was 11~); update debian/compat.
  [ Louis-Philippe VĂ©ronneau ]
  * d/control: Update the VCS fields from Alioth to Salsa

79d3cfa... by Pino Toscano <email address hidden> on 2018-05-18

Import patches-applied version 2.9.0-1 to applied/debian/sid

Imported using git-ubuntu import.

Changelog parent: 875e475c31d5c63c16c5e5d9464db2120a62c2d5
Unapplied parent: 58708f529d5a2889d47958233e3ad6be16a33afe

New changelog entries:
  * Team upload.
  * New upstream release:
    - the Wikipedia applet works with the newer Wikipedia APIs
      (Closes: #851945)
  * Update the patches:
    - backport_dont_add_analyzer_when_not_supported.diff: drop, backported from
      upstream
    - backport_dont_crash_on_shuffle_keyb_shortcut.diff: drop, backported from
      upstream
    - backport_dont_allow_analyzer_with_vlc.diff: drop, backported from
      upstream
    - backport_gcc6.diff: drop, backported from upstream
    - backport_mpris2_desktopentry.diff: drop, backported from upstream
    - debian_disable_qtscriptbindings_check_fix.diff: drop, fixed upstream
    - debian_mysqle_amarok_local_errmsg_feature.diff: refresh/update
    - debian_mysqle_force_defaults_file.diff: disable for now, as it does not
      seem to be needed anymore
    - debian_clamz_is_runtime_dependency.diff: refresh
    - ffmpeg_2.9.patch: drop, fixed upstream
    - backport_fix_taglib_version_check.patch: drop, backported from upstream
  * Update install files.
  * Disable the gpodder.net support, as libmygpo-qt will switch soon to Qt5 in
    Debian: (Closes: #896941)
    - remove the libmygpo-qt-dev build dependency
    - update install files
  * Remove the primary libgpod-nogtk-dev build dependency, leaving the
    alternative libgpod-dev. (Closes: #877295)
  * Remove trailing whitespaces in changelog.
  * Simplify watch file, and switch it to https.
  * Update lintian overrides.
  * Remove from debian/tmp all the stuff we do not want, so it is easier to
    spot uninstalled stuff
    - remove debian/not-installed, no more needed now
  * Replace the libmariadbd-dev build dependency with default-libmysqld-dev,
    so we do not rely anymore on a specific MySQL implementation.
  * Disable the mp3tunes service: moc raises a build error related to GLib
    headers, but it does not provide a meaningful error message to diagnose
    the error; patch no-mp3tunes.diff.
  * Bump Standards-Version to 4.1.4, no changes required.
  * Bump the debhelper compatibility to 11:
    - bump the debhelper build dependency to 11~
    - bump compat to 11
    - remove --parallel for dh, as now done by default
  * Pass --fail-missing to dh_missing, so no file is missed.
  * Stop passing -Wl,--no-relax as linker flag on alpha, as hopefully the
    problem should be solved after more than 5 years.
  * Switch Homepage to https.

8caf1bb... by Pino Toscano <email address hidden> on 2018-05-18

Import patches-unapplied version 2.9.0-1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 4612a905adf87ce2f157db78d737d2ff761a2755

New changelog entries:
  * Team upload.
  * New upstream release:
    - the Wikipedia applet works with the newer Wikipedia APIs
      (Closes: #851945)
  * Update the patches:
    - backport_dont_add_analyzer_when_not_supported.diff: drop, backported from
      upstream
    - backport_dont_crash_on_shuffle_keyb_shortcut.diff: drop, backported from
      upstream
    - backport_dont_allow_analyzer_with_vlc.diff: drop, backported from
      upstream
    - backport_gcc6.diff: drop, backported from upstream
    - backport_mpris2_desktopentry.diff: drop, backported from upstream
    - debian_disable_qtscriptbindings_check_fix.diff: drop, fixed upstream
    - debian_mysqle_amarok_local_errmsg_feature.diff: refresh/update
    - debian_mysqle_force_defaults_file.diff: disable for now, as it does not
      seem to be needed anymore
    - debian_clamz_is_runtime_dependency.diff: refresh
    - ffmpeg_2.9.patch: drop, fixed upstream
    - backport_fix_taglib_version_check.patch: drop, backported from upstream
  * Update install files.
  * Disable the gpodder.net support, as libmygpo-qt will switch soon to Qt5 in
    Debian: (Closes: #896941)
    - remove the libmygpo-qt-dev build dependency
    - update install files
  * Remove the primary libgpod-nogtk-dev build dependency, leaving the
    alternative libgpod-dev. (Closes: #877295)
  * Remove trailing whitespaces in changelog.
  * Simplify watch file, and switch it to https.
  * Update lintian overrides.
  * Remove from debian/tmp all the stuff we do not want, so it is easier to
    spot uninstalled stuff
    - remove debian/not-installed, no more needed now
  * Replace the libmariadbd-dev build dependency with default-libmysqld-dev,
    so we do not rely anymore on a specific MySQL implementation.
  * Disable the mp3tunes service: moc raises a build error related to GLib
    headers, but it does not provide a meaningful error message to diagnose
    the error; patch no-mp3tunes.diff.
  * Bump Standards-Version to 4.1.4, no changes required.
  * Bump the debhelper compatibility to 11:
    - bump the debhelper build dependency to 11~
    - bump compat to 11
    - remove --parallel for dh, as now done by default
  * Pass --fail-missing to dh_missing, so no file is missed.
  * Stop passing -Wl,--no-relax as linker flag on alpha, as hopefully the
    problem should be solved after more than 5 years.
  * Switch Homepage to https.