Nux

nux:ubuntu/xenial

Last commit made on 2018-06-22
Get this branch:
git clone -b ubuntu/xenial https://git.launchpad.net/nux
Members of Unity Team can upload to this branch. Log in for directions.

Branch merges

Branch information

Name:
ubuntu/xenial
Repository:
lp:nux

Recent commits

49a5748... by CI Train Bot Account on 2018-06-22

Releasing 4.0.8+16.04.20180622.2-0ubuntu1

fcd2043... by Marco Trevisan (Treviño) on 2018-06-22

* debian/control: update Vcs
* debian/nux-tools.preinst:
  - Restore backup config files before installing nux-tools, so that they
    will be updaded with the fixed versions (LP: #1768610)

c62b694... by Marco Trevisan (Treviño) on 2018-06-19

debian/changelog: update with vcs change

76d2c0b... by Marco Trevisan (Treviño) on 2018-06-19

debian/nux-tools.preinst: restore backup config files

These might be moved by x11-common.

LP: #1768610

fdbf2cd... by Marco Trevisan (Treviño) on 2018-06-19

debian/control: update Vcs to use git

7a21eef... by CI Train Bot Account on 2018-06-13

Releasing 4.0.8+16.04.20180613.1-0ubuntu1

ab28882... by Marco Trevisan (Treviño) on 2018-06-13

Revert: "debian: don't consider the Xsession.d script as a config file anymore"

It seems something there's not full agreement on it, so to avoid further discussions
I'm reverting this back. However I strongly believe that given the current tools we have
this is the way to go, as debian doesn't provide other tools to get this done.
Nor X11 can move files outside of /etc.

c513e48... by Marco Trevisan (Treviño) on 2018-06-13

debian: don't consider the Xsession.d script as a config file anymore

This is just a script to be loaded, and not something the user is supposed to change,
so it should be removed on simple package removal.
To achieve this, as per maintainer-guide 5.3, using sym-links is the standard way.

85ee739... by Marco Trevisan (Treviño) on 2018-06-13

50_check_unity_support: only run when called from an unity session

The content of ubuntu:GNOME is checked inside a sub-shell
not to affect the value of IFS for all the scripts sourced by the X session.

If running in Unity we should call unity_support_test, not inside gnome
ubuntu X sessions.

XDG_CURRENT_DESKTOP values are currently the followings:
- unity before 17.10: Unity
- unity after 17.10: Unity:Unity7:ubuntu
- gnome session: GNOME
- ubuntu gnome session: ubuntu:GNOME

8ed3097... by Marco Trevisan (Treviño) on 2018-06-12

50_check_unity_support: only export LIBGL_ALWAYS_SOFTWARE=1 on command failed