lp:~ubuntu-dev/ubuntu/lucid/php5/lucid-201002110915

Created by James Westby on 2010-02-11 and last modified on 2010-02-11
Cannot lock LockDir(lp-mirrored:///~ubuntu-dev/ubuntu/lucid/php5/lucid-201002110915/.bzr/repositorylock): File exists: u'/srv/bazaar.launchpad.net/mirrors/00/04/bf/c7/.bzr/repository/lock': [Errno 17] File exists: '/srv/bazaar.launchpad.net/mirrors/00/04/bf/c7/.bzr/repository/lock'
Get this branch:
bzr branch lp:~ubuntu-dev/ubuntu/lucid/php5/lucid-201002110915
Members of Ubuntu Development Team can upload to this branch. Log in for directions.

Branch merges

Related bugs

Related blueprints

Branch information

Owner:
Ubuntu Development Team
Status:
Development

Recent revisions

55. By Chuck Short on 2010-01-19

debian/rules, debian/source_php5.py: Install apport hook.

54. By Marc Deslauriers on 2009-11-30

* Merge from debian unstable, remaining changes:
  - debian/control, debian/rules: Disable a few build dependencies and
    accompanying binary packages which we do not want to support in main:
    + firebird2-dev/php5-interbase (we have a seperate php-interbase source)
    + libc-client/php5-imap (we have a seperate php-imap source)
    + libmcrypt-dev/php5-mcrypt (seperate php-mcrypt source)
    + readline support again, now that the libedit issue is fixed.
  - debian/control: Add build dependency: libdedit-dev (>= 2.9.cvs.20050518-1)
    CLI readline support.
  - debian/rules:
    + Correctly mangle PHP5_* macros for lpia
  - debian/control:
    + Rename Vcs-Browser & Vcs-Git to XS-Original-Vcs-Browser & XS-Original-Vcs-Git (LP: #323731).
  - debian/control: Move php5-suhoshin to Suggests.
  - debian/rules: Fix broken symlink for pear.
  - main/php_version.h: updated with Ubuntu version info
* debian/patches/series: Re-enable the 033-we_WANT_libtool.patch patch
* debian/patches/sybase-alias.patch: use the debian patch
* Dropped unapplied patches: fix_64bit_time.patch,
  fix-autoconf-ftbfs.patch, 027-readline_is_editline.patch,
  deprecated_freetds_check.patch, use-specific-libdb-version.patch,
  CVE-2008-5625.patch.
* SECURITY UPDATE: safe_mode bypass via tempam function
  - debian/patches/CVE-2009-3557.patch: check for safe_mode in
    ext/standard/file.c.
  - CVE-2009-3557
* SECURITY UPDATE: open_basedir restrictions bypass via posix_mkfifo
  - debian/patches/CVE-2009-3558.patch: check for open_basedir in
    ext/posix/posix.c.
  - CVE-2009-3558

53. By Chuck Short on 2009-11-06

* Merge from debian testing, remaining changes:
  - debian/control, debian/rules: Disable a few build dependencies and
    accompanying, binary packages which we do not want to support in main:
    + firebird2-dev/php5-interbase (we have a seperate php-interbase source)
    + libc-client/php5-imap (we have a seperate php-imap source)
    + libmcrypt-dev/php5-mcrypt (seperate php-mycrpt source)
    + readline support again, now that the libedit issue is fixed.
  - debian/control: Add build dependency: libdedit-dev (>= 2.9.cvs.20050518-1)
    CLI readline support.
  - debian/rules:
    + Correctly mangle PHP5_* macros for lpia
  - debian/control:
    + Use libdb-4.6-dev.
    + Rename Vcs-Browser & Vcs-Git to XS-Original-Vcs-Browser & XS-Original-Vcs-Git (LP: #323731).
  - Dropped patches:
    - debian/patches/119-sybase-alias.patch: Use Debian's patch.
    - debian/patches/fix-autoconf-ftbfs.patch: Use Debian's patch
    - debian/patches/fix-zlib-decompression: Already in upstream
  - Use the default pear/install-pear-nozlib.phar in php 5.2.11
  - debian/control: Move php5-suhoshin to Suggests.
  - debian/rules: Fix broken symlink for pear.
  - Dropped dependency on autoconf2.13.

52. By Chuck Short on 2009-10-28

debian/patches/series: Re-enable 019-z_off_t_as_long.patch. This is
causing users to have issues with zlib (LP: #451314)

51. By Chuck Short on 2009-10-23

debian/rules; Fix broken symlink preventing php-pear from working
properly. (LP: #451277)

50. By Chuck Short on 2009-10-13

* debian/control, debian/patches/115-autoconf_ftbfs.patch:, debian/series:
  Drop patch build-depend on autoconf2.13
* pear/install-pear-nozlib.phar: PHP 5.2.10 was shipped with a broken
  install-pear-nozllib.phar which caused pear to be broken. Use the
  version from http://pear.php.net. (LP: #420639)
* debian/patches/fix-zlib-decompression: Add upstream fix from 5.2.11
  fo fix zlibe.deflage compress filter to actually accept level parameter.
* debian/rules: Fix symlink for pear.

49. By Chuck Short on 2009-09-18

debian/control: Move to php5-suhoshin to Suggests

48. By Chuck Short on 2009-09-06

debian/control, debian/patches/115-autoconf_ftbfs.patch: Revert building
with autoconf2.13 since upstream has the proper fix.

47. By Mathias Gug on 2009-08-18

debian/control: Change dependencies to MySQL 5.1.

46. By Chuck Short on 2009-07-10

* Merge from debian unstable, remaining changes:
  - debian/control, debian/rules: Disable a few build dependencies and
    accompanying, binary packages which we do not want to support in main:
    + firebird2-dev/php5-interbase (we have a seperate php-interbase source)
    + libc-client/php5-imap (we have a seperate php-imap source)
    + libmcrypt-dev/php5-mcrypt (seperate php-mycrpt source)
    + readline support again, now that the libedit issue is fixed.
  - debian/control: Add build dependency: libdedit-dev (>= 2.9.cvs.20050518-1)
    CLI readline support.
  - debian/rules:
    - Correctly mangle PHP5_* macros for lpia
  - debian/patches/119-sybase-alias.patch:
    + Fix sybase regression since change to mssql. (LP: #240519)
  - debian/patches/fix-autoconf-ftbfs.patch:
    + Fixes FTBFS.
  - debian/control:
    + Use libdb-4.6-dev
    + Rename Vcs-Browser & Vcs-Git to XS-Original-Vcs-Browser & XS-Original-Vcs-Git (LP: #323731).
    + Use autoconf2.13 to build. Thanks to dreamcast4 (LP: #411890)

Branch metadata

Branch format:
Branch format 7
Repository format:
Bazaar repository format 2a (needs bzr 1.16 or later)
Stacked on:
lp:ubuntu/lucid/php5
This branch contains Public information 
Everyone can see this information.

Subscribers