lp:~ubuntu-dev/ubuntu/lucid/coherence/lucid-201002110914

Created by James Westby on 2010-02-11 and last modified on 2010-02-11
Get this branch:
bzr branch lp:~ubuntu-dev/ubuntu/lucid/coherence/lucid-201002110914
Members of Ubuntu Development Team can upload to this branch. Log in for directions.

Branch merges

Related bugs

Related blueprints

Branch information

Owner:
Ubuntu Development Team
Status:
Development

Recent revisions

19. By teresa <teresa@teresa-laptop> on 2010-01-24

closed bug in changelog

18. By teresa <teresa@teresa-laptop> on 2010-01-24

added org.Coherence.service installation fix

17. By Charlie_Smotherman on 2010-01-02

* New upstream release, summary of changes:
    - adding all necessary files to MANIFEST.in, to compensate for the
      gone 'auto-include-all-files-under-version-control' setuptools
      feature.
    - rearranging genre and genres attribute in DIDLLite - thx Caleb
    - fix face_path typo, fixes #275.

16. By Charlie_Smotherman on 2009-10-08

* Updated Rythmbox plugin from upstream trunk so the Rythmbox plugin
  broadcasts correctly. This is need due to changes in Rythmbox.
  Files updated
  - coherence/misc/Rythmbox-Plugin/upnp_coherence/__init__.py
  - coherence/misc/Rythmbox-Plugin/upnp_coherence/MediaPlayer.py
  - coherence/misc/Rythmbox-Plugin/upnp_coherence/MediaStore.py
  - coherence/misc/Rythmbox-Plugin/upnp_coherence/UpnpSource.py (LP: #435602)

15. By Charlie_Smotherman on 2009-08-24

* debian/control
  - changed package stanza to python-coherence, to provide a proper
    python-coherence package that will be installed in the global name space
    to make python-coherence accessible to upnp-inspector and other programs.
  - changed Conflicts/Replaces/Provides fields from python-coherence to
    coherence, to account for upgrade path.
* debian/rules
  - removed --install-scripts and --install-libs, so python-coherence will
    be installed into the global name space (LP: #409518) (LP: #411209)
* Added misc/Desktop-Applet/applet-coherence.1 to debian/manpages, upstream
  moved the location of applet-coherence.1.
* Bumped Standards Version to 3.8.3 no changes needed.

14. By Charlie_Smotherman on 2009-07-20

* Added Conflicts/Replaces/Provides field to debian/control to account for
  binary name change. Thx Adreas Moog Closes: #537438
* debian/install
  - install the coherence binary. Thx Adreas Moog Closes: #537439

13. By Andreas Moog on 2009-07-20

* debian/control
  - Conflicts/Replaces/Provides python-coherence as the name of the
    binary changed (LP: #401975)
* debian/install
  - install the coherence binary

12. By Charlie_Smotherman on 2009-07-05

* Removed coherence.1 from the debian dir, upstream has included it in the
  orig.tar.gz.
* Updated debian/manpages to install coherence.1.
* Removed applet-coherence.1 from the debian dir, upstream removed the applet.
* Updated debian/manpages to reflect removal of applet-coherence.1.
* debian/control
  - Removed cdbs from Build-Depends section.
  - Bumped debhelper to 7.
  - Bumped debian/compat to 7.
  - Added Build-Depends-Indep field.
  - Package now uses python-support.
  - Bumped Standards-Version to 3.8.2, no changes needed.
  - Bumped XS-Python-Version to 2.5.
  - Changed the Package: stanza to be coherence as this is a stand alone app
    and not a python module.
  - Removed python2.5 from Depends section, the Dependency on python is
    satisfied in the Build-Depends-Indep section.
  - Removed XB-Python-Version as it is not needed with python-support.
  - Changed Priority: section to extra to correct a debcheck error.
* debian/rules
  - Simplified debian/rules to take advantage of dh 7 features.
  - Coherence now installs to /usr/share/coherence in preperation for the
    python 2.6 transition.

11. By Charlie_Smotherman on 2009-05-13

* New upstream release. Summary of changes.
    - new MediaServer backends that allow access to Picasa Web Albums
    - a TestServer to easily serve and test interaction with,
        - one or more items and adjust 'upnp_class', 'mimetype'and 'DLNA-flags
        - items that are a GStreamer pipeline or an external program.
    - a new, used in parallel, D-Bus API with an 'org.DLNA' interface with the
      goal to create a common API for all UPnP/DNLA frameworks
    - support for the dlna-playcontainer URI
    - enchancements to the GStreamer MediaRenderer, supporting now
      dlna-playcontainer and SetNextAVTransportURI, and jumping to previous
      and next tracks
    - support for video items served by Ampache
    - base classes for a ScheduledRecording? service
    - some 'compatibility' adjustments for different devices
* Removed MochiKit symbolic link creation from debian/rules.
* Removed dependency on MochiKit in debian/control.

10. By Charlie_Smotherman on 2009-05-07

* debian/python-coherence.install
   - install org.Coherence.service to dbus-services. Thx Adreas Moog
     Closes: #524426
* Corrected the lintian error copyright-with-old-dh-make-debian-copyright
  by deleting/replacing (C) with the word Copyright in debian/copyright.
* Updated standards version to 3.8.1.

Branch metadata

Branch format:
Branch format 7
Repository format:
Bazaar repository format 2a (needs bzr 1.16 or later)
Stacked on:
lp:ubuntu/lucid/coherence
This branch contains Public information 
Everyone can see this information.

Subscribers