lp:~ubuntu-dev/firefox-extensions/mozvoikko.ubuntu

Created by Alexander Sack on 2009-01-13 and last modified on 2010-02-22
Get this branch:
bzr branch lp:~ubuntu-dev/firefox-extensions/mozvoikko.ubuntu
Members of Ubuntu Development Team can upload to this branch. Log in for directions.

Branch merges

Related bugs

Related blueprints

Branch information

Owner:
Ubuntu Development Team
Project:
Firefox Extensions
Status:
Mature

Recent revisions

15. By Martin Pitt on 2010-02-22

releasing version 1.0-4ubuntu1

14. By Martin Pitt on 2010-02-22

* Merge changes from Debian (LP: #493628)
* Change conflict to abrowser (>= 3.7). Closes LP: #513320
* Add optional dependency to firefox-3.6. (LP: #513320)
* Change conflict to iceweasel (>= 3.7)
* Merge changes from Debian. Closes LP: #493628
* Move Ubuntu specific changes on file mozvoikko.config to separated
  patch file patches/fix_min_version.patch
* Change Maintainer to Ubuntu Core Developers as the package is in main
* Add quilt patch system
* Add patches/fix_freebsd_ftbfs.patch via quilt to fix FTBFS bug on
  GNU/kFreeBSD. Thanks to Cyril Brulebois. Closes: #558337
* Add pkg-config to Build-Depends. Closes: #551225
* Change Standards-Version to 3.8.3
* LP: #456598 - incorrect Breaks statement forces removal
  because of newer firefox-3.5; fix install.rdf to use proper
  minVersion bounds rather than shipping a package Breaks:
  - update mozvoikko.config
  - update debian/control

13. By Alexander Sack on 2009-09-07

(merge lp:~heikki-mantysaari/firefox-extensions/mozvoikko.ubuntu-0.9.5-1ubuntu2_to_1.0-1ubuntu2)
* drop firefox-3.0 and firefox-3.1 from Depends; add 3.0 to Breaks instead.
* xulrunner-1.9.1 by default transition
  + see: https://blueprints.launchpad.net/ubuntu/+spec/desktop-karmic-firefox-3.5
    - bump minimal xulrunner-dev version
* Merge new upstream release from Debian. Closes LP: #377049
* Keep Ubuntu changes in debian/control
* Add optional dependency to firefox-3.5.
* Change conflict to abrowser (>= 3.6)
* New upstream release.
* Change conflict to iceweasel (>= 3.6).
* Change Standards-Version to 3.8.1
* New upstream release. Closes: #515505
* debian/control:
  - Improve description (thanks to Teemu Likonen)
  - Add conflict to iceweasel (>= 3.2)
* debian/rules: Remove useless LDFLAGS setting (thanks to Harri Pitkänen)

12. By Alexander Sack on 2009-01-26

* RELEASE 0.9.5-1ubuntu2 to ubuntu/jaunty

11. By Heikki Mäntysaari on 2009-01-13

Modify src/Makefile.xulrunner to use pkg-config for libxul, increase version to 0.9.5-1ubuntu2

10. By Alexander Sack on 2009-01-13

* RELEASE 0.9.5-1ubuntu1 to ubuntu/jaunty

9. By Alexander Sack on 2009-01-13

* .bzr-builddeb/default.conf:
  - add bzr builddeb hints including upstream revision info

8. By Alexander Sack on 2009-01-13

* point Vcs-Bzr: control header to ~ubuntu-dev realm
  - update debian/control

7. By Heikki Mäntysaari on 2008-12-30

Solve conflict

6. By Heikki Mäntysaari on 2008-12-30

Edit changelog to mention conflicts

Branch metadata

Branch format:
Branch format 6
Repository format:
Bazaar pack repository format 1 (needs bzr 0.92)
This branch contains Public information 
Everyone can see this information.