lp:~ubuntu-desktop/aisleriot/ubuntu

Created by Jeremy Bicha on 2011-09-26 and last modified on 2015-01-16
Get this branch:
bzr branch lp:~ubuntu-desktop/aisleriot/ubuntu
Members of Ubuntu Desktop can upload to this branch. Log in for directions.

Branch merges

Related bugs

Related blueprints

Branch information

Owner:
Ubuntu Desktop
Project:
Aisleriot
Status:
Development

Recent revisions

13. By Daniel Holbach on 2014-10-26

* Merge from debian (LP: #1385745). Remaining changes:
  - 0001-Don-t-set-ubuntu-specific-environment-variables.patch: Cherry-pick
    patch from git to not override environment variables we use in Ubuntu for
    global menus and overlay scrollbars.
* New upstream release.
* Update Homepage URL.
* Bump Standards-Version to 3.9.6. No further changes.
* New upstream release.
* Add build-dependency on appdata-tools
  - needs appdata-validate
* Use dh-autoreconf and use it for --as-needed
* debian/rules: ensure bash shell is used to avoid issues in ltmain.sh
* debian/aisleriot.install: ship usr/share/appdata
* 0001-Don-t-set-ubuntu-specific-environment-variables.patch: Cherry-pick
  patch from git to not override environment variables we use in Ubuntu for
  global menus and overlay scrollbars.
* New upstream release
  - Build-depend on dh-autoreconf
  - Set dependant version of guile-2.0-dev
* debian/rules:
  - Use autoreconf.mk
* debian/patches/no-bash.patch:
  - Remove bash check, it breaks the build
* Set pysol card themes base explicitly because configure script doesn't
  recognise raspbian.
* New upstream release
* The new version adds a workaround to the cards being invisible while
  dragged. Closes: #740315.
* New upstream release. 1:3.9.90-1
* debian/control.in:
  - Lower GTK dependency back to 3.4
  - Update homepage
* New upstream release (v3.10.0)
* New upstream release (v3.10.1)
* Bump Standards-Version to 3.9.4
* debian/control.in:
  + Bump libgtk-3-dev build dependency to 3.6, needed for
    gtk_application_get_active_window().
* New upstream release.
* debian/control.in:
  - Build-depend on desktop-file-utils
  - Recommend yelp
  - Remove obsolete libgstreamer build-depends
* debian/aisleriot.install:
* debian/aisleriot.menu:
* debian/patches/02_desktop-path.patch:
* debian/pixmaps/freecell.xpm:
  - Updated as freecell.desktop is removed
* debian/control.in: Bump Build-Deps on libgtk-3-dev (>= 3.4.0),
  libglib2.0-dev (>= 2.32.0)
* debian/watch:
  + Fixed, it wasn't tracking new versions.
* New upstream release
* debian/control.in: (Build)-depend on guile-2.0
* debian/*.install: Cards files are now stored as zipped .svg's
* debian/patches/99_format-security.patch: Dropped, applied upstream
* New upstream release.
* Update copyright to final version of the machine-readable 1.0 spec.
* Bump Standards Version to 3.9.3.
* debian/control: Build-depends on yelp-tools
* debian/copyright: Fixed a few lintian warnings
* Fix FTBFS with -Werror=format-security. (LP: #890889)
  - Add 03_format-security.patch.
* Sync from Ubuntu.
* Watch for .xz tarballs.
* Bump to debhelper 8.
* Strip debian/tmp prefix from install paths.
* Don't autoreconf, we don't need it.
* Remove Conflicts/Replaces on self-package.
* Replace versioned Conflicts with Breaks.
* Drop obsolete 03_format-security.patch in favour of upstream fix.
* Use versioned copyright Format URL.

12. By Robert Ancell on 2012-05-14

releasing version 1:3.2.3.2-0ubuntu2

11. By Jeremy Bicha on 2012-04-16

releasing version 1:3.2.3.2-0ubuntu1

10. By Jeremy Bicha on 2012-04-16

* New upstream bugfix and translation update release.
  - Fix blurry freecell icon
  - Fix freecell with guile 2.0
  - Fix potential format string crash
* debian/patches/03_format-security.patch: Dropped, applied upstream
* debian/watch: Watch for .xz tarball releases

9. By Martin Pitt on 2012-04-16

Add 00git_automake_build_fix.patch: Fix building with automake 1.11.
Patch backported from 3.3 series.

8. By Jeremy Bicha on 2011-11-16

releasing version 1:3.2.2-0ubuntu1

7. By Jeremy Bicha on 2011-11-16

* New upstream release
  - Fix missing sound effects

6. By Jeremy Bicha on 2011-11-16

[ Felix Geyer ]
* Fix FTBFS with -Werror=format-security. (LP: #890889)
  - Add 03_format-security.patch.

5. By Jeremy Bicha on 2011-10-17

releasing version 1:3.2.1-0ubuntu1

Branch metadata

Branch format:
Branch format 7
Repository format:
Bazaar repository format 2a (needs bzr 1.16 or later)
This branch contains Public information 
Everyone can see this information.

Subscribers