lp:ubuntu/wily/libstruts1.2-java

Created by Ubuntu Package Importer on 2015-05-06 and last modified on 2015-05-06
Get this branch:
bzr branch lp:ubuntu/wily/libstruts1.2-java
Members of Ubuntu branches can upload to this branch. Log in for directions.

Related bugs

Related blueprints

Branch information

Owner:
Ubuntu branches
Status:
Development

Recent revisions

11. By Hideki Yamane on 2014-05-31

* Team upload.
* debian/patches
  - add struts-1.2.9-CVE-2014-0114.patch from Red Hat to fix CVE-2014-0114
    (Closes: #745897)

10. By Emmanuel Bourg on 2014-04-07

* Team upload.
* Replaced the build dependency on libcommons-collections-java
  with libcommons-collections3-java

9. By Tony Mancill on 2014-01-18

* Team upload.
* Address FTBFS.
  - Add libcommons-ollections4-java to build-deps.
  - Update jsp-api version in ant.properties from 2.1 to 2.2.
  - Thanks to Roddy Shuler. (Closes: #733397)
* Bump Standards-Version to 3.9.5.

8. By Emmanuel Bourg on 2013-06-26

* Transition to the Servlet API 3.0 (Closes: #713195)
* Removed Michael Koch from the uploaders list (Closes: #654095)
* Updated Standards-Version to 3.9.4 (no changes)
* Use canonical URLs for the Vcs-* fields
* Removed the redundant Priority field declared on the binary package
* debian/copyright: Updated to the copyright format 1.0

7. By Torsten Werner on 2011-09-25

* Team upload.
* Add Vcs-* headers.
* Remove Arnaud and Stefan from Uploaders list.
* Switch to debhelper level 7.
* Update Standards-Version: 3.9.2.

6. By Debian Java Maintainers on 2010-04-07

[ Onkar Shinde ]
* Build/runtime dependency libservlet2.3-java -> libservlet2.5-java.
* Build dependency java-gcj-compat-dev -> default-jdk.
* Remove runtime dependencies since the package is build with lowest target
  JVM version (1.3)
* Convert patches to quilt format. Convert package to 3.0 format.
* lintian errors/warnings fixed
  - Section devel -> java.
  - Standards version 3.7.2 -> 3.8.4.
  - Remove Debian revisions from build/runtime dependencies.
  - Add ${misc:Depends} to runtime dependencies.
  - Update compat version to 5.
  - Move homepage url to Homepage field.
  - Write copyright in DEP-5 format. Remove complete text of Apache-2.0
    license.

[ Emmanuel Bourg ]
* Update of the URLs
* Rename Jakarta Commons to Apache Commons

5. By Giuseppe Iuculano on 2009-12-06

* Non-maintainer upload by the testing Security Team.
* Fixed CVE-2008-2025: Cross-site scripting (XSS) vulnerability.
  (Closes: #528352)

4. By Michael Koch on 2007-06-27

Build-Depends on java-gcj-compat-dev instead of java-gcj-compat.
Closes: #430806.

3. By Arnaud Vandyck on 2006-04-24

New upstream release Fixes three security problems: CVE-2006-1546,
CVE-2006-1547, CVE-2006-1548 (closes: #360551), thanks to Moritz
Muehlenhoff.

2. By Arnaud Vandyck on 2004-11-19

* New upstream release based on libstruts1.1.
* depends on ant (not libant1.6-java) because regexp is needed in the
  build; antlr; commons-validator >= 1.3

Branch metadata

Branch format:
Branch format 7
Repository format:
Bazaar repository format 2a (needs bzr 1.16 or later)
This branch contains Public information 
Everyone can see this information.

Subscribers