lp:ubuntu/wily-proposed/libasm4-java

Created by Ubuntu Package Importer and last modified
Get this branch:
bzr branch lp:ubuntu/wily-proposed/libasm4-java
Members of Ubuntu branches can upload to this branch. Log in for directions.

Branch merges

Related bugs

Related blueprints

Branch information

Owner:
Ubuntu branches
Review team:
Ubuntu Development Team
Status:
Development

Recent revisions

9. By Emmanuel Bourg

* Team upload.
* New upstream release
  - Refreshed the patches
  - Updated the OSGi metadata in debian/osgi
  - Updated the version in debian/libasm4-java.poms
* Standards-Version updated to 3.9.6 (no changes)
* debian/copyright: Fixed the shortname of the BSD license

8. By Emmanuel Bourg

* Team upload.
* New upstream release
* Refreshed the patches
* Updated the version in debian/libasm4-java.poms

7. By Emmanuel Bourg

* Team upload.
* Install the 4.x generic Maven artifacts to preserve the compatibility
  (Closes: #746112)

6. By Emmanuel Bourg

* Team upload.
* New upstream release
* Keep the prebuilt jars used for the tests in the source tarball

5. By Emmanuel Bourg

* Team upload.
* New upstream release
* Updated the OSGi metadata in debian/osgi
* Standards-Version updated to 3.9.5 (no changes)
* Switch to debhelper level 9
* debian/copyright: Updated the Format URI
* Use XZ compression for the upstream tarball
* debian/rules: Removed the unused gnujaxp.jar from the classpath

4. By Damien Raude-Morvan

* Upload to unstable.
* d/control: Use canonical URL for Vcs-*.

3. By Damien Raude-Morvan

d/patches/remove_bnd.diff: Re-work so that each jar only include expected
packages instead of -all.

2. By Damien Raude-Morvan

* Team upload.
* New package libasm4-java (ITP: #623950) based on libasm3-java packaging.
  ASM 4.x is need for Java 7 support (ie. for class format 51).
* d/control: Set Aditya Vaidya and myself as Uploaders.
* d/control: Import packaging in Alioth Git, so update Vcs-* headers.
* d/patches/remove-bnd.diff: Drop usage of BND to create OSGi metadata
  and use pre-generated MANIFEST from debian/osgi/.
* d/maven.rules: Replace poms version by "4.x".

1. By Damien Raude-Morvan

Import upstream version 4.1

Branch metadata

Branch format:
Branch format 7
Repository format:
Bazaar repository format 2a (needs bzr 1.16 or later)
Stacked on:
lp:ubuntu/wily/libasm4-java
This branch contains Public information 
Everyone can see this information.

Subscribers