lp:ubuntu/vivid/qgis

Created by James Westby and last modified
Get this branch:
bzr branch lp:ubuntu/vivid/qgis
Members of Ubuntu branches can upload to this branch. Log in for directions.

Related bugs

Related blueprints

Branch information

Owner:
Ubuntu branches
Status:
Mature

Recent revisions

25. By Cyril Brulebois

* Non-maintainer upload.
* Fix FTBFS with gcc 4.7 due to uncoordinated gcc-defaults switch, patch
  by Steven Chamberlain, thanks! (Closes: #673567)
  - 10_fix_gcc4.7_build.patch
* Set urgency to “high” for the RC bug fix, needed for the gdal
  transition.

24. By Francesco Paolo Lovergine

The "Sometimes they come back" release.

* Branching from Qgis tree and adapting to current Debian Policy and
  standards. The target tree is currently set to release-1.7.
  (closes: #661491, #606304, #615683, #616182, #600308)
* Policy bumped to 3.9.3.
* Moving to debhelper compatibility level 9.
* Source format is now 3.0 with quilt support.
* Merged with 2bf42287 upstream git snapshot.
* Migrated to dh_python2 instead of python-central.
  (closes: #617048)
* Snapshot in qgis.org release-1.7: c936d031
* Added an automagic creation of a lintian override for sqlite embedding.
  This is required for uploading currently.
* Added missing ${misc:Depends} to make lintian happy.
* Copyright notes updated and debian/copyright moved to format 1.0.
* More licenses notices now reported in debian/copyright. Thanks ftpmasters.

23. By Colin Watson

Switch gdal dependencies to libgdal1-1.7.0 and libgdal1-1.7.0-grass.

22. By Felix Geyer

* Merge from Debian unstable (LP: #707791), remaining changes:
  - Fix compilation issues with QT 4.7
  - Add build-depends on libqtwebkit-dev
  - Fix build failure with GCC 4.5
* Fix build failure with python-qt4 4.8
* Build-depend on python-sip-dev instead of *sip4* transitional packages.

21. By Matthias Klose

Fix build failure with GCC 4.5.

20. By Matthias Klose

Rebuild with python 2.7 as the python default.

19. By Philip Muškovac

Build-dep on libqtwebkit-dev for qtwebkit transition

18. By Johan Van de Wauw

* Merge from Debian unstable (LP: #540941).
* Fix compilation issues with QT 4.7
* Add build-depends on libqt4-webkit-dev

17. By Francesco Paolo Lovergine

[ Francesco Paolo Lovergine ]
* Fixed wrong build-deps:
 python-qt4-dev -> python-qt4
      python-sip4-dev -> python-sip4
* Added composer.dpatch that should fix some archs FTBS.

[ Paul Wise ]
* Switch to new Homepage field

16. By Steve Kowalik

* Rebuild for libgsl0 -> libgsl0ldbl transition.
* Munge Maintainer field as per spec.

Branch metadata

Branch format:
Branch format 7
Repository format:
Bazaar repository format 2a (needs bzr 1.16 or later)
Stacked on:
lp:ubuntu/wily/qgis
This branch contains Public information 
Everyone can see this information.

Subscribers